playing wma lossless from LMS to Squeezebox with ffmpeg and custom-convert.conf

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) playing wma lossless from LMS to Squeezebox with ffmpeg and custom-convert.conf

Tagged: ,

This topic contains 6 replies, has 2 voices, and was last updated by  shaunm 2 years, 3 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 21. Juni 2018 at 2:06 #36282

    I have done this successfully with PiCorePlayer, but as Max2Play as the added Access Point feature, I’m hoping to switch to Max2Play.

    I have set up Max2Play on a Pi Zero W with LMS only (ie not using a player as I have a Squeezebox Classic)
    Max2Play and LMS work with perfectly playing mp3, wav, etc
    It cannot play wma or wmal

    On PiCorePlayer the process was to instal ffmpeg & lame and created a custom-convert.conf file and I can play wmal files on my squeezebox.
    Is a similar process possible on Max2Play?

    Thanks in advance!

    21. Juni 2018 at 12:10 #36289

    Hi shaunm,

    We have not had this request yet. However, you can first check whether the option „WMA lossless“ is set to „native“ or „deactivated“ in the LMS Settings‘ advanced section for file formats.

    21. Juni 2018 at 15:04 #36297

    Thanks for the fast reply.
    To answer your question…

    WMA Lossless > FLAC Disabled
    > MP3 Disabled
    > PCM Disabled
    > WMA Lossless Native

    Thanks,
    Shaun

    21. Juni 2018 at 15:33 #36299

    Yes, you’re right. But how?

    In PiCorePlayer, I install ffmpeg and it converts the files on the fly with this custom-convert.conf file:

    wmal flc * *
    # FRB:BITRATE=-B %B}T:START=-ss %s}
    [ffmpeg] -loglevel quiet $START$ -i $FILE$ -f flac -compression-level 4-

    In Max2Play, „sudo apt-get install ffmpeg“ gives > E: Package ‚ffmpeg‘ has no installation candidate

    I have 21,000 songs, and it is a backup from my music folder on my pc, so converting the files on the hard drive is not an option.

    Thanks,
    Shaun

    21. Juni 2018 at 15:43 #36300

    Hi shaun,

    You need „sudo su“ to execute commands under root in Max2Play. But initially I meant converting them manually and not on the fly.

    21. Juni 2018 at 16:08 #36301

    I tried your suggested „sudo su apt-get install ffmpeg“, but it comes up with „No passwd entry for user ‚apt-get'“

    With my previous attempt of „sudo apt-get install ffmpeg“ it seemed to go further…
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Package ffmpeg is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or is only available from another source.

    • This reply was modified 2 years, 3 months ago by  shaunm.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here