Playback issues with pops and silence.

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Playback issues with pops and silence.

This topic contains 12 replies, has 2 voices, and was last updated by  Heiner Moderator 7 months, 2 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 28. Januar 2018 at 14:19 #33705

    Hi

    My setup is a few months old. It was working flawlessly until a few days ago when playing tracks it would go silent for a few seconds and continue before repeating the silence.

    It’s deteriorated progressively since to more silence and pops than song. I tried using a backup copy of the original install image with no change in behavior. Just further deterioration. Now it is just silence when playing tracks. All this happens while the track play indicator in squeezebox suggest a smooth play.

    I use it to stream to another Pi3 with no problems there.

    Any guidance would be most welcome. Thanks.

    I have the following set up:
    IQaudIO DigiAmp+
    PI3
    USB HDD

    Debug:
    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.1 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=IQaudIODAC -a 80:4:: -o hw:CARD=IQaudIODAC -V Digital -Q
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=IQaudIODAC -t hardware -m hw:CARD=IQaudIODAC -c Digital
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081
    LMSIP=192.168.1.116

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    dmix:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample snooping device
    hw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Hardware device with all software conversions
    default:CARD=IQaudIODAC – IQaudIODAC, – Default Audio Device
    sysdefault:CARD=IQaudIODAC – IQaudIODAC, – Default Audio Device
    dmix:CARD=IQaudIODAC,DEV=0 – IQaudIODAC, – Direct sample mixing device
    dsnoop:CARD=IQaudIODAC,DEV=0 – IQaudIODAC, – Direct sample snooping device
    hw:CARD=IQaudIODAC,DEV=0 – IQaudIODAC, – Direct hardware device without any conversions
    plughw:CARD=IQaudIODAC,DEV=0 – IQaudIODAC, – Hardware device with all software conversions

    #### SHAIRPORT (SYNC) VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####
    closed

    29. Januar 2018 at 17:22 #33736

    Hi NearTheBeach,

    Could you paste the command line options of your Squeezelite here?

    Also, could please try selectin „none“ for audio card in the IQaudIO plugin, saving, rebooting, selecting „DigiAmp+ (with unmute)“ again, saving and rebooting again.

    29. Januar 2018 at 20:05 #33739

    Thank you for coming back to me. Here is the command line option: -o hw:CARD=IQaudIODAC -V Digital -Q
    Also, I did as asked on second line with „none“ for IQaudIO plugin, save, reboot, etc with no joy.

    30. Januar 2018 at 14:45 #33754

    Hi NearTheBeach,

    If your system is running via WiFi, could you try running it on ethernet to rule out the WiFi connection as a source of error? Also if you are not using Bluetooth, please deactivate it in the Raspberry Settings.

    30. Januar 2018 at 20:04 #33763

    I did as suggested (Bluetooth deactivated. ethernet plugged in) and did a reboot to boot. No change. I also powered it off and moved the USB HDD (with the music database)to another usb port on the pi. No joy with that either.

    Could this be a hardware fault? DigiAmp? Anyway to know? Pi seems fine as it will serve the other one on the network with the music database.

    Thank you.

    31. Januar 2018 at 12:16 #33769

    What power supply are you using and what capacity are your speakers? These two factors might be an issue as well.

    You can also try running a test playback with another OS to make sure the issue is not a hardware defect.

    31. Januar 2018 at 15:33 #33774

    Thanks again. I’m using a 19v POWER BRICK (65w / 3.4amp) and Q Acoustics 3020 sold as „Perfect for the Pi-DigiAMP+ or Pi-DAC/AMP+ combination…“ supplied together with the DigiAmp+.

    I’ll try out your suggestion re os when and if i can.

    31. Januar 2018 at 23:16 #33781

    I put the iqaudio on another pi3 with max2play os and set up for it. Works fine. Could be the pi3 issue. Ill check it out when chance offers and let you know. Edit. Utterly wonderful sound by the way.

    • This reply was modified 7 months, 3 weeks ago by  NearTheBeach.
    1. Februar 2018 at 12:59 #33788

    Hi NearTheBeach,

    Thank you for the quick follow-up and the kind words 🙂

    4. Februar 2018 at 17:52 #33838

    Im using the other pi3 as it was as a client and it works fine with squeezebox. I did have to change output to hdmi and not iq. There appears to be nothing wrong with the hardware.

    7. Februar 2018 at 11:18 #33898

    Why did you change to HDMI? Were the pops gone with DigiAmp+ playback as well?

    7. Februar 2018 at 16:24 #33904

    I’m happy to answer questions and provide further information. My setup is…

    Two pi3s both controlled via orangesqueeze:

    Pi3 One:
    DigiAmp+ hat
    Max2play os
    Q speakers
    Usb hard drive (for music)
    Squeezebox server

    Pi3 Two:
    HDMI connection to TV and it’s sound bar.
    Max2play os. (DigiAmp+ still available in settings)
    Client to squeezebox on Pi3 One.

    I switched the Pi’s around and it worked.

    Noticed after that that there were ‚goings on‘ with cross fade function in orangesqueeze /squeezebox and removed the cross fade between tracks which cleared the problem.

    8. Februar 2018 at 13:36 #33911

    Hi NearTheBeach,

    First of all, thank you so much for the detailed and thoughtful response.

    If there is still an issue with your setup, please let us know.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here