Pi4-4GB in bestehendes Multiroom System einbinden

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Pi4-4GB in bestehendes Multiroom System einbinden

This topic contains 8 replies, has 2 voices, and was last updated by  MarioM Moderator 2 weeks, 1 day ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 26. Juli 2022 at 21:42 #52326

    hallo zusammen,
    Ich habe ein, seit Jahren funktionierendes, MR-System bestehend aus 3x Pi2, 6x Pi3B, 1x Pi3B+ als LMS, das ganze mit teils Wlan teils LAN in die Fritz 7490 eingebunden.

    Es funktioniert bestens, alles Synchron, auch nach zuschalten eines Players mit dem Squeeze Commander als App.

    Jetzt wollte ich einen Pi2 mit Hifiberry Amp+ durch einen Pi4B-4GB mit einer Soundblaster USB Karte ersetzen um einen Verstärker anzusteuern. Dieser Pi4 wird durch WLAN eingebunden.

    so nun kommts, der Pi alleine läuft ganz normal aber sobald ich andere Player zuschalte fängt der Pi4 an 1-3 Titel vorzuspringen und dann ist das ganze System aus dem Takt und es fängt sich auch nicht wieder, bis ich den Pi4 ausschalte d.h. im Squeeze Commander aus dem MR-System rausnehme, dann fangen sich die anderen Player wieder und sind synchron.

    ach zur Info, der Pi4 steckt in einem Geekworm Model: P173 Voll Alu Gehäuse.

    wer hat eine Idee.

    MFG Peter

    @Edit: ich hab den Pi4 nun mit LAN eingebunden und den Kernel auf 64Bit geuppt, jetzt läufts, ich hab noch versucht einen Edimax EW-7612UAn V2 anzustöpseln, bisher ohne Erfolg.

    Noch was, der Pi4 wird auf dem Webinterface oben rechts, da wo steht “ Lizenz aktiviert“ nicht als Pi4 angezeigt, Pi2 und Pi3 dagegen schon.

    • This topic was modified 3 weeks ago by  knorke007.
    • This topic was modified 3 weeks ago by  knorke007.
    • This topic was modified 3 weeks ago by  MarioM.
    27. Juli 2022 at 13:30 #52331

    Hallo Peter,

    nicht wundern warum bei dem Beitrag ein Edit von mir steht, er wurde von unserem System als Spam markiert und ich habe ihn jetzt veröffentlicht.

    Schön, dass du vorerst eine Lösung für das Problem gefunden hast. So etwas ist mir tatsächlich auch noch nicht untergekommen. Vielleicht hilft das anderen, bei denen ein ähnlicher Fehler auftritt.

    Dass der Pi 4 nicht richtig angezeigt wird ist ein Bug, den wir eigentlich mit Max2Play Version 2.55 behoben hatten. Gegebenenfalls müssen wir da nochmal reinschauen.

    27. Juli 2022 at 14:52 #52332

    hallo Mario,

    die Lösung mit LAN ist eher suboptimal denn da wo er PI4 hin soll bräuchte ich zwingend WLAN, das Alugehäuse verringert allerdings die Signalstärke und nun meine nächste Frage.

    Wie kann ich das interne WLAN und BT abschalten und den Edimax EW-7612UAn V2 einbinden, mit dem sollte die Verbindung zum Router funktionieren.

    Geht das mit sudo nano /boot/config.txt dann dtoverlay=disable-wifi und dtoverlay=disable-bt einzutragen ?

    • This reply was modified 3 weeks ago by  knorke007.
    27. Juli 2022 at 16:58 #52334

    Du kannst WLAN und Bluetooth des Pi über die Raspberry Einstellungen deaktivieren. Dazu musst du einfach nur die Haken bei den entsprechenden Checkboxen (unter „CPU-Frequenz und Grafikspeicher Einstellungen“) setzen und speichern.

    Um den Stick nutzen zu können solltest du dich noch vergewissern, dass der entsprechende Treiber (in deinem Fall RTL8192Cu, wenn ich mich nicht täusche) installiert ist.

    27. Juli 2022 at 22:07 #52335

    hi MarioM,

    ja da steht aber bei beiden Optionen Pi3, da war ich nicht sicher ob das beim 4rer genau so ist. Webinterface überarbeiten bitte.

    also ich probiere das mal.

    –Mist, der installiert den Treiber nicht >>Failed to initialize driver interface<<

    • This reply was modified 2 weeks, 6 days ago by  knorke007.
    29. Juli 2022 at 13:19 #52337

    hallo nochmal,

    ich hab hier echt ein Galama und dazu folgendes, der Pi4-4GB ist nicht als max2play hotspot zu erreichen, d.h. das erscheint gar nicht erst auf dem Smartphone, beim Pi4-8GB ist dasselbe Problem und der Edimax EW-7612UAn V2 lässt sich auch nicht einbinden, bei den Pi3ern war das p&p erledigt. beide Pi4rer sind neu.

    am Lan-Kabel sind beide sichtbar.

    Interessanterweise starten beide 4rer nicht mit der M2P Version 2.53 sondern nur mit der Version 2.56.. aber wenn ich die V2.56 von eurer Webseite Downloade und dann entpacken will erscheint die Meldung, die Zip-Datei sei beschädigt.

    alles seltsam das

    29. Juli 2022 at 20:18 #52338

    Ich gebs auf mit dem EW-7612UAn V2 Wlan Dingenskirchen,

    Ich krieg den nicht ums verrecken zum laufen.

    30. Juli 2022 at 20:31 #52340

    So nun das Schlußwort, nach (apt-get update; apt-get upgrade) und Upgrade zum letzten Kernel und Enable 64 Bit Kernel (Pi4 ONLY)

    läuft der Pi4-4 und der Pi4-8 beide mit internem Wlan trotz das der Pi in dem Vollalu von Geekworm Gehäuse sitzt, welches übrigens ein richtig gutes Gehäuse ist denn der Pi4-4 hat CPU Temp von 35° ,

    Also der EW-7612 Stick läuft nicht aber vllt is der auch im A…

    MfG Peter

    2. August 2022 at 12:15 #52342

    Hallo Peter,

    tut mir Leid, dass das so große Probleme bereitet hat. Ich könnte mir noch vorstellen, dass der Treiber für den Stick bei Stretch noch vorinstalliert war (falls du bei den Pi 3 unser Stretch Image verwendet hast) und unter Buster nicht mehr unterstützt wird.

    Super dass du einen (wenn vlt. auch nicht ganz zufriedenstellenden) Workaround gefunden hast und das integrierte Wlan der beiden Pis ausreicht.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here