Pi3 WiFi not working

This topic contains 7 replies, has 3 voices, and was last updated by  OneArmedBandit premium 3 months, 3 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 2. July 2016 at 18:36 #21068

    Trying to use the HiFiBerry image from their site (https://www.hifiberry.com/guides/hifiberry-installer/) to configure Max2Play, but it shows that the WiFi card is not seen. Ethernet connects just fine, but it seems that the Pi3 isn’t supported with their image. Is there something else I can do?

    Thanks in advance!

    4. July 2016 at 14:53 #21133

    Hi Hammerhead,
    HiFiBerry seems to be loading the old WPS image that is not fully compatible with the RPi3. Thanks for bringing this to our attention, we will notify HiFiBerry immediately and have this corrected. Meanwhile, you can head to our Download page and get our current Image based on Jessie lite which is fully compatible with the RPi3 and recognizes the WiFi module from the first boot.

    4. July 2016 at 15:16 #21135

    Thank you for your reply.

    I was able to work around it by using the HiFiBerry installer, and updating M2P via ethernet. However I found that the wifi connection isn’t very stable and dropped out a lot, which means I had a lot of trouble trying to connect to my Qnap NAS running Emby. I then tried to install gmediarenderer but that didn’t work either. Sorry to say, after about five or six attempts at flashing and reconfiguring, I went with OpenELEC and Kodi which finally got me up and running. A very impressive combination of DAC, FLAC and Tech when it finally works right. 😉

    I would like to make another try at M2P, though. Tomorrow I plan to buy another card, and will experiment further. My original goal was to use MediaMonkey because of its very robust tagging and playlist functions. Unfortunately it doesn’t run on Pi, so I got frustrated and decided to get at least something working for the time being.

    Looking forward to working further on this with your help. If there’s anything you’d like me to try, I’m at your service.

    • This reply was modified 3 months, 3 weeks ago by  Hammerhead.
    4. July 2016 at 16:16 #21146

    Hi Hammerhead,
    These issues are probably caused by the wrong base image being loaded for RPi3 by the HiFiBerry installer. Please download one of the images from our download page that says it is compatible with the Raspberry Pi 3, burn it with a tool like the WinDiskImager32, expand the filesystem in “Settings/Reboot” and you should be fine.

    4. July 2016 at 16:41 #21151

    I’ll give that a try later this week. Most stores are closed today for our national holiday, and I have beer to drink. 🙂

    If you have any thoughts on how to get MediaMonkey working on Pi, I can tell you for sure that you’d have a lot of fans. There are many, many calls for that functionality. It’s reported to work on WINE, but I have no knowledge of this sort of stuff, so I’m at a loss.

    • This reply was modified 3 months, 3 weeks ago by  Hammerhead.
    5. July 2016 at 14:44 #21210


    Not sure if it’s still the case but the early RaspBian images for the RPi3 had wifi power management turned on by default which caused this unstable and bad working Wifi. I don’t know if max2play fixed that in their image (can’t check now) but it sounds like you were suffering from that.

    You can check this by running:

    And look for: “Power Management:”

    You can change it by running the following to see if it makes a difference:
    sudo iwconfig wlan0 power off

    If it does, here’s more info on how to make it permanent http://www.modmypi.com/blog/disable-wifi-power-management but I’m sure max2play will (or have already) make it default in their image.

    Funny, I’m slowly moving away from OSMC and OpenELEC because I want more then “just Kodi” and I prefer more flexibility 😉


    6. July 2016 at 3:17 #21231

    I’ll give that a look.

    Would there be any difference between the M2P Kodi install and the HiFiBerry install?

    So, if you’re abandoning OpenElec and Kodi for more flexibility, what are your plans? Curious to know.

    9. July 2016 at 18:33 #21402


    I’m not abandoning Kodi, I’m gradually moving away from OSMC in favour of max2play.

    A while back I tried OpenElec and OSMC and ended up settling with OSMC on a RPi3 in both the living room and the bedroom (can’t remember why I chose OSMC over OpenElec but I don’t think there was much difference).
    When I got an interest in having multi-room audio I found and tried squeezelite which does run on OSMC as well but is not supported (because OSMC is fully aimed at Kodi).

    I’m moving towards max2play because of the flexibility and plugins like jivelite and bluetooth and I like to tinker with things myself.


Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here