[FIX INSIDE] Pi3 and HiFiBerry Amp 2 produces no sound with Max2Play

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions [FIX INSIDE] Pi3 and HiFiBerry Amp 2 produces no sound with Max2Play

This topic contains 10 replies, has 4 voices, and was last updated by  Heiner Moderator 3 weeks, 2 days ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 22. October 2017 at 14:10 #32040

    After struggling to make my new Pi3/HiFiBerry Amp 2 work with WiFi under the Roon ready iamge provided by HiFiBerry, they advised me to try Max2Play and use the Squeeze mode on Roon.

    I used the Max2Play web configurator to chose the HiFiBerry Amp 2 and provide the WiFi settings. The Amp 2 indeed works under WiFi and shows under Roon as a network device. So far so good. However the only sound I’m able to control is via the HDMI output. The Amp 2 remains silent.

    The setup seems jinxed, because with the HiFiBerry Roon image I only have sound from the Amp 2 on wired connections. With Max2Play I do have a WiFi connection, but no sound from the Amp 2.

    Help is much appreciated. I’ve purchased a 1 year license for Max2Play and did a donation ;-]

    Thx, wim

    • This topic was modified 1 month ago by  wimvans.
    • This topic was modified 3 weeks, 5 days ago by  Heiner.
    24. October 2017 at 12:48 #32061

    Hi wim,

    First of all, thanks for the support. It’s much appreciated.

    To your issue, please check whether your selection of the HiFiBerry AMP2 is also set in Squeezelite, in the Audioplayer menu. Furthermore, you should have volume sliders in the HiFiBerry menu. Also, please remove the autostart from Shairport to rule it out as a source of error and remove the tick from the Access Point Autostart Mode in the WiFi/LAN menu.

    24. October 2017 at 18:08 #32076

    Hi Heiner,

    Squeezelite was selected in the Roon player. I’m also able to control the HDMI sound by means of the Roon player.

    Squeezelite is running in the Audioplayer. The volume sliders are indeed available in the Hifi Berry Amp 2 menu. I removed the autostart from Shairport and deactivated the Accespoint Autostart Mode. But still no sound coming from the Amp2…

    Would it be possible that my Pi3 has a different version number and is therefore behaving differently. I consider myself to be able to activate WiFi on the Roon ready HiFiBerry diskimage, but haven’t been able to. And now Max2Play also doesn’t function as predicted.

    Thx for looking into this.

    • This reply was modified 4 weeks, 1 day ago by  wimvans.
    • This reply was modified 4 weeks, 1 day ago by  wimvans.
    25. October 2017 at 9:44 #32088

    Hi wimvans,

    We are not really familiar with Roon, so I have to ask whether you installed the Squeezebox Server and checked whether you can play a random radio station from the Logitech Media Server interface. Please install version 7.9, if you have not done it, yet.

    Also check the advanced options of the Squeezelite player to make sure that the sound card selection for output has “…hifiberry…” in its name. (Should be “sysdefault[…]hifiberry[…]”)

    26. October 2017 at 14:22 #32126

    I think I have the same problem with my Amp2.
    It is setup as HiFi Berry Amp2 on Max2play under the HiFiBerry menu and under Squeezelite in the advanced options it is set as “sysdefault – snd_rpi_hifiberry_dacplus, – Default Audio Device, CARD=sndrpihifiberry”
    In Squeezebox (logitech media server) I can select the device and play music but I get no sound from the AMP2. I have another setup going using the Amp+ and this works perfectly.
    One bit that does seem odd is that back in the Max2Play config under the Raspberry Settings, in the dropdown under where it says:

    “The following DACs/AMPs are supported. Just choose the one that you want to enable and click save. After Reboot you may find more options (e.g. volume settings) for your selected soundcard on this page.”

    There is not an option for the AMP2 listed only the HiFi Berry Digi/Digi+.
    I do not have any other players installed on the devices. Been at this for 2 nights now and can’t think where I am going wrong.

    26. October 2017 at 22:16 #32133

    @heiner, I’m not familiar with Squeezebox server. Installed it on the Pi3, opened an account and now I’m completely lost what to do where. Now the server is running on the Pi3. Where is the Logitech Media server interface running and what has all this to do with Roon?

    I’m afraid I’m drifting further away from what I intended to do. All this started with a Pi3 Roon ready image from HiFi Berry and an AMP 2 that is somehow not able to work with WiFi. Some people seem to manage it and others like me don’t. HiFi Berry pointed me to Max2Play as a possible solution, but this brings new complexities. I suggest we leave it here and I will try to sort this out with HiFi Berry.

    Thanks, wim

    26. October 2017 at 23:51 #32138

    I am also having this issue where squeeze server seems to be playing back audio to the lite player but AMP2 is producing no audio. Audio works fine in YMPD though so it is working just not with squeezeserver and lite player.

    Can you help?

    27. October 2017 at 11:37 #32148

    Hi guys,

    Sorry about the confusion.

    The driver is not yet added to the Raspberry Settings overview. Selecting it in the HiFiBerry Plugin is the recommend way to go.

    After reboot you should get the right drivers. In Audioplayer menu, make sure that Squeezelite is running successfully with a process and that “sysdefault – snd_rpi_hifiberry_dacplus, – Default Audio Device, CARD=sndrpihifiberry” is selected.

    The one issue I experienced while setting it up, is that we now automatically set the hardware volume control in the command line options (in Squeezelite’s advanced options) to “hw:0” which only works with the built-in audio is deactivated. You can do this in the Raspberry Settings. If you do not have a premium license or do not do deactivate the built-in audio, you either:

    Option 1:
    Remove the command line options from Squeezelite’s Advanced Options and click “save”
    -> NO Hardware Volume Control anymore!

    Option 2:
    Change the hw:0 to hw:1 OR deactivate build in audio in the Raspberry Settings
    -> Hardware Volume Control remains

    Thanks for pointing us towards this issue, we will find the best fix for this as soon as possible and I will make sure everybody encountering this gets the solution they need.

    For now, these options are your best bet. Please let me know whether you would prefer Hardware Volume Control to be set right after selection, or whether you would rather want it to be optionally available as a later addition?

    • This reply was modified 3 weeks, 5 days ago by  Heiner.
    27. October 2017 at 19:07 #32161

    Thanks for the info, I took the steps you mentioned and it now works perfectly!

    27. October 2017 at 19:31 #32162

    I have premium license and disabling onboard audio worked perfectly thank you

    30. October 2017 at 17:32 #32211

    Thanks for the feedback. We have now added a notice to the configuration for this issue. Automatically, it now sets up hw:1 for new setups in our most current beta.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here