Pi Zero W, wifi DHCP issue

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Pi Zero W, wifi DHCP issue

This topic contains 9 replies, has 2 voices, and was last updated by  yakelkun 3 months, 1 week ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 8. June 2017 at 18:57 #29426

    Hello,

    I start my new Pi Zero W with Max2Play.

    Wifi SSID : Getout3
    The DHCP server, serve 192.168.1.100~199

    Wifi is detected :

    iw dev
    phy#0
    Interface wlan0
    ifindex 2
    wdev 0x1
    addr b8:27:eb:36:9e:87
    ssid Getout3
    type managed
    channel 10 (2457 MHz), width: 20 MHz, center1: 2457 MHz

    Something I noticed when On/Off the wifi :

    sudo ifdown wlan0
    [email protected]:~ $ sudo ifup wlan0
    Successfully initialized wpa_supplicant
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    mount error(16): Device or resource busy
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

    But wlan0 gets up anyway :

    wlan0 Link encap:Ethernet HWaddr b8:27:eb:36:9e:87
    inet adr:192.168.3.1 Bcast:192.168.3.255 Masque:255.255.255.0

    Note:
    i added an usb+lan hub, and the lan0 gets the good adress via DHCP :
    eth0 Link encap:Ethernet HWaddr 00:e0:4c:53:44:58
    inet adr:192.168.1.100 Bcast:192.168.1.255 Masque:255.255.255.0

    Can you help me please.

    • This topic was modified 4 months, 1 week ago by  yakelkun.
    9. June 2017 at 9:20 #29439

    I changed the router and selected wifi thru webui succesfully using scanning function…

    But same résult :

    [email protected]:~ $ ifconfig
    eth0 Link encap:Ethernet HWaddr 00:e0:4c:53:44:58
    inet adr:192.168.1.100 Bcast:192.168.1.255 Masque:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:461 errors:0 dropped:2 overruns:0 frame:0
    TX packets:309 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 lg file transmission:1000
    RX bytes:42035 (41.0 KiB) TX bytes:46080 (45.0 KiB)

    lo Link encap:Boucle locale
    inet adr:127.0.0.1 Masque:255.0.0.0
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:362 errors:0 dropped:0 overruns:0 frame:0
    TX packets:362 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 lg file transmission:1
    RX bytes:35718 (34.8 KiB) TX bytes:35718 (34.8 KiB)

    wlan0 Link encap:Ethernet HWaddr b8:27:eb:36:9e:87
    inet adr:192.168.3.1 Bcast:192.168.3.255 Masque:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:68 errors:0 dropped:0 overruns:0 frame:0
    TX packets:92 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 lg file transmission:1000
    RX bytes:17348 (16.9 KiB) TX bytes:28762 (28.0 KiB)

    [email protected]:~ $ iw dev
    phy#0
    Interface wlan0
    ifindex 2
    wdev 0x1
    addr b8:27:eb:36:9e:87
    ssid GetOut
    type managed
    channel 1 (2412 MHz), width: 20 MHz, center1: 2412 MHz

    So it’s not related to the router (who works flawlessly by the way with lots of devices)

    Any clue please ? Or a way to use static IP…

    9. June 2017 at 11:28 #29442

    I give it a try to volumio with the very same hardware.

    Minutes after I selected the same wifi network, one reboot later and it was working like a breeze.

    So there must be a configuration problem with Max2Play and the Pi Zero W…

    13. June 2017 at 12:35 #29531

    Hi yakelkun,
    Did you use the most current version of Max2Play? We got to test the Zero W just a few days ago and made it compatible with an update right after.

    The WPS connection takes a little time.

    13. June 2017 at 13:46 #29532

    Hello,
    I online updated Just before testing the Pi ZW.

    I dont use WPS as résultat date so-so in my experience.
    I use m2p gui to choose thé correct wifi succesfully enter the password.
    BUT I get always the same wrong 192.168.3.1 ip adress,

    • This reply was modified 4 months ago by  yakelkun.
    15. June 2017 at 19:36 #29552

    Any clue please ?

    19. June 2017 at 11:24 #29597

    Hi yakelkun,

    Have you checked on your router, whether the Pi connects right and why it is assigned that IP?

    The Max2Play WiFi GUI is just a simple output of the Pi WiFi interface. Have you made a tick at “load WiFi Interface”?

    19. June 2017 at 11:41 #29602

    Have you checked on your router, whether the Pi connects right and why it is assigned that IP?

    this [email protected] doesn’t come from my DHCP. Note that I tried on two different routers with the same problem. both router serves 192.168.1.x+20 and y+20.

    Changing just the sdcard with v.l.m.o distribution and the Pi Zero gets the correct [email protected] on both routers.

    Yes load wifi interface is ticked, GUI allow me to find the different ssid available at my location, so wifi interface is up, but I don’t understand why it continuously get this 192.168.3.1 adress…

    5. July 2017 at 13:45 #29811

    Hi yakelkun,

    Unfortunately, this seems to be related to your home network, as we have never heard of this issue with any other M2P user. Please check under a different network to make sure the image is not the source of error. If the issue remains on a different network, please burn a fresh image.

    6. July 2017 at 14:48 #29844

    Dear,
    chances that x2 different wifi router (different brand) with different network settings (different dhcp server) are causing the same error on the very same device are against odd, and moreover against statistic…

    Nevertheless I’ll make a fresh install and keep you informed.

    Note that my plateform is a Pi Zero W, the latest model with embeded wifi. Maybe an issue on the driver….

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here