Pi Zero W Accesspoint Setup problem

Max2Play Home 2016 (en) Forums Max2Play Add-ons Pi Zero W Accesspoint Setup problem

This topic contains 10 replies, has 2 voices, and was last updated by  Heiner Moderator 4 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 2. June 2017 at 14:40 #29212

    Hi,

    I have a Pi Zero W setup and I have (using the Raspberry Settings plugin)
    Update Kernel
    Update Packages

    I have then downloaded the Bluetooth and Accesspoint plugins.

    They all seem to have installed correctly and I am using the WiFi OK to connect the Pi Zero W to my home WiFi LAN.

    My problem is that I am not seeing the stand alone SSID (max2play) appearing for me to connect to.
    (I also tried the nl80211 driver (although the default seemed to work OK))
    The debug information is
    #### DNSMASQ Installed ####
    Status: install ok installed

    #### HOSTAPD Installed ####
    Status: install ok installed

    #### WiFi Interface Installed ####
    2

    #### DNSMASQ Running ####
    5 S 116 756 1 0 80 0 – 1999 – ? 00:00:00 dnsmasq

    #### HOSTAPD Running ####

    Can you please help me solve this.

    [Note I have had a Pi3 working with your Accesspoint quite satisfactorily]

    6. June 2017 at 13:16 #29277

    Hi Fred,
    We are currently solving an issue with the Zero W which should also help solve yours. I will update you tomorrow.

    For now, please try deactivating both BT and AP to make sure they are not the source of error.

    6. June 2017 at 13:19 #29279

    Thank you.

    7. June 2017 at 12:34 #29333

    Hi fred,

    Our update is now out. Please update your system.

    7. June 2017 at 14:20 #29339

    Hmm!!
    When I run Settings/Reboot
    “Update MaxPlay”
    I get
    ——————————-
    Running Check for Plugin Updates and install if available
    Max2Play is up to date – no update required
    —————————————-
    Fred

    7. June 2017 at 14:51 #29342

    Hi Heiner
    In case I misunderstood,
    I have also tried the “Update2Beta Max2Play”
    Version Beta-170523
    Raspberry PI
    …….and this too does not solve the problem.
    Fred

    9. June 2017 at 13:49 #29455

    Hi Fred,

    You have to deactivate the WiFi interface with a tick in the WiFi/LAN menu, save, then shutdown the device, remove the power supply and reattach it. Afterwards the AP should be accessible. However, we currently do not see the use for a Zero Wireless AP setup. What do you use it for?

    9. June 2017 at 15:36 #29479

    Hi Heiner,

    OK I will try your instructions and report back.

    As for uses for a Zero Wireless AP setup, I have 2

    The first can be seen from my write-up of a project here https://community.wd.com/t/will-wd-be-releasing-a-1tb-wd-node-zero-w/203662/3
    (If you want I can supply a copy of my project write-up for your site too)

    The second was for some friends I have who live in rural Ireland without access to the internet. They wanted to be able to have a
    Wireless router/ DHCP server, Access Point in their house so that they could connect up their modern electricals to see each other. I provided them with a Pi Zero and a Micro USB Wifi adaptor, installed Kodi/Libreelec and turned on the AP facility in that to provide an Access Point. This is working fine for them. A Pi Zero W would do this without having to have the USB WiFi adaptor. I prefer your web based Pi configuration capabilities and would like to do this using Max2Play.

    Hope this helps

    Fred.

    • This reply was modified 4 months, 1 week ago by  fredhopper.
    9. June 2017 at 16:02 #29480

    Hi Heiner,

    Yes, your instructions work and I now have a standalone mode AP working on the Pi Zero W music player.
    However, a question, I understood that on the Pi3 and Pi Zero W, the WiFi chip could act as an AP and connect to a WiFi router at the same time.
    Is this the case and if so is it possible using the Max2Play plugin? (reason – one could then (when at a know Wifi Connection point) get internet radio. (obviously one would have to deselect the “standalone mode”).

    Fred

    9. June 2017 at 16:20 #29481

    picture of the Pi Zero w AP enabled Music centre

    hope I have managed to do this image share correctly.

    Fred

    15. June 2017 at 18:40 #29542

    Hi Fred,

    We have not tried this setup yet and did not know it was possible. But you can try a solve from this thread: https://raspberrypi.stackexchange.com/questions/63841/rpi-zero-w-as-both-wifi-client-and-access-point

    Please report your results with your Zero W here, if you try it.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here