Pi Zero mit tp-link wlan-stick funktioniert nicht

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Pi Zero mit tp-link wlan-stick funktioniert nicht

This topic contains 8 replies, has 2 voices, and was last updated by  Quasinix premium 3 years, 7 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 22. März 2018 at 17:52 #34665

    Hallo Zusammen,
    ich habe einen pi zero über usb2-Ethernet-Adapter am laufen. Hatte gedacht, über Wlan-Stick wäre es noch praktischer und habe flux … irgend einen … Wlan-Stick gekauft. Tuts natürlich nicht! Ist ein TP-Link TL-WN823N. Kann man da irgendwas machen? Einen Treiber installieren oder einen anderen Trick anwenden?

    Viele Grüße

    Quasinix

    22. März 2018 at 21:06 #34672

    Hallo nochmal,
    ich habe gerade einen Beitrag gesendet der nicht erscheint …

    Hier habe ich eine Anleitung zum Installieren des Treibers für den Stick gefunden. Leider scheitert es bei mir schon beim sudo apt-get install raspberrypi-kernel-headers Ich bekomme dabei eine Fehlermeldung:

    Entpacken von raspberrypi-kernel-headers (1.20170703-1) ...
    raspberrypi-kernel-headers (1.20170703-1) wird eingerichtet ...
    run-parts: executing /etc/kernel/header_postinst.d/dkms 4.9.35+
    : Unable to find an initial ram disk that I know how to handle.
    Will not try to make an initrd.
    run-parts: executing /etc/kernel/header_postinst.d/dkms 4.9.35-v7+
    : Unable to find an initial ram disk that I know how to handle.
    Will not try to make an initrd.
    

    Ich würde mich sehr freuen, wenn jemand eine Idee dazu hätte 🙂

    Viele Grüße

    Quasinix

    Viele Grüße

    Quasinix

    22. März 2018 at 21:08 #34673

    Hm, der Link ist nicht reingekommen … hier nochmal in Klartext:

    „https://blog.junaid.site/2017/07/11/tl-wn823n-driver-in-raspberry-pi-2-b/“

    Viele Grüße

    Quasinix

    26. März 2018 at 15:17 #34741

    Hi Quasinix,

    Könntest du den Stick nochmal mit einem frischen Stretch Image versuchen zu laden? Die meisten Sticks sollten automatisch erkannt werden, sobald sie eingesteckt wurden. Du kannst dies prüfen im Debug Info Fenster. Dort sollten sowohl wlan0 als auch wlan1 auftauchen. Bitte deaktiviere auch wlan0 in den Raspberry Settings.

    26. März 2018 at 23:07 #34769

    Hallo Heiner,
    Danke für deine Antwort. Mit Stretch Image meinst Du ein normales aktuelles Image? Ich versuche es die Tage noch mal. Wie gehe ich da am besten vor? Weil das wlan nicht direkt funktioniert hatte, habe ich an dem usb port des zero einen hub angeschlossen und daran den Ethernet und den wlan Stick angeschlossen. Reicht der Strom aus? Oder ist besser ein Bildschirm mit Tastatur?
    Viele Grüße Quasinix

    27. März 2018 at 10:18 #34788

    Hi Quasinix,

    Versuche bitte vorerst unser Automatic Access Point Setup mit deinem WiFi Stick. Anleitung

    27. März 2018 at 22:37 #34832

    Hallo Heiner,
    das Automatic Access Point Setup funktioniert nicht. Auch nicht mit dem Strech Image.

    Habe dann über einen USB Hub den wlan- und den ethernet-Adapter angeschlossen. In den WLAN und LAN Einstellungen steht dann oben: Status: WLAN Adapter status ist nicht aktiv.

    Wenn ich versuche irgendwelche Einstellungen bei WLAn zu Speichern bekomme ich oben in dem Statusfenster angezeigt:
    Debug: Saving WPA-Supplicant (Successfully initialized wpa_supplicant rfkill: Cannot open RFKILL control device Could not read interface wlan0 flags: No such device WEXT: Could not set interface ‚wlan0‘ UP wlan0: Failed to initialize driver interface )

    – Wahrscheinlich schlucken WLAn-STick und Ethernet-Adapter zusammen zu viel Strom. Ich weiß aber nicht, wie ich das herausfinden kann.
    – Wenn beides zusammen auf dem USB-Hub läuft: muss ich nicht doch evtl. einen Treiber für den Stick TP-Link TL-WN823N installieren?

    In jedem FAll: Erstmal evelen Dank für die Hilfe 🙂

    Gute Nacht
    Quasinix

    28. März 2018 at 11:10 #34838

    Hi Quasinix,

    Stromprobleme bei Auslastung der USB-Schnittstellen ist in der Tat ein Problem mit dem Raspberry Pi.

    Ist der Hub mit externer Stromquelle? Wenn nicht, bitte einmal ziehen und nur mit Stick versuchen die Automatic AP Sequenz zu folgen.
    Ist dein Netzteil 2.5A?

    28. März 2018 at 11:40 #34840

    Hallo Heiner,
    Die AP Sequenz hatte ich schon ohne Hub versucht. Der Hub hat keine eigene Stromquelle und das Netzteil hat 2.5A.

    Auch hatte ich die WPS-Taste bei Start-Methode versucht. Auch ohne Hub. Alles ohne Erfolg.

    Hm, wahrscheinlich komme ich ohne USB Hub mit Stromversorgung nicht weiter. Alternativ könnte ich einen Monitor und eine Tastatur anschließen. Die Tastatur wäre dann aber auch wieder am Hub. Die schluckt aber wahrscheinlich weniger Strom als ein Ethernet-Adapter.

    Viele Grüße

    Quasinix

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here