[SOLVED] Pi Zero mit Hifiberry Dac+ zero Device and Mixer

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Pi Zero mit Hifiberry Dac+ zero Device and Mixer

Tagged: 

This topic contains 4 replies, has 3 voices, and was last updated by  anesthesia premium 8 months, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 11. February 2017 at 16:45 #26838

    Hi Alle,

    ich habe ein Problem bei der Einrichtung eines Hifiberry Dac+ zero zusammen mit einem aktuellen Zero. Installiert ist das max2play image V2.41.

    Welches Device muss ich im HifiBerry plugin von max2play korrekterweise eintragen? Es stehen 4 DAC Devices zur Wahl, keines davon scheint spezifisch für meinen Hifiberry Dac+ zero. Diese Devices gibt es im installierten Image für die DAC Reihe von Hifiberry:

    1. Hifi Berry DAC (PI A/B)
    2. Hifi Berry DAC+ light (B+ / PI 2/3)
    3. Hifi Berry DAC+ (B+ / PI 2/3)
    4. Hifi Berry DAC+ pro (B+ / PI 2/3)

    Unter dem Device 1. kommt keine Sound (bereits probiert), momentan habe ich das 2. Device aktiviert, Hifi Berry DAC+ light (B+ / PI 2/3). Resultat:

    Es kommt zwar sound, aber

    a) ich habe das Gefühl, die Qualität im Vergleich zu meinen anderen HifiBerry DACs ist deutlich schlechter (dies kann aber auch einfach systembedingt sein) und
    b) Das Gerät tauch nicht im amixer auf. Allerdings wird es mit aplayer angezeigt:

    [email protected]:~ $ aplay -l
    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: ALSA [bcm2835 ALSA], Gerät 0: bcm2835 ALSA [bcm2835 ALSA]
    Sub-Geräte: 8/8
    Sub-Gerät #0: subdevice #0
    Sub-Gerät #1: subdevice #1
    Sub-Gerät #2: subdevice #2
    Sub-Gerät #3: subdevice #3
    Sub-Gerät #4: subdevice #4
    Sub-Gerät #5: subdevice #5
    Sub-Gerät #6: subdevice #6
    Sub-Gerät #7: subdevice #7
    Karte 0: ALSA [bcm2835 ALSA], Gerät 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0
    Karte 1: sndrpihifiberry [snd_rpi_hifiberry_dac], Gerät 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
    Sub-Geräte: 0/1
    Sub-Gerät #0: subdevice #0

    Und nun kommt:

    [email protected]:~ $ amixer -c 1

    -> keine Anzeige, der Gegentest mit einer Reihe von weiteren PIs (A+) mit verschiedenen Hifiberry DACs und einem AMP zeigt bei amixer -c 1 alle möglichen alsa mixer Einstellungen an.

    Hat jemand eine Idee, woran es liegt? Ich vermute, es ist das falsche device, aber welches wäre das korrekte?

    thanks

    16. February 2017 at 17:19 #26983

    Hi Marc,
    Wie bereits im anderen Thread erwähnt, versuche bitte die Option “HiFiBerry DAC”.

    16. February 2017 at 20:23 #26997

    Hallo Heiner,

    danke für die Rückmeldung. Wie ich aber schrieb, kam bei dem Versuch mit HiFiBerry DAC gar kein Sound. Ist es sicher dieses Device?

    Marc

    22. February 2017 at 18:24 #27136

    Hi Marc,
    Entschuldige die späte Rückmeldung und die bestehenden Probleme. Laut HiFiBerry ist dies in der Tat der richtige Treiber (https://support.hifiberry.com/hc/en-us/articles/205377651-Configuring-Linux-4-x-or-higher) für

    DAC for Raspberry Pi 1/DAC+ Light/DAC Zero/MiniAmp

    11. March 2017 at 13:03 #27574

    Hallo, bei mir gehts mit diesem Treiber. Allerdings habe ich den Onboard Sound deaktiviert und im Squeezelite einen anderen Treiber einstellen müssen, plughw. Mit default oder sysdefault war es auch stumm.

    • This reply was modified 8 months, 2 weeks ago by  anesthesia.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here