[SOLVED] Pi-hole Adblocker

This topic contains 16 replies, has 11 voices, and was last updated by  justinj 1 month, 1 week ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • 18. Dezember 2016 at 14:50 #24970

    Hi,

    the pi-hole adblocker would be a great plugin to have:

    Home

    Cheers,
    Andreas

    11. Februar 2017 at 15:34 #26837

    I absolutely subescribe to that proposal – pi hole addon would be great

    15. Februar 2017 at 14:58 #26939

    Dear volderette,

    Thank you for your suggestion, we will pass this suggestion to our development team and then consider it.

    Regards
    Mohammad Mbydeen

    25. April 2017 at 7:49 #28460

    +1 !!!!

    To install manually we need to change web interface port to to use other than 80. Any other change?
    Thanks in advance.

    Best Regards,

    6. Mai 2017 at 11:03 #28731

    Another vote here please. At this stage I’ll need to purchase another pi just for pi hole.

    https://discourse.pi-hole.net/t/max2play-on-rpi-doesnt-like-pi-hole/370/9

    9. Mai 2017 at 20:00 #28768

    I installed pihole manually and so far it’s running ok.

    First I changed the max2play web interface to port 81 to free it for pihole use.
    To do it edit file /etc/apache2/ports.conf and change listen port 80 to 81:

    Listen 81

    Also edit file /etc/apache2/sites-enabled/max2play.conf and change port 80 to 81:

    <VirtualHost *:81>

    Restart and you can access max2play interface in port 81.

    Now install pihole using install command:

    curl -sSL https://install.pi-hole.net | bash

    And that’s all. Pihole at port 80 and max2play at port 81.

    Hope this helps
    Best Regards,

    10. Mai 2017 at 1:38 #28772

    Thanks very much for this. I’ll give it a go tonight.

    11. Mai 2017 at 3:08 #28787

    Works perfectly thanks. Very happy. Working with readonly files so need to open vi with sudo and save with :wq!

    11. Mai 2017 at 7:41 #28788

    I’ve found a small problem. Reboot button stop working because max2play code assumes that server will work only in port 80. So when you press reboot max2play tries to open:

    http://SERVER_ADDR/plugins/max2play_settings/controller/Basic.php?action=reboot

    and not:

    http://SERVER_ADDR:SERVER_PORT/plugins/max2play_settings/controller/Basic.php?action=reboot

    Seems a easy to fix issue for max2play developers.

    Best Regards,

    6. November 2018 at 17:19 #41852

    Hi, ich habe es nach der Anleitung von yonesmit gemacht. Leider kommt jetzt anstelle der Myx2play Oberfläche auf Port 81: 403 – Forbidden

    You don’t have permission to access / on this server.
    Was hab ich anders gemacht? Irgendwelche Rechte? Ich habs mit root Rechten installiert…
    Gruß
    Christoph

    19. November 2018 at 18:33 #42135

    „Seems a easy to fix issue for max2play developers.“

    Did the issue get fixed?

    19. November 2018 at 21:10 #42136

    /etc/apache2/ports.conf

    /etc/apache2/sites-enabled/max2play.conf

    On macOS I neither find the “ports.conf“ nor the “sites-enabled“ direction? Help would be much appreciated.

    20. November 2018 at 11:54 #42146

    Hi Berlinmalte,

    Use „sudo su“ when in SSH to get root rights.

    Regarding the „fix“, we cannot change ports for this as it would create dependencies for other services. Since it is an easy fix for people wanting to add Pi-Hole, we suggest manually doing if you want to follow yonesmit’s instructions.

    1. April 2019 at 12:35 #44936

    Hallo,
    kleiner Tip am Rande, mit dem Befehl nano anstatt edit file kam ich persönlich besser klar.

    Bei mir läuft Pi-Hole parallel zu Max2Play, die Ports sind wie oben beschrieben auf 81 geändert. Der Raspberry kann auch über LMS angesteuert werden. Einziges Problem ist, dass ich nicht mehr auf die Benutzeroberfläche von Max2Play komme, auch wenn ich hinter der IP-Adresse :81 setze… pi hole erreiche ich über /admin problemlos… gibt es einen Trick?

    15. Mai 2019 at 22:22 #45410

    Any news on this?
    I do run 2 Pi, one for pihole and one for Max2Play.
    I’m tempted to try to get them both on one, but I know I’ll spend hours on it and it won’t work because I’ve done something stupid!
    A plugin would be fantastic.

    29. Mai 2019 at 9:57 #45496

    Hi TJH,

    We’ll evaluate possibilities and challenges of Pi-Hole Plugin in the coming weeks.

    9. Juni 2019 at 10:16 #45640

    As good as Pihole is, MAX2PLAY is a media platform and I think we need to restrain from having all these other non-media related addons/plugins/extras added into it as it only causes bloat and more work for devs. As time is limited for everyone, that means that time would be taken away from some other task/bug fix that actually effects the media portion of M2P. As mentioned above, if you want Pihole (Let’s face it, it’s not something a lot of people will know how to setup even if it were a click to enable plugin) you can install it yourself as you have full access to your entire system.
    The other alternative is Pi’s are cheap, you can run it on a second Pi so as not to slow down any media related functions that might possibly introduce jitter in the M2P distribution.

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.

Register here