Pi does not boot anymore after I set up an additional partition on boot device

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Pi does not boot anymore after I set up an additional partition on boot device

This topic contains 4 replies, has 3 voices, and was last updated by  Boba premium 1 year, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 28. Juli 2019 at 20:22 #46510

    Hi there,

    By using dd I created a SSD from the SD Card for using with my Raspi 3B+.
    Everything is working fine, but the most space on SSD is unused 🙁
    So I came up with the idea to set up an additional partition as storage for MP3 files.
    Since I’ve done this, my Raspi doesn’t boot anymore. When it shows the 4 Raspberrys (as a symbol for the processor cores) ist hangs up, only the green LED flashes in a steady rhythm.
    I have no idea, what is the reason for this Behaviour.

    Regards,
    Norbert

    29. Juli 2019 at 18:15 #46523

    I tried diffrent things, but nothing is working…

    – First I’ve maked a 1:1 copy of the SD card to the SSD by using a Linux dd (plugged by using a SATA to USB adaptor) – this is working well.
    – Then I created a third partition (ext4) by using an ubuntu laptop – Raspi doesn’t boot anymore
    – Now I’ve maked a new copy from SD card to SSD and booted the Raspi. On console of my Pi I’ve maked a new partition by using cfdisk – reboot goes wrong.
    – At third, I’ve maked a new copy again and booted the Pi well. Then, I’ve increased the existing ext4 partition and tried to boot the Raspi – no way…
    At last I’ve tried to disable boot device check at boot time by editing cmdline.txt: fsck.repair=no

    Nothing helps me to boot from SSD and using the full space of it…

    Does anyone have an idea?

    Thanks,
    Norbert

    29. Juli 2019 at 18:55 #46525

    OK, I think, I know the reason for this. By copying the SD card to the SSD device, the UUID will be inherited.
    If I change something on partition table, the UUID will be overwritten.
    I’ve adjusted this on cmdline.txt but this solves not my problem completely. Raspi starts booting, but I get lots of errors beginning by „failed to start remount of root and kernel file system“

    30. Juli 2019 at 11:59 #46537

    Hello Norbert,

    While do not recommend booting from USB and do not offer support for it, there is a previous discussion about the topic on here:
    Boot from usb stick

    8. August 2019 at 21:54 #46708

    Hello Norbert
    I made a copy from the SD to the SSD with a program called „Roadkil`s DiskImage Version 1.6“.
    For 32Gb SD the program ran 45minutes.
    Afterwards i copied the ISO with DiskImager to a blank SD (240 GB).
    Then I did a first boot with raspi 3B+. Everthing worked fine.
    Afterwards I did a shutdown (sudo shutdown -h now)
    I put the SSD on my Laptop via USB an formated the unused space with partionwizzard (free Version) to EXT4 with name „Daten“
    then:
    sudo mkdir/mnt/daten for the new space
    check also sudo nano /etc/fstab -> I used for the mounting the max2play html gui in tab „file System mount“

    my Settings:
    ##USERMOUNT
    UUID=fdf7a0af-2c14-d601-f0b5-a0af2c14d601 /mnt/daten ext4 defaults,nofail,iocharset=utf8
    /dev/sda4 /mnt/daten ext4 defaults,noatime 0 1

    [email protected]:~ $ sudo blkid
    /dev/sda1: LABEL=“boot“ UUID=“DF02-C322″ TYPE=“vfat“ PARTUUID=“ee397c53-01″
    /dev/sda2: UUID=“28590797-4810-4851-b4ec-bf9672c2918c“ TYPE=“ext4″ PARTUUID=“ee397c53-02″
    /dev/sda4: UUID=“fdf7a0af-2c14-d601-f0b5-a0af2c14d601″ TYPE=“ext4″ PARTUUID=“ee397c53-04″
    /dev/sda3: PARTUUID=“ee397c53-03″

    [email protected]:~ $ lsblk
    NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
    sda 8:0 0 223,6G 0 disk
    ├─sda1 8:1 0 41,8M 0 part /media/usb0
    ├─sda2 8:2 0 29,1G 0 part /media/usb1
    ├─sda3 8:3 0 195,3M 0 part
    └─sda4 8:4 0 194,3G 0 part /mnt/daten

    best regards

    • This reply was modified 1 year, 3 months ago by  Boba.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here