permission denied when mounting samba share

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions permission denied when mounting samba share

This topic contains 10 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year, 6 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 4. März 2019 at 12:44 #44634

    hi,

    I am trying to mount a share from my NAS via the Filesystem Mount page but get the following error messeage:

    mount error(13): Permission denied Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Mountpoint NOT added! Please refer to the description below!

    If I do the same thing on the command line, it works fine

    [email protected]:~# mount //GOOFY/MP3 /mnt/mp3 -t cifs -o user=xbmc,password=test123
    [email protected]:~#

    When trying to mount from max2play, dmesg shows the following:

    [ +0.028811] Status code returned 0xc000006d STATUS_LOGON_FAILURE
    [ +0.000026] CIFS VFS: Send error in SessSetup = -13
    [ +0.000027] CIFS VFS: cifs_mount failed w/return code = -13

    I am using max2play 2.47 on a Raspi.

    Regards

    Clemens

    4. März 2019 at 15:53 #44640

    Hi Clemens,

    Which version of cifs are you using on your NAS?

    4. März 2019 at 15:58 #44641

    Hi,

    I am using samba 4.5.12-Debian (the one that comes with Debian 9.6).

    Regards

    Clemens

    4. März 2019 at 16:40 #44643

    Hi Clemens,

    Try removing the value vers=1.0.

    Please also share the values you previously entered with the login obscured.

    4. März 2019 at 16:44 #44644

    Hi,

    This is what the debug info says:

    //GOOFY/MP3 /mnt/mp3 cifs user=xbmc,password=“test123″

    it is already without vers=1.0 and yet it does not work.

    The same thing on the command line works.

    The password is of course not the real password.

    Regards

    Clemens

    4. März 2019 at 17:30 #44645

    Hi Clemens,

    If you did not have it included, please try doing so.

    Please also follow the help section’s advice:

    Options (user, password and other options for network share): e.g. user=name,password=pass,sec=ntlm,iocharset=utf8,vers=1.0
    important: always add to the options sec=ntlm! With cifs mounts, always include vers=1.0!

    Should look like this:
    //GOOFY/MP3 /mnt/mp3 cifs user=xbmc,password=“test123″,sec=ntlm,iocharset=utf8,vers=1.0

    4. März 2019 at 18:22 #44648

    Hi,

    Sorry, I forgot to mention: this was the first thing I tried. It did not work.
    However, using these options it also does not work on the command line. If I change from sec=ntlm to sec=ntlmssp it works on the command line, but not from the web interface.

    Regards

    Clemens

    5. März 2019 at 11:14 #44656

    Did you create a new login for this share? Could you try using without any special characters to rule this out as a source of error (if you haven’t)?

    5. März 2019 at 19:27 #44666

    I have no idea why, but after a reboot it worked.
    Thanks for your help.

    6. März 2019 at 11:24 #44672

    glad to hear! 🙂

    I’ll mark the topic solved.

    6. März 2019 at 11:24 #44673

    glad to hear! 🙂

    I’ll mark the topic solved.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here