Odroid XU4 – Attached USB drive switches port on power down

Max2Play Home 2016 (en) Forums Max2Play Add-ons Odroid XU4 – Attached USB drive switches port on power down

This topic contains 3 replies, has 2 voices, and was last updated by  Teetertank premium 1 month, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 9. February 2016 at 4:16 #18412

    I have been using Max2play as a Squeezebox server with great success apart from a recurring issue with my USB drive which is attached directly to the USB port(s) on the Odroid XU4. I normally leave the Odroid on all the time but if I need to switch it off for a time it will often change the allocated port that the USB drive is connected to or loose the drive completely. If I try physically swapping the USB cable for the hard drive into a different port it sometimes finds it again, sometimes not. I have tried reinstalling the operating system a number of times to try to remedy this or out of necessity as LMS can no longer register the hard drive at all no matter which USB connector I plug the drive into.

    I have tried ticking the box to: “Set fixed Mountpoint to prevent directory switching on reboot:” when clicking save after selecting the tick box I get the following error message in the Filesystem – mount network paths section on the web page:

    sudo: unable to resolve host OdroidXU4
    Mountpoint NOT added! Please refer to the description below!

    Can anyone advise if I am doing anything wrong, or is this a bug in the system? I’d love to get this resolved as it’s really frustrating when the USB drive disappears completely. It usually starts on USB1 then changes to USB0 then it can be found on USB and then it will never come back and I need to re-flash the operating system and the cycle starts again.

    In case it matters my USB hard drive has two partitions: one with general back-up data and the other with my music library. Each partition seems to get allocated to a separate drive. When it shows up in LMS I point the music library to the one that contains my music library, eg:

    My Passport in /media/usb0 (Device /dev/sda1 with UUID 4E1AEA7B1AEA6007)
    Set fixed Mountpoint to prevent directory switching on reboot: Save
    Music Library in /media/usb1 (Device /dev/sda2 with UUID AEFA0C58FA0C1F69)
    Set fixed Mountpoint to prevent directory switching on reboot:

    Many thanks.

    1. March 2016 at 17:57 #18950

    Hi Teetertank,

    I did a lot of testing to reproduce your setup, but did not find anything going wrong. The mountpoints where loaded correctly. I added a “unmount” option to the latest Max2Play-Beta (available from 2.28 in regular Max2Play) that lets you unmount the USB-storage before unplugging it.

    One important note: I always use a powered USB-Hub when connecting hard-drives via USB as the power-supply of the Odroid XU4 might not be strong enough to handle the external hard drive. If you directly connect your hard drives this might be the problem.

    10. September 2016 at 22:16 #22978

    Hi,

    I am still having the same issues with USB hard drives becoming undetected and not found in LMS after a reboot/power down.

    I have three Odroids: XU4, U3 and U3+ and have experienced the same issues with each. I have tried with two different USB drives too.

    I noticed in your last reply that you recommended using a powered USB hub. Previously I ad hard drives connected directly. So as this problem is still persisting I bought this week a powered USB3 hub with as strong external power supply. Unfortunately when rebooting Max2Play the hard drive disappears and LMS can not see it.

    I have obviously tried ticking the ‘Set fixed Mountpoint to prevent directory switching on reboot‘ but doesn’t seem to work for me.

    Other than this issue, the system seems excellent as a Squeezebox server. I notice others have reported similar issues too. If there was a means to solve this it would be perfect.

    I hope there can be some development in this area. If there is any more information I need to provide to assist this, please let me know.

    Thanks.

    18. February 2017 at 18:06 #27012

    After numerous fresh installations and frustrating hours I am happy to report that I now have a reliable hard drive mount point!

    When I tried installing a fresh copy of the latest operating system and connecting my USB hard drive, I had the usual difficulties of the drive not being recognised but there was an indication in the yellow box at the top of the screen that there was a problem. I had never seen this warning come up previously. I think it was something in the latest Ubuntu 16.04 version. I don’t remember the exact message but it advised to run check disk or something, I wish I could remember the exact message but it was about a month ago now.

    So I plugged USB drive into Windows PC and ran the recommended fix (I think it was check disc). Since running the fix my USB drive has always been recognised by Max2play even after a reboot.

    I now even removed the USB hub and connect portable drive direct to Odroid and drive is still recognised and powers up fine and does not randomly get forgotten or not recognised after power down.

    My only problem now is that the dive won’t spin down once it starts up. Other than that the system is now rock solid as a Squeeze box server and am so much happier.

    Hope the Windows drive fix may help others with similar issues.

    Please let me know if there is a fix to make the drive spin down, it used to work on the old system fine.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here