No volume on IQaudIODAC

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI No volume on IQaudIODAC

Tagged: 

This topic contains 4 replies, has 2 voices, and was last updated by  MarkE 4 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 22. September 2020 at 13:55 #49735

    I have been running Max2Play for many years with no problems and have had an IQAudio DAC+ for at least a couple of years. Now, suddenly, I have no volume from the DAC. In trying to resolve this, I attempted to update Max2Play which failed. I also attempted to update the OS (wheezy) which also failed as did my attempt to upgrade it to jessie (at least) by changing the relevant apt source files as per Raspberry Pi instructions. don’t know if these issues are related, but the important thing is that I have no sound from the DAC. Otherwise Max2Play is working fine with my Squeezebox devices.
    In alsamixer I am unable to adjust the digital output from 0 and playing a wav file produces no sound. I have not changed any of the settings and have checked the configuration as per the IQAudio manual. The diagnostics imply that the DAC is present and correct. I have also checked the sound with some headphones in case it was a problem with my speakers.

    Any ideas in relation to any of these issues would be most welcome.
    Thanks.

    EDIT PS the Pi is a model 2

    • This topic was modified 4 weeks, 1 day ago by  MarkE.
    23. September 2020 at 10:56 #49741

    Hi Mark,

    Please burn our current stretch image onto the SD card and set up your system again. We are currently developing primarily for the Pi 3 and Pi 4, so older models may have problems with the latest updates. Please let us know whether the new image works for you.

    23. September 2020 at 11:33 #49742

    Thanks. I was thinking similarly – including maybe upgrading to a Pi 4, which I assume will work with the IQAudIO DAC+. Any recommendations you have re hardware/software config would be useful.
    EDIT – actually I’ll do a separate post re the config and how best to fit it into my existing set-up.

    • This reply was modified 4 weeks ago by  MarkE.
    23. September 2020 at 12:09 #49743

    Hi Mark,

    The IQaudIO DAC+ should definitely work with the Pi 4. The Pi 4 is especially recommended for use as a server, as it is equipped with more RAM than the Pi 3 (at least the versions over 1GB). Apart from that, the Pi 4 can be set up with Max2Play just like the Pi 3 or older versions. All it needs is the newer buster image, which is currently in beta. Nonetheless, all features should work normally and we try to fix any occurring bugs as soon as possible.

    23. September 2020 at 23:41 #49746

    New image works fine, so at least that proves the DAC is OK. The only difficulty is that I had several other applications on the Pi which I will need to re-install manually.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here