No sound – Raspberry Pi Zero with IQaudio Pi-DACZero

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI No sound – Raspberry Pi Zero with IQaudio Pi-DACZero

This topic contains 1 reply, has 2 voices, and was last updated by  Heiner premium 3 months, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 14. July 2016 at 18:00 #21536

    I’m having problems getting sound on a Raspberry Pi Zero with the IQaudio Pi-DACZero. I’m trying to set up a multi-room configuration. I already have a Raspberry Pi 3 with a IQaudio Pi DAC+. This is running SqeezeBox Server and is working really well.

    On the Zero, I’m using the m2p_default_226_wps.img image and updated to Max2Play version 2.33 using the max2play web interface. I couldn’t use either m2p_rpi3_default_232.img or the m2p_rpi3_iqaudio_232.img mage because I couldn’t get a wifi connection (using the WPS button on my router).
    I see and select the IQaudio Pi DAC+ sound card in Raspberry Settings. Save and reboot. 3 problems:
    1. I cannot save the 3 volume controls. I set them all to 100% and click Save. But they all return to 0. there is also a lot of feedback in the interface starting: “Usage: amixer [command]”
    2. I do not see the IQaudio Pi DAC+ sound card in the Audio Player > Advanced Settings > Soundcard drop-down
    3. I cannot start Squeezelite. Two errors are shown:
    [17:21:54.470360] test_open:294 playback open error: No such device
    [17:21:54.471010] output_init_common:381 unable to open output device

    Kind regards

    19. July 2016 at 17:32 #21665

    Hi Mike,
    I will answer your request here for the benefit of the community since your comment is on our general information page on how to support Max2Play.
    I recreated your setup today, using a fresh 2.26 WPS image and unfortunately did not encounter any of your issues.

    If you have somewhere deviated from my procedure, please try a new setup with my steps.

    1 burn the image default WPS 226
    2 connect the pi with the new image inside to power supply
    3 activate WPS on your router
    4 access the web interface with http://max2play/
    5 expand the filesystem
    6 reboot
    7 activate your premium license
    8 update the max2play system (under Settings/Reboot) to 2.33
    9 activate the IQaudIO DAC+ selection under Raspberry Settings
    10 reboot

    You should then be able to change the volume controls and find the IQaudIO selection in your Audio Player. Also, the two boost options only recognize either 0 or 100, meaning on or off. We will make this more clear in a future update.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here