No sound on RPI3+AMP+M2P

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner premium 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 10. November 2016 at 23:12 #23869

    I am not getting sound through my Raspberry Pi anymore. When I first set it up it worked fine, but after I shortened the cables and played around a bit with the settings I can’t get it to produce sound anymore. After many attempts I today heard a very loud click in one of my speakers and I’ve heard that twice now.

    I have:
    – rebooted and reinstalled the image a few times
    – went back to the standard settings
    – disabled build-in audio
    – only Shairport running (not Squeezelite or any other player)

    Any thoughts on what might be the problem here?

    14. November 2016 at 15:17 #23904

    Hi wouthermans,
    Please try out different speakers to rule out yours as a source of error.
    Also, what do you have selected in the advanced options of your shairport player?

    14. November 2016 at 22:03 #23909

    Hi Heiner, I just checked my speakers on another source and then they work fine.
    In the advanced options of shairport player I have “soundcard equel-equel,” And for the rest haven’t filled in anything here.

    Any other idea?

    15. November 2016 at 16:51 #23913

    If you are using a sound card, please select it in the Raspberry Settings. If you are not using one but instead the built-in audio jack, please select sysdefault – bcm2835…

    15. November 2016 at 20:18 #23917

    I’m using the Hifiberry Amp+ and I had this set already. I’ve also disabled build-in audio on RPI3.

    Could the power supply be the problem here? I’ve bought a new 18V 13W power supply and it worked when I first set it up, so it would be a bit weird if this would be the problem.

    17. November 2016 at 15:15 #23937

    That might be the problem, however, crucial is the Ampere of your power supply. The recommended one by HiFiBerry has 3,3 A at 18 V (resulting in ca. 60 Watt). We sell one that can achieve at least 72 Watt. Do you have a more powerful supply to test in order rule out this source of error?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here