No Sound On Headphones With IQaudIO Pi-DAC+

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions No Sound On Headphones With IQaudIO Pi-DAC+

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner Moderator 8 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 10. Januar 2018 at 1:25 #33334

    Hi,

    I have set up Max2Play on a Raspi 3 with the 7″ Raspi-Display and the IQaudIO Pi-DAC+. The Max2Play plugins Raspberry settings, RPi Display, IQaudIO, Audioplayer, Squeezebox Server, Jivelite and Bluetooth are also installed. But unfortunately, at least on the headphone jack of the sound card, I don’t get any signal. I have not yet been able to test the RCA sockets. But whether I’m streaming the sound from my smartphone to the Squeezebox server via the Raspi Bluetooth interface or whether I’m using Jivelite to access my music collection directly, I don’t hear anything in the headphones. Not even a crackle when I plug the jack plug into the socket. But the green diode of the Pi-DAC+ lights up. And Jivelite seems also to play the songs I want. Do you have any idea what else can I try?

    Thanks in advance an best regards,

    • This topic was modified 8 months, 2 weeks ago by  drundanibel.
    12. Januar 2018 at 17:26 #33379

    Hi drunadibel,

    Do you have both Squeezelite and Shairport running? Please check the advanced options to make sure only the one you want to use has „sysdefault-…“ selected as sound card.

    13. Januar 2018 at 23:02 #33395

    Hi Heiner,

    thanks for your reply.

    You mean the advanced settings in the Audioplayer tab, right? In fact, both options were active at the same time. So this can’t work at all? However, it also didn’t help to stop one of the two services (and deactivate the autostart entry). Even after restarting the Raspi, the symptoms are still the same. In the meantime I could also check the RCA outputs: No signal here either.

    As I said, I don’t even hear a crack or scratch when I insert the plug into the socket (neither with the jack nor with Cinch). Would that be normal if only the software is not configured correctly? How can I check if the card is working correctly in general?

    Thanks again and best regards

    • This reply was modified 8 months, 2 weeks ago by  drundanibel.
    15. Januar 2018 at 13:51 #33439

    Please deactivate the build-in audio in Raspberry Settings (and add this parameter ot the command line options:-o hw:CARD=IQaudIODAC -V Digital -Q). Please also try using different audio streams (online radio) for test playback.

    Furthermore, please try running a fresh image (you can easily make a back-up with Max2Play) and only selecting the sound card as your first step to make sure the problem is isolated. We will try to recreate it in our testers.

    15. Januar 2018 at 22:36 #33464

    Hi Heiner,

    thanks for your advice. Can you please tell me exactly where to enter the comman line options?

    Thanks and best regards

    16. Januar 2018 at 17:24 #33481

    In the Audio Player menu -> Squeezelite’s Edit Advanced Options -> Command Line Options

    After testing the RCA sockets and making sure the issue is always connected to the sound card (try selecting the Pi’s own audio jack), you can consider contacting the shop you got it from via email (if it’s us, use [email protected]) for further steps.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here