No sound from internet radio using Hifiberry AMP+

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI No sound from internet radio using Hifiberry AMP+

This topic contains 4 replies, has 2 voices, and was last updated by  Heiner Moderator 1 month, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 2. October 2017 at 11:18 #31650

    Hi
    I have a three Raspberry Pi setup. The Pi3 that runs Squeezebox Server has a Hifiberry Digi+. The other two are Pi2 that has Hifiberry Amp+.
    The problem is I cannot get any sound when playing the tunein radio on the two Pi2 that has the Hifiberry Amp+. I can play music on the Pi2 from a hard drive attached to the Pi3 Server and can play radio and music files on the Pi3 Server but just not on the Pi2 that has the Hifiberry Amp+ attached. Iam using LMS

    Where can I start looking for this problem?

    Here is the debug file from one of the Pi2 —
    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.2 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o default:CARD=sndrpihifiberry -a 80:4:: -o hw:0 -V Master
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=1
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal – Equalizer for plughw:0,0
    headphonesplug
    bs2b
    headphones
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_amp, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_amp, – Default Audio Device
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_amp, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_amp, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_amp, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_amp, – Hardware device with all software conversions

    #### SHAIRPORT VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: MMAP_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 22050 (22050/1)
    period_size: 441
    buffer_size: 1764

    #### OUTPUT SOUND DETAILS CARD 1 ####

    2. October 2017 at 16:23 #31661

    Hi CB672,

    What radio channel did you try?

    Are your Pi 2’s connected via ethernet or WiFi?

    Have you tried synchronizing the Pi3’s stream with the other two? If so, what were the results?

    2. October 2017 at 18:02 #31662

    Hi Heiner

    I am using wired connections. I did some more playing around and found a lot of other radio stations that play on both the Pi Players. The radio station I was trying to play is 94.7 | 947 (Top 40/Pop) based in South Africa. I noticed that the bitrate is 64k, the other stations that I could play on both players were either 48k or 128k. Seems like there could be a problem with the 64k bitrate. I have synchronised the players with no problems.

    Thanks
    Clyde

    5. October 2017 at 12:18 #31688

    Hi Heiner

    Any update as to why some radio stations do not play through the the Raspberry Pi using the Hifiberry Amp+? I tried setting up the Pi with the Amp+ as a Server but still have the same issues.

    Thanks
    Clyde

    5. October 2017 at 17:42 #31717

    Please try adding the hardware volume control.

    HW volume is -o hw:0 -V Master if you do not have built-in audio activated.

    You can also check the parameters list to see whether adding another might help your situation: https://www.max2play.com/en/wiki/command-line-options-for-squeezelite/

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here