No Output from Wolfson Card

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI No Output from Wolfson Card

This topic contains 10 replies, has 3 voices, and was last updated by  nickc premium 3 months, 3 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 16. April 2016 at 17:24 #19794

    I have a R Pi with a Wolfson Audio Card.

    Under Raspberry Pi Settings, I have selected the Wolfson Option and saved it. Under Change Sound Output. I have selected the Line Output option and saved it.

    After rebooting, the Wolfson Card is shown in the sound card options but the output option is blank.

    Under AudioPlayer I have disabled Shairport. There are no Wolfson card options shown.

    Sound still comes from the R Pi Headphone Jack.

    Have I missed something?

    21. April 2016 at 12:45 #19884

    Hi Sabreur,
    Which image and version of Raspberry Pi are you using? Also, what options are available for output after you have activated the Wolfson and rebooted?

    22. April 2016 at 20:17 #19914

    Hi Heiner,

    I used m2p_Jessie_wps229.img

    Under Raspberry Settings

    Soundcard box shows Wolfson Cirrus Logic (kernalchange)

    Wolfson Audiocard box is blank
    dropdown menu has Playback to Headset, Playback to Lineout, Playback to SPDIF, Playback to Speakers.

    After selection SAVE the box is still empty

    Under AUDIOPLAYER – Advanced Options

    Soundcard is set to plughw-bcm2835 ALSA, bcm2835 ALSA -Hardware device with all software conversions CARD=ALSA Dev=0

    25. April 2016 at 15:19 #19951

    Hi Heiner,

    It is the Original Wolfson for the Pi B not the later Cirrus Logic version.

    27. April 2016 at 15:35 #19983

    Hi Sabreur,
    The Jessie-Image is not compatible with the old Wolfson Card since it needs a kernel change which would break the Jessie system. Please use one of the Wheezy-based images, e.g. m2p_default_226_wps.img, on our Download page:

    28. April 2016 at 2:41 #19987

    I reinstalled everything from scratch with a wheezy image and realised I had been using the wrong driver. I went back to the Jessie version and now that is working, too. Not got time to do any further testing as the day job is calling. I’m going to be away for 10 days or so, I’ll pick this up then but it does look like it was fingure trouble on my part! Sorry for putting you to all this trouble. Let’s hope I can get Kodi running.

    Thanks for your help.

    4. July 2016 at 17:41 #21164

    I’ve come to the forum for a solution to the same problem. I’m using the CirrusLogic card with v 2.26 of Max2Play on a Pi B+. I have not updated since installing the image. I’ve bought a licence and activated it, installed the advanced Raspberry settings and tried to configure the CirrusLogic soundcard. I have a screen attached and I noticed after saving the Cirrus card under Raspberry settings there’s the following in the log:

    [info] Loading kernel module snd-bcm2835.
    [ 13.974000] snd-rpi-wsp sound: ASoC: CODEC DAI wm5102-aif1 not registered
    [ 14.0164131] snd-rpi-wsp sound: Failed to register card: -517

    The second two lines then repeated.

    When I “Change Soundoutput for Wolfson Audiocard” and choose “Playback to headset”, then save, I get:

    ” amixer: Control hw:sndrpiwsp open error: No such device

    …. {repeated 9 times}

    Updated Alsa Settings ”

    Playing a sound file I hear it played through my screen speakers via hdmi, but nothing on my headphones plugged into the Cirrus card.

    I know the card is ok as I’ve had it working with HiassofT’s patch for LibreELEC. But I tried the Max2Play image as it promised straightforward functionality with the Cirrus Card, as well as more advanced options. But no such luck in my case.

    What next?

    5. July 2016 at 12:14 #21179

    Hi nickc,
    Firstly, we would recommend that you update your system since it might also include a patch for your issues. Secondly, if that does not change the output, check if your card is in slot 0 or slot 1. You can see this by clicking the debug info in the Audio Player menu. Depending on the cards position, then enter either “hw:0,0” or “hw:1,0” in Squeezelite’s command line options.

    5. July 2016 at 23:23 #21228

    Hi Heiner,
    Thanks for your advice. It turns out that the card wasn’t properly seated in its connector strip! Doh! I realised it must be something like that when I tried it again with the LibreELEC image and found it no longer working with that either. Once I got it properly connected again Max2Play recognised it and I was able to configure it successfully, as shown in the logs after each save and reboot.

    However – I’ve yet to hear any sound from it! I’ve enabled headphone and line out from the card and have headphones plugged into it. I’ve enabled DLNA and am using BubbleUPnP on my android tablet as a controller. BubbleUPnP sees Max2Play DLNA and accepts it as a renderer, but when I play a track from music in my NAS hosted library, there’s no sound in the headphones. It’s getting late now and I’ve only tried the once, so I’ll do some more reading in the forum and try again tomorrow before I post back.

    6. July 2016 at 12:54 #21254

    I’m pleased to report that output from the CirrusLogic card now works fine. I don’t know what the problem was last night – possibly an issue with BubbleUPnP or the NAS server, but this morning the sound came rich and sweet from both headphones and line out. Brilliant! Thanks for this software!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here