[SOLVED] No Hifiberry in Kodi

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] No Hifiberry in Kodi

This topic contains 11 replies, has 2 voices, and was last updated by  TubeFX premium 1 year, 1 month ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 14. August 2017 at 16:12 #30616

    Hello

    My Max2play does play with the hifiberry Dac+ on my Raspberry Pi 3 card.
    But when I use Kodi it does not show up in the audio settings.
    Only the Pi’s analog option and HDMI.
    What is going wrong here???

    15. August 2017 at 16:03 #30642

    Hi TubeFX,

    Please diable build-in audio in the Raspberry Settings menu.

    Please also have a look at our wiki on Kodi: https://www.max2play.com/en/wiki/kodixbmc/

    16. August 2017 at 11:41 #30656

    Dear Heiner, Thank you , I did exactly what you wrote here.
    Stil no hifiberry in Kodi…led is on and its playing in my other set up with volumio!!!
    What kan it be???

    Tubefx

    16. August 2017 at 14:09 #30661

    Hi TubeFX,

    What options do you get after deactivating the build-in audio?

    16. August 2017 at 14:25 #30663

    pi:HDMI
    pi:Analoque
    Pi:HDMI and Analoque
    AlSA:Default(bcm2835AlSA2835)

    Kodi is playing only from the Pi: headphone out.
    Led on the Hifiberry is on though.

    16. August 2017 at 14:54 #30664

    Did you select your HiFiBerry card in the HiFiBerry menu or in the Raspberry Settings yet?

    16. August 2017 at 15:08 #30666

    Yes I did

    In Hifiberry settings i have Dac+ (pi 2/3)
    In Raspberry pi settings I have also Hifiberry Dac+ (pi 2/3).

    I have nothing else running besides this than Kodi and settings/reboot

    17. August 2017 at 9:22 #30674

    Hi TubeFX,

    Please select „none“ as sound card, reboot, select your HiFiBerry again, reboot and check again.

    This issue has always been related to deactivating the build-in audio. If you had not done a reboot after deactivation, please do so before following the instructions above.

    17. August 2017 at 10:37 #30679

    I am sorry to say that after those instruction stil no changes in Kodi!!
    Everything else is oké and I stop when I use Kodi, so nothing else is going .
    I also treid to install Kodi again.

    Very strange , bc the led on the Hifiberry is on and it plays wonderfull, only not in Kodi!!!

    17. August 2017 at 14:04 #30681

    Indeed very strange, this forum is full of threads with the same issue and the solve was always to disable the build-in audio.

    Please also make sure to disable Squeezelite and any other audio player to rule it out as a source of error.

    Also, could you share a screenshot of your settings page for audio output?

    18. August 2017 at 9:15 #30688

    I can but I don’t know how???
    I can make a screenshot but I cannot get it in this window here???
    No kopie/cut or paste?????

    How?

    Tubefx

    18. August 2017 at 12:08 #30690

    Happy to say that it’s al working now.
    What have I done?
    I wrote a new .img from hifiberry installer.
    After boot up an M2P update and boot again.
    I have a older version of Kodi now (isengard) but it is playing music now over the Hifiberry output!!!!!

    Case closed!!!

    Tubefx

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here