No audio of Kodi until a Kodi stop/start (USB-DAC)

Max2Play Home 2016 (en) Forums Max2Play on ODROID U3/C1 No audio of Kodi until a Kodi stop/start (USB-DAC)

This topic contains 12 replies, has 4 voices, and was last updated by  Nojelc 8 months, 2 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 6. January 2016 at 15:03 #17593

    Hi,
    I have reported the early stages of this issue in the Slimserver forum and some upgrades and fixes made the issue less problematic, but didn’t fixed for good.
    I’m using LMS and Kodi on a U3 bord with a Hardkernel USB-DAC for Squeezelite output, hdmi for Kodi. There were perfectly working until necessary Max2play upgrades for Kodi15(I don’t remember versions). After that upgrades Kodi has sometimes no audio. I had to restart Kodi, reboot a few times, sometimes upgrade Max2play to get audio at first. Then a few upgrades/fixes came and problem happened less, a reboot cured it most of the time.
    Now I can report the problem still exist for me after every reboot but a “stop Kodi-wait 5 seconds-start Kodi” procedure always fixes the issue.
    I hope you can check the autostart process and fix this issue like in the old versions.
    Best regards,
    Murat

    1. February 2016 at 12:10 #18274

    Hi Murat,

    thank you for your post. Are you still having trouble with your U3 and the latest Kodi version?

    You could try out the following solutions:

    Solution 1:
    Do a beta update and reinstall Kodi (the package hosted on our website)

    Solution 2:
    Log into the console (with SSH) and enter the following command:
    rm -R /usr/lib/arm-linux-gnueabihf/mesa-egl/

    Unfortunately, it is not possible for us to check every USB-DAC available and we don’t have tested the Hardkernel USB-DAC so far. If the audio output is still unstable, it could be related to compatibility issues.

    Maximilian from Max2Play

    1. February 2016 at 12:47 #18279

    Hi Maximilian,
    I still have the problem, sometimes less, sometimes more often.

    It’s fair that you cannot check every USB-DAC, but this is original Hardkernel USB-DAC. I was thinking that you have it.

    — I’m on 2.27 stable at the moment. I will install and keep updating beta for a while to test.
    — I have compiled and using Kodi 15.2 from Owersun’s github.
    — Actually there is no /usr/lib/arm-linux-gnueabihf/mesa-egl/ on my install.

    Can a delay option for Kodi at startup help for this problem?

    4. February 2016 at 18:56 #18382

    Dear Maximilian,
    I have installed beta without improvement, but I did some start/restart and different card setup tests and I think I have found something that may be can help.
    If kodi starts before squeezelite with this setup, kodi is starting with usb dac as audio device and fails to produce HDMI audio.(Kodi’s sound comes from amp’s squeezelite connections, from usb dac)
    If I stop Kodi and start squeezelite, after that start Kodi everything goes well.
    I believe it can be solved if Kodi checks squeezelite before starting or at least if Kodi has an optional dumb delay.

    1. March 2016 at 15:23 #18904

    Hi,
    I’m now on Beta-160301 and the problem still exists. Most of the times I still need to stop/start Kodi after a reboot, to have sound working.
    Is there a chance that you can at least add a delay option to Kodi tab like in Squeezeserver tab?

    3. March 2016 at 12:47 #19050

    Hi mkkyah,

    we checked the technical possibilities to delay the start of Kodi. Unfortunately, it does not work the same way as it does for the Squeezebox Server.
    Have you ever tried to use your USB-DAC with another board like a Raspberry Pi 2 to find out if this is a U3 or a USB-DAC-specific problem with Kodi 15?
    You could also try to set the following option in Kodi: Go to Settings -> System -> Audio -> Keep Audio device alive and choose “Always”.

    Maximilian from Max2Play

    4. March 2016 at 12:05 #19108

    Hi Maximilian,
    I see, but Kodi is normally checking Squeezellite and Shairplay (to stop I guess) if used without USB-Dac. Can this mechanism used for our case, to check and wait for Squeezelite to start first?

    I have unfortunately no Raspi available to test at the moment.
    “Keep Audio Device alive/always” did not help I’m afraid.
    BTW I’m on Kodi Jarvis 16.0 now and the problem exists.
    I remember Pulseaudio and one other option (maybe named default or alsa) under Kodi audio output device settings before Kodi 15. Now there are only “PulseAudio Sound Server” and “Playback/recording Through the PulsAudio sound server” as options and I don’t see any difference between them. Is this related?

    11. March 2016 at 17:52 #19207

    Hi mkkyah,

    if the reason for your problem is Pulseaudio, you may want to try either of the two options:

    1) Edit /opt/max2play/start_xbmc.sh and uncomment the line that says killall pulseaudio
    or
    2) Run this script manually as root before you start Kodi.

    Please let us know if this helps. In any case, it is also advisable to install the latest image build for your U3.

    Roman from Max2Play

    • This reply was modified 8 months, 3 weeks ago by  Roman.
    11. March 2016 at 18:04 #19209

    Thanks Roman,
    I did uncomment “killall pulseadio”, but after that Kodi is not starting. I’m getting “/opt/max2play/start_xbmc.sh: 24: /opt/max2play/start_xbmc.sh: Syntax error: “fi” unexpected” error.
    I think that was added for 15.2, after I have reported “not starting” issue.

    11. March 2016 at 18:11 #19210

    I have also checked last image I have used, it’s the last downloadable image and updated to Version Beta-160307 until today.

    24. March 2016 at 13:58 #19446

    I am also having problems with audio output from my U3 following upgrade to Kodi 15.
    Nothing complicated in my set up, I am playing audio on my TV via HDMI. I have also tried using the audio jack on my U3 to my analog amp. It makes no difference, the result is the same.

    Following a restart of M2P and Kodi I get audio for about 2secs, then it stops. If I leave it running I occasionally get another 2 secs of audio before it stops again. Completely unusable as it is. I have tried various changes to all the audio settings I can find, but nothing makes any difference.

    On my previous Kodi implementation quite often playback started without any audio, however there was an audio setting that toggled between 2 options. I found if I changed that I always got the audio. Now I cannot remember what the setting was – something obscure that meant nothing to me, but it did get the audio working OK, every time without fail. That setting, whatever it was, has been removed from Kodi 15.

    As my setup is absolutely standard I cannot believe that this problem is not reproducable, or being experienced by others.

    24. March 2016 at 15:44 #19450

    Nojelc,
    I think I have found a solution.
    As you say, actually listed devices and settings were more clear and obvious with 14, now it’s confusing.

    Here is what I did:
    -Stop Kodi and go to Ubuntu desktop, open Sound & Video/Pulseaudio Volume Control
    – Select Configuration tab, set built-in Audio off and find usb-dac (CM108 audio controller by me) set digital stereo output. This can be confusing, because it’s always changing by me, needed a few reboots, good luck.
    -Now change to Output devices tab, set usb-dac device port(cm108 by me again) as digital output (s/pdif), close
    – Start Kodi
    – Go to Settings/system/ audio output/audio output device
    – Select Built in Audio(dmixer),analog (Now this step is confusing again; There were only Pulsaudio device and CM108 usb-dac listed with kodi 14 before. Now there are 2 pulseaduio devices and 2 built in audio listed with 15. An even we choose “built in audio, analog”, audio comes from hdmi. I’m confused, but happy that it works!)
    I hope this works for you to. I have no problems with these settings so far.
    Edit: BTW I’m on Kodi 16, but the listed devices and settings were same on 15, too.

    • This reply was modified 8 months, 2 weeks ago by  mkkyah.
    25. March 2016 at 7:47 #19458

    Thanks mkkyah. I have not tried the above yet because after I tried again after a few hours, and before I read your posting, I found that it was working OK, and as far as I can remember I had not changed anything (well apart from closing the vpn connection on my router, but I cannot see that that will impact audio output from my U3! – but who knows?). So a bit of a mystery. Next time it fails, and I suspect it will, I will follow your instructions and see what happens. I will post any findings back here.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here