New IQaudio Dac Plus no sound, all trouble shooting done

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions New IQaudio Dac Plus no sound, all trouble shooting done

This topic contains 9 replies, has 2 voices, and was last updated by  Heiner Moderator 3 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 8. Juli 2019 at 1:32 #46177

    This is a fresh install of raspian.

    In config.txt the following changes:

    # For HDMI Screen without audio
    max_usb_current=1
    hdmi_group=2
    hdmi_mode=87
    hdmi_cvt 1024 600 60 6 0 0 0
    hdmi_drive=1

    # For is2
    dtparam=i2s=on

    # Enable audio (loads snd_bcm2835)
    #dtparam=audio=on

    # For DAC
    dtoverlay=iqaudio-dacplus

    The system recognizes the device:

    **** List of PLAYBACK Hardware Devices ****
    card 0: IQaudIODAC [IQaudIODAC], device 0: IQaudIO DAC HiFi pcm512x-hifi-0 []
    Subdevices: 0/1
    Subdevice #0: subdevice #0

    The logs show it being mapped: dmesg

    [ 4.613042] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered – will retry
    [ 4.703092] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered – will retry
    [ 4.716010] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered – will retry
    [ 4.805985] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered – will retry
    [ 4.863189] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered – will retry
    [ 4.876753] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered – will retry
    [ 4.923615] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
    [ 4.923724] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
    [ 4.924499] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM43430/1 wl0: Oct 23 2017 03:55:53 version 7.45.98.38 (r674442 CY) FWID 01-e58d219f
    [ 5.608664] pcm512x 1-004c: Linked as a consumer to regulator.2
    [ 5.620379] snd-rpi-iqaudio-dac soc:sound: pcm512x-hifi <-> 3f203000.i2s mapping ok

    In the UI, under audio settings, the DAC is listed. I connected headphones to the DAC, and no sound. I connected L/R RCA cables to my stereo, no audio. Played a youtube video to test (and before installing the DAC, audio from youtube worked in the pi headphone jack.

    What do I do now?

    8. Juli 2019 at 11:22 #46185

    Hello Marc,

    With fresh Raspbian, do you mean the new Max2Play image based on Raspbian Buster?

    You should not edit the config.txt as you interfere with the webinterface config.

    Select the IQaudIO sound card in the IQaudIO plugin and reboot. Afterwards, your audio players should automatically run with the sound card as output.

    8. Juli 2019 at 15:07 #46193

    Hi Heiner,

    No, I am trying to add the DAC to a proprietary image of Raspbian with some pre-built software I cannot compile, but to make sure I know how to do it, I am testing adding to a clean Raspbian version, not the M2P image.

    8. Juli 2019 at 15:23 #46194

    I will test with the M2P Image to see if that works.

    8. Juli 2019 at 15:44 #46195

    Ok, tested with your image and still no sound.

    The only thing I am not sure about is my setting for my screen interfering with the DAC somehow.

    
    # For HDMI Screen without audio
    max_usb_current=1
    hdmi_group=2
    hdmi_mode=87
    hdmi_cvt 1024 600 60 6 0 0 0
    hdmi_drive=1
    

    If this shouldn’t be interfering, looks like this DAC is dead on arrival. What are the steps to return it?

    8. Juli 2019 at 16:06 #46197

    Hello Marc,

    I will send you an email with the further steps.

    Thank you for posting.

    8. Juli 2019 at 17:25 #46200

    I got the max2play „server“ running and removed the screen settings (an email from m2p told me their image was a server not something that should have a head on it).

    http://max2play/ did not work for me, but putting in the IP of the pi does bring up stuff. I selected my DAC.

    I can’t seem to find any way to test the audio. I don’t have a share or anything for this setup (as this is not why I bought the DAC). And I can’t seem to find a test audio button or some kind of streaming service to test it.

    Any one have a suggestion so I can test if this DAC works?

    9. Juli 2019 at 10:04 #46210

    Hello Marc,

    The Squeezebox Server has a radio plugin, you can stream from your phone with DLNA or AirPlay, there are also some radio stations preconfigured in MPD.

    10. Juli 2019 at 15:00 #46253

    Can I highly recommend a test button?

    I think this would be important.

    12. Juli 2019 at 9:55 #46298

    Hello Marc,

    Thank you for the feedback, I will add this request to our agenda and discuss it with our head developer.

    You can also create a topic for the request and if other max2play users chime in and also request it, we will prioritize this development.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here