Network Path Mounted but no External Device Found

Max2Play Home Forums Max2Play as Squeezebox (Player / Server) Network Path Mounted but no External Device Found

Viewing 6 posts - 1 through 6 (of 6 total)
  • 12. Mai 2023 at 19:39 #52823

    Can you kindly help – I’ve been trying different variations for options on filesystem mount without any luck
    Max2Play Version 2.56 Running with Raspberry Pi 3b+ and Audiophonics Sabre V3 Audio Card
    Squeezelite is running
    Squeezebox Server is running
    Webadministration shows Logitech Media Server with max2play as player and media folder as media/usb/music

    Filesystem network path is mounted both nfs and cifs types
    Path MAX2PLAY/usbshare
    Mountpoint media/usb/music
    Type nfs
    Options defaults,nofail,iocharset=utf8
    Path //MAX2PLAY/usbshare
    Mountpoint media/usb/music
    Type cifs
    Options user=root,password=^^^^^,pass,iocharset=utf8,_netdev

    However the list of external storage shows that no external devices found
    The external storage connected is 4Tb HDD partioned as 2 x 2TB – The indicating light on the HDD is continuously flashing

    15. Mai 2023 at 11:15 #52824

    Hi Ken,

    what exactly are you trying to achieve?

    You have an external HDD connected to your Pi and you use this as your media source for your Squeezebox Server. If you connect a HDD and it is not shown in „External Storage“ on „Filesystem Mount“ in Max2Play Webinterface, it might be that the Format is wrong or maybe the power supply is not strong enough to power the PI and the USB system with the HDD connected.

    But then you want to connect to a „Filesystem network path“ which means that the source is on another computer/NAS.

    We recorded some videos on how to connect the HDD and also how to mount network storage to use it as media source.


    16. Mai 2023 at 10:34 #52833

    Hi Stefan
    Thanks for you prompt response.
    I would confirm that I am connecting the HDD (Freecom) for use with the Logitech Media Server
    I don’t think the problem is with the power supply as I am using an Audiophonics linear power unit (25VA). I have also set the current output on the pi to 1.2 Amps.
    I previously used a similar arrangement with a HiFiBerry Digi+ and Raspberry Pi 3+ that was successfully operational for approx 4 Years using the same Freecom HDD. The network path for this setup was as follows – PATH UUID=263A36B23A367F3D MOUNTPOINT /mnt/exdrive TYPE nfs OPTIONS defaults,notail,iocharset=utf8
    Earlier today I reinstalled the Max2play image and added the network path as follows – PATH UUID=263A36B23A367F3D MOUNTPOINT /media/usb TYPE nfs OPTIONS defaults,nofail,iocharset=utf8. This displays ‚mountpoint successfully added’in the yellow information box.
    I have viewed ‚Network Mounting and SambaShares in Max2Play’s Filesystem Plugin‘ video. On my setup the section ‚External Drives on Max2play-Mountpoints for USB Storage‘ displays in bold font ‚No External Devices Found‘.
    Audioplayer and Multisqueeze are both running and Squeezebox Server (Version 8.2.0) is running and shows two players Max2play and Max2play_0 but a media scan does not find music on the usb HDD.
    Could there be anything missing in the Options part of the mountpoint?

    17. Mai 2023 at 13:49 #52835

    Hi Ken,
    you don’t need to add anything to the network path as you want to use a HDD directly connected to the Pi. There is an option to make the mountpoint of the HDD fixed, in case the mount folder changes after restart. Normally you don’t need to add anything to the mountpoints manually for a local connected HDD. The mountpoints are meant to be for network connections (NAS / other computer).
    But the problem, that the HDD is not shown in the External Drives section is strange. Maybe something in the configuration file is messed up – but after burning a new Image this should not be a problem.
    If you never see the HDD mounted or available in the External Drives section, you might consider removing anything but the HDD. Use a new SD-Card-Image and Ethernet via cable. Just to rule out a problem with power or interfering devices.

    One more idea: start the pi without the HDD connected and wait a minute – then connect the HDD and check if this shows anything besides „No External Devices Found“.


    18. Mai 2023 at 13:04 #52837

    Hi Stefan
    Thanks for explaining that the network path is only for Samba and Network connections.
    I tried disconnecting the HDD and reconnecting but it did not solve the problem.
    I have also installed a new image on a different manufacturers micro sd card and have removed the plugins I do not require i.e. Kodi/XMBC, WiFi/Lan, Accesspoint Setup, Jivelite, Bluetooth and DLNA Server. My connection is via Ethernet over the mains using Devolo adaptors. I would also note that the Audiophonics Sabre is part of there RASPDAC unit (not the mini). Currently I only have the power button running but not the display. I am not sure what you mean by ‚removing anything but the HDD‘ The only connections to the RASPDAC unit are ethernet, USB from HDD and incoming power. I have just powered up the RASPDAC and opened up Max2Play interface. Everything is running except HDD is still not recognised. Also checked Samba via Advanced IP Scanner and this shows up as connected. I have also tried two other HDD’s but result is the same although the indicating lights on all of them are operating.

    12. Juni 2023 at 10:15 #52851

    Hi Stefan
    Further to my post of the 18 May I have re-installed my setup using HiBerry card but with the remainder of the system remaining as with Audiophonics. The HDD was recognised without any problem. Would this indicate that there may be a problem with the Audiophonic Plugin?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here