Network connection fails when ethernet removed / reattached. Requires PI reboot

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Network connection fails when ethernet removed / reattached. Requires PI reboot

This topic contains 7 replies, has 2 voices, and was last updated by  MarioM Moderator 3 months, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 19. Januar 2022 at 16:04 #51953

    I am running max2play 2.54 on a PI 3B+ with „pijiuce“ UPS attached and have noticed the following:-

    1. If ethernet connection is lost (due to power outage at the ethernet switch, or ethernet cord removed) while PI is powered up, the PI does not reconnect on ethernet after the cord is replaced (or power reapplied to ethernet switch). Only by rebooting the PI can the ethernet be restarted successfgully.
    2. When rebooting, ethernet connection on the PI does not start, unless a mouse is connected by USB to the PI. This is very repeatable: no mouse, no ethernet, 100% of the time. With mouse connected, ethernet always starts.

    Any help please. Thanks

    31. Januar 2022 at 15:02 #52011

    Hi pomeroy,

    Please excuse the late reply. Is the problem still occurring? Are you using our stretch image? If so, you could try our Buster Image. If the problem also occurs there, you could try adding allow-hotplug eth0 to the following file: /etc/network/interfaces

    1. Februar 2022 at 13:12 #52017

    Hi. Yes problem is still woth me. I am using V2.54 which I believe is a „buster“ image. How do I add „allow-hotplug eth0 to the following file: /etc/network/interfaces“ via the web interface? Or is there some other means to login to the pi runnig max2play?

    3. Februar 2022 at 16:34 #52024

    You can check whether you are using a Stretch or Buster image at the bottom of the Settings/Reboot plugin by clicking „Debug Info“.

    There are two ways to access the Pi’s file system: via an SSH connection or Samba. With SSH, you can either install Putty on a computer or our Remote Control Plugin in the web interface. Then you have to log in with the user name „pi“ and password „max2play“.
    If you create a Samba share via our Filesystem/mount plugin, you can also access the Pi from a computer (for example Windows) via „Add network drive“. You can find more about this in our Wiki: https://www.max2play.com/en/wiki/creating-a-sambashare/

    3. Februar 2022 at 16:52 #52027

    Hello Mario

    Thanks for this. I found the filew and added the line which you suggested to the END of ythe filew. So the file is as below. Is this correct?
    Thanks

    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback

    #auto eth0 # managed by ifplugd
    iface eth0 inet static
    address 192.168.0.24
    gateway 192.168.0.1
    dns-nameservers 192.168.0.1
    dns-nameservers 8.8.8.8
    netmask 255.255.255.0
    #hwaddress ether 1a:64:b6:bf:36:37

    #allow-hotplug wlan0
    #auto wlan0
    #iface wlan0 inet dhcp
    #pre-up wpa_supplicant -B w -D wext -i wlan0 -c /opt/max2play/wpa_supplicant.conf
    #post-down killall -q wpa_supplicant
    allow-hotplug eth0

    14. Februar 2022 at 12:30 #52046

    Yes, it should work like this. Have you noticed any improvement?

    14. Februar 2022 at 17:47 #52050

    No that did not help Mario.

    15. Februar 2022 at 15:01 #52054

    Please try to operate the system with a „normal“ power supply unit and disconnect the Ethernet connection during operation. Does the reconnect work there? If so, there is some problem with the pijuice. If not, please try to burn a new image onto the SD card and try everything again.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here