Napster

This topic contains 16 replies, has 4 voices, and was last updated by  medapayne premium 2 years, 7 months ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • 10. März 2018 at 12:42 #34307

    Hello,

    Actually, I’m wondering, that I seem to be the only napster user here. But since the last post regarding napster here is from 2016, I wanted to know, if there are some news avalilable. It seems, that the squeezebox server may be connected to napster, but the squeezebox lite player, coming with m2p images is not able playing the content. It doesn’t depend on the server version, the same problem at synology disk station and LMS 7.9.1 in connection with m2p. Other players, especially SB Touch, seem to work.

    There are some questions. Why does m2p provide the napster app at the image, when it doesn’t work at all? Is it possible, to upgrade the player, that it may connect to napster?

    Best,
    Haiko

    11. März 2018 at 18:18 #34319

    I also use napster. Seems that Napster only works on „newer“ Logitech-Hardware like SB Touch, SB Radio.

    12. März 2018 at 17:46 #34346

    Hi guys,

    We have not tested Napster in a while. We will take this on in our next session and look at possible fixes to make sure Napster users don’t have to manually alter Max2Play in the future. Thank you for pointing this out.

    12. März 2018 at 19:58 #34357

    The latest Nightly-Update of LMS 9.1 fixes the problem (by switching all connections to https), also you need to update all perl libraries (apt-get update etc.) via the setting in max2play for raspberry pi settings.

    13. März 2018 at 12:28 #34390

    Hi justwords,

    Thanks for the quick follow-up! Glad to hear that it works now.

    13. März 2018 at 14:52 #34394

    Hallo Heiner,

    wieso ist das Problem gelöst? Vielleicht solltest du solche Aussagen erstmal prüfen. Ich habe die 7.9.1 installiert und alle Paketupdates sowie das Kernelupdate ausgeführt. Selber Fehler.

    NO, IT DOES NOT WORK NOW!

    14. März 2018 at 13:38 #34418

    Hallo Haiko,

    Kannst du bitte versuchen, das Beta Update in Settings/Reboot durchzuführen, den LMS Nightly erneut zu installieren, die Pakete zu updaten und Napster neu einzurichten?

    14. März 2018 at 15:11 #34420

    Hallo Heiner,

    das hat leider auch nicht funktioniert. Die Beta läuft, LMS 7.9.1 wurde nochmal installiert, die Pakete sind aktualisiert und das Plugin ist auch deinstalliert und wieder installiert. Selber Fehler. Leider.

    15. März 2018 at 9:22 #34437

    Ich habe erst unter den raspberry-Settings apt getupdate ausgeführt, dann auf nightly aktualisiert. Jetzt geht Napster auf allen Squeezebox Radios wieder. Insofern muss bei dir irgendetwas anders sein.

    15. März 2018 at 11:12 #34441

    Hallo justwords,

    hast du dieses Image:

    http://downloads.slimdevices.com/nightly/7.9/sc/75286ea5bfd9a19bbb3fb5f8a878d668d5b94ed5/logitechmediaserver_7.9.1~1521043527_arm.deb

    verwendet?

    Napster auf Squeezebox Radio? Heißt das, dass du nicht das Plugin benutzt? Ich versuche nämlich die App (unter eigene Apps) zu starten. Allerdings werde ich jedes Mal darauf hingewiesen, dass ich eine Squeezebox 2 benötige.

    • This reply was modified 2 years, 7 months ago by  XRobertson.
    16. März 2018 at 21:43 #34486

    Hi, verstehe deine Frage leider nicht: Man muss auf dem Raspberry via max2play die neuste Version vom lms nightly installieren und unter raspberry settings apt update starten. Das Plug-in muss im lms natürlich aktiviert sein. Auf der Squeezebox nutzt man dann die Napster-anwendung. Auf älteren Squeezeboxen wie Boom oder Receiver/Duet ging das auch früher nicht, erst ab Radio oder Touch.

    26. März 2018 at 23:03 #34768

    hi

    So the solution exist?
    in my side same problem Napster don’t work.
    Plugin Napster 1.0 installed on LMS
    Napster Application Installed but i have the message : “ you need Squeezebox2 for work“.

    Please help us……

    • This reply was modified 2 years, 7 months ago by  medapayne.
    27. März 2018 at 16:21 #34817

    Hi medapayne,

    Have you tried justwords‘ tips yet?

    27. März 2018 at 16:39 #34818

    Hi Heiner
    Yes look my LMS specs:

    Logitech Media Server Version : 7.9.1 – 1521477787 @ Mon Mar 26 14:30:20 CEST 2018
    Système d’exploitation : Debian – FR – utf8
    Architecture de la plate-forme : armv7l-linux
    Version de Perl : 5.20.2 – arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan : 0.95
    Version de la base de données : DBD::SQLite 1.34_01 (sqlite 3.7.7.1)

    I think we need physical SB .
    Or you think is possible with software modification ?

    27. März 2018 at 16:48 #34819

    Hi medapayne,

    From the last discussion I had on Napster, it was indeed required thanks to a new encryption method. However, I am not sure what the current status is, perhaps justwords has some more insight.

    27. März 2018 at 17:07 #34823

    In fact I think the Napster plugin only works with squeezebox radio and touch. Alternative: If you have iOS devices or HTC phones you can use Napster app on your phone and play the music via airplay on any audio device in lms. Downside: This way only one user can use Napster at one time whereas every squeezebox on lms can play different music via one Napster account on lms.

    28. März 2018 at 7:42 #34833

    My solution i stop my Napster suscription and i take spotify family ( reality my family is my friend so for mont i paid 3€ ) 🙂

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.

Register here