Nach Samba-Freigabe kein Kopieren auf Rasbpi USB Laufwerk möglich

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Nach Samba-Freigabe kein Kopieren auf Rasbpi USB Laufwerk möglich

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner premium 8 months, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 20. March 2016 at 18:59 #19385

    Hallo zusammen,
    hab den USB Stick am Rasbpi als Neztwerkfreigabe für externe Geräte eingerichtet, die
    Abfrage von Konto und Kennwort läuft auch sauber durch.
    NUR: Das Kopieren von Daten funktioniert trotz Schreibrechte “yes” und Dateirechte “664” nicht:
    Meldung: Fehler 0x80070005 – Zugriff verweigert.
    Betriebssystem ist Windows 10 64 Bit
    Kann jemand damit was anfangen. Bin echt ratlos….

    Vielen Dank schonmal !

    Gruß Peter

    • This topic was modified 8 months, 3 weeks ago by  rasbpi.
    21. March 2016 at 14:36 #19390

    Hi rasbpi,
    Bitte versuche eine neue Freigabe mit den Dateirechten “777” einzurichten. Dies gibt dir alle Schreib- und Leserechte auch von anderen Geräten in deinem Netzwerk.

    22. March 2016 at 17:40 #19414

    Hallo Heiner,
    sehr geiler Tip…und funktioniert !!!
    Superherzlichen Dank an Dich.
    By the Way, warum ist das Recht “664” eigentlich vorgegeben, wenns nicht(immer) funktioniert ?

    Gruß Peter

    • This reply was modified 8 months, 3 weeks ago by  rasbpi.
    22. March 2016 at 17:56 #19416

    Kein Problem, die Vorgabe ist 664, da diese sicherer ist. Falls jemand anderes auf dein Netzwerk zugreifen könnte, könnte er so frei mit den Dateien und dem Ordner der freigegeben ist, machen was er wollte, was sicherheitstechnisch problematisch ist.

    • This reply was modified 8 months, 3 weeks ago by  Heiner.
    • This reply was modified 8 months, 3 weeks ago by  Heiner.
    23. March 2016 at 19:37 #19433

    Hallo Heiner,
    muss mich revidieren, denn das Problem hat doch nichts mit den Schreibrechten zu tun.
    Was Du natürlich nicht wissen konntest:
    Bin Betroffener der Netzwerkprobleme mit Samba seit des Windows 10 TH2 Updates. Das stellte sich so dar, dass meine 3 Linux-Receivern und der Pi teilweise überhaupt nicht sichtbar waren, teilweise zumindest die Netzwerknamen, aber nicht die Datenträger eingeblendet wurden und so weiter und so fort.
    Heute habe ich allerdings ENDLICH den richtigen Lösungs-Thread dafür gefunden, hier ein Posting , das das Thema auf den Punkt bringt:

    Moin,
    Abhilfe schafft hier zur Zeit das Abschalten von SMBv2/3 und das nutzen von SMBv1 unter Win 10 TH2
    hierzu folgende zwei Befehle in einer Shell mit Admin-Rechten eingeben:
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc.exe config mrxsmb20 start= disabled
    nach einem Neustart sollte dann die Netzwerkumgebung wieder normal arbeiten.
    Rückgängig macht man das ganze mit folgenden Befehlen:
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
    sc.exe config mrxsmb20 start= auto

    Hintergrund ist wohl das seit TH2 das SMB-Protokoll v3.11 Standard unter Win10 ist, leider wird diese SMB-Version unter Linux erst ab Samba 4.2 unterstützt, und da die meisten Kisten im Netzwerk (NAS/Router/DVB-Receiver usw.) unter irgendeiner Art Linux laufen, welche meistens ältere Samba-Versionen nutzen, kommt es zu Problemen mit der Netzwerkumgebung.

    Bei mir hat der Workaround funktioniert und jetzt funktioniert der Schreibzugriff auf den Rasbpi auch mit “664”

    • This reply was modified 8 months, 2 weeks ago by  rasbpi.
    • This reply was modified 8 months, 2 weeks ago by  rasbpi.
    • This reply was modified 8 months, 2 weeks ago by  rasbpi.
    29. March 2016 at 13:14 #19485

    Sehr gut, vielen Dank für die Info!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here