[SOLVED] Musikordner auf NAS WD my Cloud im Squeezeserver nicht zu finden

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] Musikordner auf NAS WD my Cloud im Squeezeserver nicht zu finden

This topic contains 9 replies, has 2 voices, and was last updated by  jcu-muc Moderator 7 months, 1 week ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 3. January 2017 at 23:47 #25444

    Hallo,

    ich möchte meinen neuen Raspberry 3 ausschließlich als Squeezeserver für mehrere vorhandene Squeezeboxen einsetzen. Mit einem testweise mit Musik gefüllten und an den Raspi angeschlossenen USB Stick klappt das soweit auch prima.
    Meine Musikdateien liegen aber sonst auf meiner NAS, einer WD myCloud 3TB. Den Ordner habe ich im M2P auch erfolgreich gemounted.
    Im Logitech Media Server ist dieser Ordner aber nicht aufzufinden.Den LMS habe ich schon mehrmals neu gestartet, auch schon neu installiert,die Datenbank immer wieder gelöscht und neu durchsucht.
    Installiert habe ich den LMS 7.9 nightly, Version 7.8 habe ich testweise versuchen wollen, aber nicht zum laufen bekommen.
    Falls das noch weiterhelfen sollte, meine Musikordner liegen unter WDMYCLOUD/Public/Shared Music.

    Ich bin für jede Hilfe echt dankbar!

    4. January 2017 at 0:03 #25445

    Hallo Ralf,

    ich habe auch eine WD My Cloud und wie folgt angebunden:

    1. In der My Cloud Administration einen User “raspberry” mit passwort “xyz123” eingerichtet. Der User raspberry hat Lese- und Schreibrechte auf den Musikordner (auch bei mir ist er public, aber so bekommt er explizite Rechte)

    2. In Max2Play sind meine Ordner wie folgt eingebunden:

    //WDMYCLOUD/Music/MP3
    /media/Music/MP3
    cifs
    user=raspberry,password=xyz123,sec=ntlm,iocharset=utf8

    //WDMYCLOUD/Music/FLAC
    /media/Music/FLAC
    cifs
    user=raspberry,password=xyz123,sec=ntlm,iocharset=utf8

    //WDMYCLOUD/Music/Playlists
    /media/Playlists
    cifs
    user=raspberry,password=xyz123,sec=ntlm,iocharset=utf8

    Passe die Pfade an, damit sie für Dich stimmig sind. Am Besten die My Cloud neu booten, danach Max2Play auch neu booten, und vielleicht hat das was gebracht.

    Viel Glück!
    JCU

    PS – fällt mir gerade ein, vielleicht ist das Leerzeichen in “Shared Music” ein Problem. Ggf. umbenennen in “Music”.

    4. January 2017 at 10:37 #25456

    Hallo,

    erstmal vielen Dank für die schnelle Antwort!
    Das mit dem Leerzeichen klingt schlüssig, den Ordner habe ich entsprechend umbenannt, leider ohne Erfolg.
    Ansonsten entspricht meine Konfiguration der deinen (glaube ich).
    In der WD Administration hat mein user ralf auch lese und schreibrechte.
    Im max2play ist der Ordner wie folgt eingebunden:
    //WDMYCLOUD/Public/Music
    beim mountpoint war ich mir nicht sicher (ich kenne mich da nicht aus), ich habe versucht wie im m2p Beispiel
    /mnt/mountdir (??) und auch
    /media/Music
    Dann weiter cifs und
    user=ralf,password=abcd,sec=ntlm,iocharset=
    Beides laut Webinterface erfolgreich gemounted. Dann müsste es doch funktionieren???
    Im Logitech Media Server habe ich aber keine Chance auf den Ordner zuzugreifen.

    Ich bin ratlos!!

    4. January 2017 at 11:28 #25460

    Hallo Ralf,

    ich habe dir hier ein paar Screenshots von meinen Einstellungen hochgeladen, bitte sage mir wenn Du sie hast, dann nehme ich sie wieder runter:

    https://www.dropbox.com/s/1bmur98cv6rpfq9/settings.zip?dl=0

    Vergleiche bitte mit deinen Einstellungen und auch mit meiner Mount-Konfiguration vom letzten Post.

    Ich würde an deiner Stelle die vorhandenen Mounts löschen und neu anlegen.

    Good luck!
    JCU

    4. January 2017 at 23:49 #25542

    Ganz herzlichen Dank dafür!
    Heute schaffe ich es allerdings nicht mehr, ich melde mich morgen dazu.

    Gruß

    Ralf

    5. January 2017 at 23:03 #25583

    Hallo,

    ich weiß einfach nicht, was ich falsch mache. Ich habe deine Konfiguration Wort für Wort übernommen, aber es läuft nicht!

    Dabei habe ich den Raspi gekauft, weil es hieß, das max2play Webinterface sei so leicht zu bedienen.
    Mit angeschlossener Festplatte ist das ganze so einfach, das ist dauerhaft allerdings keine Lösung für mich.

    Hast du noch einen Rat für mich?

    Gruß

    Ralf

    8. January 2017 at 12:44 #25667

    Hat sonst jemand einen Tipp für mich? Vielleicht der Support?
    Wenn im max2play webinterface steht, Ordner erfolgreich gemountet, dann habe ich doch alles richtig gemacht, oder?

    Ralf

    9. January 2017 at 11:22 #25684

    Habe es hinbekommen. Die Einstellungen der WD hahe ich resettet und dann neu eingegeben. Daraufhin hat es geklappt. Das mounten meiner Musikordner im max2play Interface war zwar nicht erfolgreich, im Logitech Media Server konnte der Ordner aber trotzdem ausgewählt werden.
    Ich bin also kein Stück schlauer, weil ich nicht weiß wieso es nun funktioniert, aber das Ergebnis paßt.

    Gruß Ralf

    9. January 2017 at 13:00 #25688

    Hallo Ralf,

    sorry für die späte Reaktion, ich war ein paar Tage unterwegs. Freut mich sehr, dass es nun endlich geklappt hat – auch wenn die Gründe des Gelingens unklar sind. Der Reset der WD My Cloud war wohl der Schlüssel zum Erfolg. Aus eigener Erfahrung kann ich sagen, dass die My Cloud etwas zickig sein kann; wie es sich mit anderen NAS (Synology,QNAP) verhält, kann ich leider nicht sagen.

    Anyway – enjoy!

    Viele Grüße
    JCU

    For the English speakers amongst you: After numerous unsuccessful attempts to get a WD My Cloud NAS to work with Max2Play & Logitech Media Server – even with seemingly correct and otherwise proven settings – the solution was to reset the WD My Cloud NAS via its web administration. This evidently did the trick.

    12. January 2017 at 23:32 #25837

    Hallo Ralf,

    ich habe bei meinem Setup erst jetzt gemerkt, dass der Raspberry das Playlist-Verzeichnis zwar lesen konnte (ich hatte vorhandene M3U drin), aber in das Verzeichnis nicht schreiben konnte, trotz im WD My Cloud vergebene Schreibrechte für den User Raspberry. Ärgerlich und unverständlich, aber hier die Lösung:

    //WDMYCLOUD/Music/Playlists
    /media/Music/Playlists
    cifs
    user=raspberry,password=max2play,file_mode=0777,dir_mode=0777,sec=ntlm,iocharset=utf8

    Solved!

    Viele Grüße
    JCU

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here