[SOLVED] Music suddenly invisible! And Adding Printers in Printserver Plugin under Stretch [FIXED]

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] Music suddenly invisible! And Adding Printers in Printserver Plugin under Stretch [FIXED]

This topic contains 23 replies, has 2 voices, and was last updated by  Heiner Moderator 2 years, 3 months ago.

Viewing 24 posts - 1 through 24 (of 24 total)
  • 6. März 2018 at 17:06 #34242

    Max2Play has been working well for years – Server on Pi, Music on Seagate Nas, 2 Pi players, Squeezeobx and Radio players, streaming throughout the house.

    The music on the NAS has become invisible to Max2Play, possibly after an update. Podcasts, internet radio and Spotify all still work ok.

    I have remounted the NAS share in Max2Play. Max2Play says that it has been mounted ok, but the directories and the files are not visible in Squeezeserver.

    Any ideas that might help would be gratefully received.

    7. März 2018 at 12:38 #34259

    Hi TJH,

    Please try renaming the share to rule it out as a source of error. Also, please try using a different login for the share.

    7. März 2018 at 15:46 #34263

    The share is open to all on my home network and did not need a login.
    It worked with:

    user=,password=,sec=ntlm,iocharset=utf8
    or
    user=name,password=pass,sec=ntlm,iocharset=utf8

    in the filesystem mount box.
    Now either shows as mounted ok in the filesystem mount but the files and folders aren’t visible in Squeezebox.

    I’ll try your suggestions tonight.

    8. März 2018 at 20:40 #34287

    All seems ok now.
    I removed the filesystem mount add in, rebooted the pi, put the filesystem mount back, updated Squeezebox Server to the latest nightly, deleted and readded the NAS share with the same name and credentials.
    Squeezebox Server now sees the files and folders and is busy reindexing 9269 files.
    Who knows what it was, but it’s sorted. Maybe a glitch in the old SBox Server version?

    9. März 2018 at 13:41 #34296

    Heiner – it’s all gone again!

    Yesterday I updated everything on the Pi, remounted the NAS share, rebooted (as per lat post) and all my music became visible, got indexed and was available to play. This morning it’s all gone again.

    The music is on a Seagate NAS at //192.168.0.6/Media/Music/Final and then into folders /Artist_Name

    //192.168.0.6/Media is mounted OK in Max2Play as /mnt/media

    Squeezebox server sees /mnt/media/Music/Final but does not see any /Artist_Name folders and does not see or index any music files

    Spotify and podcasts keep on working, it’s just my local network music library that gets lost.

    Any ideas?

    9. März 2018 at 15:14 #34297

    ….and now I can’t even mount //192.168.0.6/media (/mnt/media cifs user=Max2Play,password=Max2Play,sec=ntlm, iocharset=utf8)

    12. März 2018 at 12:45 #34333

    Hi TJH,

    Please make sure the mount has no spaces like in the info you posted in brackets.

    Was your system running overnight or did you shut it down and boot it again to find the music gone?

    12. März 2018 at 18:28 #34351

    Dear Heiner
    I hope you had a good holiday (and aren’t sitting with two snowboarding broken wrists like me).
    Worse and worse I’m afraid.
    I am trying to start again from scratch.
    1) Latest Max2Play image downloaded and burned onto formatted SC card, Max2Play updated
    2) Pi kernel and packages updated via Max2Play
    3) Max2Play gives error when trying to fix IP address:

    Debug: Saving WPA-Supplicant (Successfully initialized wpa_supplicant Could not read interface wlan0 flags: No such device WEXT: Could not set interface ‚wlan0‘ UP wlan0: Failed to initialize driver interface )
    IP-Address set to 192.168.0.21
    Restarting Interface (especially WLAN0) might take some time (up to 1 minute)!
    Data saved

    4) Share moved and renamed on Seagate NAS (public share called SMusic, running services SMB, NFS and FTP).
    5) New user max2play added to server users, password max2play.

    6) Share won’t mount using cifs

    mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Mountpoint NOT added! Please refer to the description below!
    Path //192.168.0.6/SMusic
    Mountpoint /mnt/smusic
    Type cifs
    Options user=max2play,password=max2play,sec=ntlm,iocharset=utf8

    7) Share will mount using nfs

    Mountpoint successfully added
    Path //192.168.0.6/shares/SMusic
    Mountpoint /mnt/smusic
    Type nfs
    Options (left blank)

    8) Latest Squeezeserver 7.9 nightly installed
    9) Max2Play wont’t start Squeezeserver

    Trying to launch … NOT successful Click here to show detailed information

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

    sudo: no tty present and no askpass program specified

    10) Haven’t tried getting the printserver working yet

    Any ideas?

    12. März 2018 at 18:31 #34352

    ….also I noticed during the package update

    You might want to run ‚apt-get -f install‘ to correct these.
    The following packages have unmet dependencies:
    logitechmediaserver : Depends: libio-socket-ssl-perl but it is not installed
    E: Unmet dependencies. Try using -f.

    12. März 2018 at 19:06 #34354

    via Max2Play Run Command

    apt-get -f -s install

    got SBServer to start

    13. März 2018 at 12:20 #34388

    Hi TJH,

    Holiday was great, thanks for asking 🙂

    – Fixed IP unfortunately only works with ethernet connection.

    – We had an issue with the LMS 7.9 nightly. After running a beta update in Settings/Reboot, the install should work again.

    Is your share still not recognized or indexed incorrectly in LMS?

    19. März 2018 at 22:49 #34542

    …so after a weekend away, I’ve had another attempt.
    New image burned to new SD card.
    Updated to beta.
    Share name changed.
    Share now mounts OK.

    Latest LMS 7.9 nightly installed.

    LMS won’t start (same error message. apt-get -f -s install doesn’t help).

    Was ist los??

    21. März 2018 at 13:21 #34592

    Hi TJH,

    Es gab eine Änderung bei der Installation der LMS 7.9 nightly. Entweder mache ein beta update um diese zu erhalten und installiere dann den server erneut oder installiere version 7.9.

    22. März 2018 at 14:55 #34657

    I did update Max2Play to beta and reinstall the latest nightly 7.9 on 19 March but LMS wouldn’t start as per my last post.

    Is the latest nightly 7.9 LMS not as up to date as the version in Max2Play beta?

    I’ll try redoing the beta Max2Play update without any LMS update and see if the LMS sent with the beta will start.

    In future I’ll just not bother with updates!

    23. März 2018 at 16:21 #34704

    Hi TJH,

    Sorry about the hassle. If you are looking to burn a new image, you can upgrade to our new Stretch Image. 🙂

    25. März 2018 at 12:03 #34721

    Danke.
    The stretch image works!
    Share mounted OK (only seems to like lower case share name?)
    LMS 7.9 nightly installed ok
    Music and spotify ok

    BUT
    CUPS Printserver not accepting user = root, password = max2play –
    I put it in over and over again without being able to get in to set up printserver –
    eventually it gives up and just tells me that I am forbidden and can’t do anything.
    I’ve also tried User = pi, password = raspberry and a few others.
    I’m using Chrome and have also tried Edge.
    (Could it be something to do with the certificate not being recognised so https isn’t available)

    Any help appreciated.

    • This reply was modified 2 years, 4 months ago by  TJH.
    26. März 2018 at 16:16 #34748

    Hi TJH,

    user pi is now also set up with password „max2play“. I will try installing the cups server here as well to see if I can recreate the issue.

    1. April 2018 at 19:16 #34928

    CUPS printserver is still no good.
    When I use pi/Max2Play I still see:

    Add Printer
    Add Printer Error
    Unable to add printer:
    Forbidden

    ????

    3. April 2018 at 14:14 #34949

    Hi TJH,

    Again thank you for pointing this out, we are trying to find a fix asap.

    4. April 2018 at 0:41 #34955

    Thanks. Please let me know as I need to print!
    I’ll have to go back to a dedicated print server box till it’s fixed 😢

    4. April 2018 at 16:23 #34982

    Hi TJH,

    For the time being, you can still revert to the Jessie Image. We added the issue to our known Stretch Bugs and will try to find a fix asap.

    10. April 2018 at 22:47 #35113

    I have downloaded and reinstalled the Jessie image (and updated as suggested on first boot) and the filesystem mount works, LMS works and the printserver works. Yay!

    I’ll keep it as it is for a while without updating anything.

    Thanks for your help and keep up the good work.

    Tim

    11. April 2018 at 13:18 #35120

    Hi Tim,

    Thanks for the follow-up. We are currently working on the print server fix, among other smaller bugs for our next.

    15. Mai 2018 at 16:00 #35701

    Hi Tim,
    Good news! The newest beta update adds special rights to user pi that let you add printers. Try making a beta update and reinstalling CUPS 😉

Viewing 24 posts - 1 through 24 (of 24 total)

You must be logged in to reply to this topic.

Register here