Multiroom squeezeboxes are playing asynchron

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Multiroom squeezeboxes are playing asynchron

This topic contains 6 replies, has 2 voices, and was last updated by  Heiner premium 1 year, 3 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 1. September 2015 at 14:08 #15530

    Hi,

    I still have some issues with my 3 Pi’s running Max2Play. I tried to build up a multiroom System. But instead of playing Music in a synchronised way, some of the Players loose connection or whatever. The result of the delayed Signal sounds like an echo – which is very annoying..
    Sometimes the Logitech Media Server is able to resynchronise the Players but often it skips the actual track or something else.
    I tried to vary the positions of the Players, but even if they are in the same distance to the WLAN Router, the trouble still occurs.

    The next day I tried to use Airplay as an alternative – therefor I searched the LMS PLugin “Shairtunes” which I haven’t found yet. Could you please provide me a Link or anything?

    How can I fix this problem?

    Thanks in advance!

    1. September 2015 at 15:30 #15537

    The Shairtunes 2 Plugin can be installed in the web interface page “Squeezebox Server under “plugins”. Regarding your connection problems, the source can be the WiFi sticks’ performance or music files with very high quality that the Raspberry Pi has problems playing. Please try to find out if any of these cause your problems.

    1. September 2015 at 16:36 #15560

    Is it only a plugin for “Squeezebox Server” running in Max2Play? My LMS is running on a NAS System where I can’t find the plugin…?

    1. September 2015 at 16:41 #15561

    I found an Option to configure the stream Quality, I’m going to try several Things:

    1. Spotify Streaming with different Quality Settings (Low, Mid, High)
    2. Streaming from local data Shares

    I’ll Keep you in the Loop

    2. September 2015 at 12:14 #15588

    The easy integration of the plugin is only for Max2Play’s LMS. The plugin should be compatible with your LMS as well. Here you can find installation instructions: http://forums.slimdevices.com/showthread.php?103783-Announce-ShairTunes2-plugin-Airtunes-on-your-LMS

    7. September 2015 at 0:04 #15631

    Hey there,
    I attached a new router with a different SSID. Only the raspis are Clients of this wifi. Performance has improved a lot, let’s wait for the next Party to check if performance issues still appear.

    Thanks in addition for the ShairTunes Link. I still have some trouble installing the plugin on my LMS. Never worked with SSH etc. before so it would be nice if I could get some Support from you.

    LMS tells me that the plugin can’t be installed / loaded.

    Via SSH (I tried using Putty) it’s not possible for me to execute all commands posted on github.
    The first line of code generates the answer: “apt-get: cannot be found”
    Second one can be executed succesfully
    Third one is “in Need of superuser privileges”

    So I don’t really know what to do. It would be really great to get some advice from you! Thanks in advance

    7. September 2015 at 15:26 #15638

    Unfortunately, I looked into it and the plugin does not support any NAS natively. So you would have to adjust the ARM binaries yourself, which we did as a major bulk of our work to function with the Raspberry and Odroid. The code is in our images, if you want to try yourself, but we cannot offer help for individual outside hardware. If you want to use shairtunes without a lot of work, I recommend using it from our Image’s LMS.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here