Multiple WiFi access points

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Multiple WiFi access points

This topic contains 12 replies, has 2 voices, and was last updated by  jemhayward premium 4 months, 3 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 16. Juli 2018 at 21:45 #36625

    Can I set up my max2play to use several different wifi access points depending in where it is? I’m using PiZeroW with Justboom Zero Amp, in a portable music player, and when I move from one part of the house to another I will lose one access point, and be in the range of another (old stone house and barn!). If I change the wifi access point via the web interface, it seems to just replace the current one, rather than add an extra one. I can SSH in, but not sure what I’m looking for and don’t want to break anything as its otherwise all ok.

    17. Juli 2018 at 15:54 #36642

    hi jem,

    I would recommend using repeaters of the signal or a mesh solution. Individual access points might cause confusion when some settings or credentials differ. However, generally there is no real danger connecting to different access points just as there is no problem with connecting to different networks in general.

    17. Juli 2018 at 16:03 #36645

    The different access points are there for specific reasons, as they do limit people connected to them to different resources, but one resource that is common to all is my Squeezebox Server (LMS). As my Max2play is set up at the moment, it can connect to one of them, but whe I move to a different building, I can’t then connect without going to the interface and manually adding in the new wifi access point, and then it seem to ‚forget‘ the first one. I’d like it to behave like my phone, which just switches over to the next access point as I move about. Is this possible?

    18. Juli 2018 at 9:25 #36656

    hi jem,

    I do not think this is possible at the moment from our web interface.

    You might be able to edit wpa_supplicant.conf manually (need to use „sudo su“ before command) as detailed in this post but I have not tested this before and cannot guarantee that it will work.

    18. Juli 2018 at 9:39 #36657

    I’ll give that a try!

    18. Juli 2018 at 10:55 #36658

    Sorry, I forgot to link to the article 😀

    Here’s the stack exchange on the topic

    19. Juli 2018 at 13:19 #36676

    I created a wpa_supplicant.conf file in the boot partition (the only bit I can access on my Mac), re-inserted the card and rebooted, and it’s not appearing on my network, but even worse, it seems to have lost it’s ability to become an access point if it can’t find a wifi SSID. I didn’t have chance to try it on the SSID it was working on (as that is outside in the garden, and it was night-time), but I fear that I may have broken it.
    I can always reflash the card, but it looks like the wpa_supplicant method isn’t going to work. I’ll try to SSH in and have a look at wpa.conf itself.

    20. Juli 2018 at 12:30 #36689

    Tested again last night, and it still works on the original SSID, so maybe the wpa_supplicant process hasn’t worked. I think I may try SSH into the running machine and try editing wpa.conf directly.

    Does anyone know how the ‚if no wireless become an access point‘ is implemented, as I’d quite like to preserve that functionality?

    20. Juli 2018 at 14:33 #36698

    not sure I understand the question, you can activate and deactivate this feature in our WiFi/Lan menu.

    20. Juli 2018 at 15:15 #36701

    My attempt to get a second SSID by using wpa_supplicant.conf method, seemed to disable the access point feature… I’ll do more experimentation, and will report.

    22. Juli 2018 at 16:16 #36723

    I’ve now SSH’d in to my ZeroW and have found the wpa_supplicant.conf file, and it has both networks listed, but only the one I added via the Max2play interface, so I’m wondering where the wifi details get stored by max2play?

    23. Juli 2018 at 16:27 #36741

    Hi jem,

    This php, and the whole github as well, should point you in the right direction.

    However, I cannot would suggest starting from a backup if you run into problems to make sure your edits have not affected Max2Play overall.

    23. Juli 2018 at 18:43 #36744

    Very useful, many thanks. I’ve now located the wpa_supplicant.conf file in /opt/max2play/ and manually edited it to add in a second wireless access point.

    However, it still doesn’t work! So I suspect it may not be possible to add this functionality, with my level of knowledge/expertise!

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here