[SOLVED] mpd soundcard settings

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] mpd soundcard settings

Tagged: , ,

This topic contains 12 replies, has 3 voices, and was last updated by  C.Marchand premium 2 years, 6 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 27. Oktober 2015 at 19:50 #16587

    (I looked for this answer but couldn’t find it) I have a hifiberry amp+ with the basic max2play image on it. I have the hifiberry hooked up to my (multiroom) speakers, from which I want to play my music. In kodi I am able to select ALSA:Default in de audio settings – that works like a charm. But what should I select in mpd to have the output go to my speakers? Thanks.

    -Stephan

    30. Oktober 2015 at 16:26 #16645

    Hi sdspieg,
    With the HiFiBerry image, the selection of the Amp+ should have automatically set the output of the mpd to the Amp+. You can see the output option under Soundcard Settings in the mpd menu; hw:0,0 is the default setting.

    30. Oktober 2015 at 23:40 #16661

    Thanks. Maybe it should have, but it didn’t. Not with the default settings. I even thought I had a defective car. But as soon as I switched to xbmc/kodi, it worked immediately. And just for myself and others – what are the other non-default‘ settings that we can use?

    6. November 2015 at 15:56 #16792

    Please check if you have Kodi activated since it interferes with MPD and will stop it from working. Also make sure that the autostart tick is not activated since that will reactivate Kodi constantly.
    hw0;0 is the correct setting for the Amp+ since it forces the volume control onto the Amp’s system. Please also make sure you have the Amp+ activated in the Raspberry Settings.

    23. April 2018 at 10:43 #35264

    Hello,
    I’ve a similar problem with the same config. Well, it is not a multi-room, only a simple player with MPD and speakers wired to HifiBerry Amp+.

    No Kodi installed – or not visible.

    mpd.log shows this :

    Apr 23 10:32 : avahi: Service 'Music Player' successfully established.
    Apr 23 10:32 : client: [0] opened from 127.0.0.1:53234
    Apr 23 10:32 : alsa_mixer: Failed to read mixer for 'Max2Play ALSA Device': failed to attach to hw:0;0: No such device

    mpd.conf contains only one audio_output, which is :

    audio_output {
            type    "alsa"
            name    "Max2Play ALSA Device"
            device  "default:CARD=sndrpihifiberry"
            format  "192000:24:2"
            mixer_device    "hw:0;0"
            mixer_control   "PCM"
    }

    Using hw:0,0 for mixer_device produces the same result.
    I can not change the volume.

    Version 2.45, license activated.

    Any help will be much appreciated.

    25. April 2018 at 11:18 #35329

    Hi C.Marchand,

    Please try heading to Raspberry Settings, ticking „Disable build in audio“ and rebooting.

    25. April 2018 at 21:51 #35332

    Ticking „Disable build-in audio“ and setting back mixer_control to „Master“ solved the problem.

    Thanks a lot,
    Christophe

    27. April 2018 at 12:03 #35360

    Hi Christophe,

    Thanks for following up and letting me know 🙂

    30. April 2018 at 14:02 #35390

    We should always at least tell if a problem is solved, or not !

    I have a similar problem, but with a Amp2 HifiBerry card, and a WiFi access-point activated. All other configuration is identical. Error message in mpd.log is very simple : „Failed to open Alsa Mixer…“, without anymore specificities. I can change the volume from the Raspberry config tab, but not from YMPD.

    Any idea ?

    Best,
    Christophe

    3. Mai 2018 at 10:13 #35506

    Hi Christophe,

    Try adding „hw:0“ if it’s not already in the advanced options and make sure all other players are inactive.

    18. Mai 2018 at 8:26 #35753

    Sorry for being so long.
    It still doesn’t work.
    I may provide config files or log files. Which ones do you need ?

    Best,
    Christophe

    22. Mai 2018 at 14:44 #35805

    Hi Christophe,

    Please try using the HiFiBerry plugin, selecting „none“, rebooting, selecting „Amp2“, rebooting. Then select simple playback there.

    25. Mai 2018 at 15:25 #35885

    That solves the problem.
    Thanks a lot for your support and your help.

    Best,
    Christophe

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here