MPD – Music Player Daemon – Music Library local – no mpd clients will attach

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI MPD – Music Player Daemon – Music Library local – no mpd clients will attach

This topic contains 5 replies, has 2 voices, and was last updated by  MarioM Moderator 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 10. Mai 2020 at 9:25 #48744

    I have worked for many, many hours, read countless web articles and Max2Play forum posts and still my Raspberry Pi running the latest max2play v2.52 with mpd service running does not connect to any mpd clients locally or remotely. I can ssh to the RPi and confirm that mpd is running and attached to a local IPV4 ethernet port and also a local loopback port and yet YMPD launched from the M2P http „Music Player MDP“ interface tab has never communicated with the mpd process. Configuring /etc/mpd.conf and getting mpd daemon to run has been difficult, but „root>systemctl status mpd“ confirms the mpd service is running after I manually start it from the cmd line. However I note the mpd daemon does not start automatically after M2P reboot though the „[x] Autostart“ box is checked (and SAVED) in the M2P „Music Player – MPD“ interface tab. MPD version = 0.19.21 There is a newer mpd-0.21.23.tar.xz on github. Has anyone successfully updated to that version in M2P debian-stretch linux with apt-get ?

    1) Can you send me links to detailed guides explaining how to configure MPD server on max2play OS -AND- configure a remote MPD client to attach to the server from another LAN local computer?

    2) How does M2P edit the /etc/mpd.conf file ? What are the linux user, group permissions, ownership of the MPD stack of files.

    3) Many MPD users complain of bugs when the MPD server starts up in dual IPV4 and IPV6 environments generating lots of errors. This is a known issue. How has M2P dealt with this IPV4 + IPV6 problem regarding MPD ? Not asking you to fix the bug … just a workaround for the M2P OS so MPD can connect to clients across the local LAN. Can I disable IPV6, since I do not use it on my LAN ?

    Have also tried logging in remotely on my LAN from my Fedora 32 linux box and my vanilla install Hackintosh using mpd client Cantata … but nothing I have tried connects any MPD clients to the MPD server running on M2P. All my other computers can see the Max2Play system over my LAN using SMB. Cantata MPD client thinks MPD is not configured properly because there are no listings in the library and probably other reasons.

    MPD has been configured to believe the music library is locally attached as an external USB drive to the M2P RaspberryPi using a mountpoint „/media/usb0“, which then becomes a library address of: /media/usb0/my-music-library-name/my-mp3-subfolders (symlink in /media/usb points to usb0). „root“ is listed as the owner/user of my music mp3 library folders, owner of other mpd files = mpd, or sometimes = root, or audio. Same exact library address is successfully used by LMS (squeezebox). Squeezebox on M2P works great, if, of course, your original squeezeboxes have healthy 10-uF electrolytic caps on the DAC audio output stages. Two of my SB’s have failing caps (audio output voltage attenuated) which I will have to replace on the circuit boards myself. This is one of the reasons I want to get MPD server to work: in case my Squeezebox hardware fails entirely in the future and I must migrate to other DAC player hardware and away from LMS. Some currently happy M2P customers running LMS may face this situation in the future, with no manufacturers producing Squeezebox hardware and not comfortable building their own from RPi boards.

    Have enjoyed using my M2P with our (3) squeezeboxes for several years. Updated LMS and M2P a few months ago and all went well. Gladly paid for a 5 year M2P license and have not wanted to bother the M2P team for support, but this issue with mpd server has defeated me, so I am asking for your help, which might encourage other mpd server users to consider RPi and max2play as a host platform for their audio needs.

    Sorry this is a long post, and that my only modest language is English, ich spreche nur ein bisschen Deutsch … in der schule von 50 jahren … entschuldigen sie bitte. Mein lehrer war sehr gut. Ich war nicht ihre beste schuler.

    Thank you for any help pointing myself and others to a successful MPD server and client installation.

    11. Mai 2020 at 11:14 #48748

    ADDENDUM: Should add following information to original post above:

    — AMPACHE INSTALL ISSUES Maybe BROKE MPD —
    When YMPD client did not attach to the local RPi MPD server I tried installing Ampache MPD-client onto M2P v2.52 RaspberryPi (HiFi-Berry-Amp2) system using the M2P web interface tab page = „Music Player – MPD“ selecting the [INSTALL] button under „Install latest version of Ampache„. However, the Ampache installation process seemed to hang after 5 – 10 minutes of apt-get progress updates. Waited another 20 mins of no activity then rebooted RPi. RPi rebooted OK.

    To continue/fix the prior possibly broken Ampache install: logged in with SSH from Fedora 32 linux machine and elevated with „su“ to user = root on RPi. On RPi from cmd line ran „apt-get update“ which finished OK, then „apt-get upgrade“ also finished OK. So it is possible my first attempt to install Ampache from M2P http interface has left the M2P RPi mis-configured somehow and that is interfering with install of MPD and YMPD ??? The M2P „Music Player – MPD“ web interface tab lists Ampache as „Ampache is NOT installed yet!“. No other music player (web tab „Audioplayer“) is auto-started at boot: unchecked Squeezelite [ ], left Shairport [ ] unchecked also.

    — TEST BUILD ANOTHER M2P RPi-4b TO RUN Music-Player-Daemon —
    As a last resort, I am willing to build another M2P RPi using a RPi-4b card I have as a test, flashing a new micro-SD memory card with the latest M2P v2.52 for HiFi-Berry adding an AudioPhonics I-Sabre v4 DAC hardware daughter card. Then test another installation of MPD and YMPD, without installing Ampache. This is not my first choice. I planned to work on the RPi-4 with M2P only when more time was available and after learning from mistakes made and corrected on my exisiting RPi3 system running LMS (squeezebox server) with HiFi-Berry Amp2 daughter card and hopefully MPD.

    Hope this additional info helps troubleshoot the problems experienced installing MPD and YMPD-client on M2P RPi.

    12. Mai 2020 at 17:03 #48770

    Hi Mark,

    Thank you for the extensive testing and detailed description. It may well be that the incorrect installation of Ampache causes problems. We will look at the installer again and adapt it if necessary. Hopefully that can solve the problem. We will get back to you as soon as we know more.

    17. Mai 2020 at 4:51 #48800

    Thank you for looking into possible installation issues with Ampache. I will check back and re-install Ampache with an updated installer depending on what you might find and report my results here. Will also let you know if I try building another Max2play RPi-4b to test if a new install of MPD and YMPD works better.

    Recently purchased a Rock Pi4b, which has much in common with original RPi-4b, but adds onboard NVME.m2 interface, faster RAM (DDR4-3200mhz) …etc. I have worried about original RPi micro-SD card R/W longevity issues, as SD spec was originally designed for very different use cases: digital cameras, music players. These devices do many sequential memory reads and very few writes over the life of the SD. Any OS, but especially Linux which inherently does lots of logging is not a good fit for SD memory, in my opinion. This is why I plan to try installing M2P-OS into an NVME.m2 drive on the Rock Pi4b. I think other users of Rock-Pi4b configure the Linux-OS to boot from an EFI partition on the SD, but control is then quickly passed to the full Linux install on the NVME.m2 drive, which runs much faster and I hope more safely from NVME.m2 than uSD card.

    I do not expect the M2P org to support M2P OS Linux image on the Rock Pi4b, but would be grateful if you have heard from other users of any specific issues that arise from Rock Pi4b hosting M2P. If enough customers want to use Rock-Pi boards in the future it might create another market opportunity for M2P.

    Thank-you.

    — mark in Seattle

    19. Mai 2020 at 16:17 #48815

    Hi Mark,

    Your project sounds interesting! Please let us know if Max2Play also works with the Rock Pi. So far we have no experience with it and are not planning to support the Rock Pi directly. But if the system structure is similar to the Raspberry Pi, it could probably also run with Max2Play without further major adjustments.

    27. Mai 2020 at 16:56 #48871

    Hi Mark,

    We finally got to fix the Ampache installer for MPD in our latest beta update for Buster. Please test if that solves your problem with MPD.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here