Mounting funktioniert nicht mehr

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Mounting funktioniert nicht mehr

This topic contains 3 replies, has 2 voices, and was last updated by  runmiwirun premium 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 15. Januar 2023 at 0:19 #52586

    Ich kämpfe seit einigen Wochen mit einem Problem: Das Mounting funktioniert nicht mehr. 🙁

    Zuerst kurz zu meiner derzeitigen Situation:
    max2play läuft in Version 2.56 auf einem Raspberry PI 2. Bis vor ein paar Wochen eigentlich ohne wirkliche Probleme. Auf max2play läuft ein Squeezebox Server.
    Die Musikdaten liegen auf einem NAS (QNAP231Plus). Auch hier klappte die Verbindung bis vor kurzem gut.

    Weil das Mounting nicht mehr funktioniert hat, habe ich nach einigem Probieren den QNAP-Benutzer gelöscht und einen neuen Benutzer (in der Gruppe der Admin) eingerichtet, sowie die Freigaben am NAS gelöscht und neu gesetzt.

    Nun versuche ich neu zu mounten; dafür trage ich die folgenden Daten in der max2play-Registerkarte „Dateisystem Mount“ ein:
    //QNAP231Plus/m2pmedia
    /mnt/Qmedia
    cifs
    user=xxx,password=xxx,iocharset=utf8

    Dabei bekomme ich stets folgende Fehler:
    mount error(95): Operation not supported Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Hinzufügen nicht möglich! Bitte Anleitung beachten!

    Hat jemand eine Idee, woran das liegen könnte bzw wie ich die Probleme lösen könnte?

    15. Januar 2023 at 0:46 #52587

    Ok … bin nun doch einen Schritt weitergekommen: Habe statt ‚cifs‘, womit es früher immer funktioniert hat, auf ’nfs‘ geändert.
    Nun klappt das Mounting.

    ABER:
    Lasse ich nun den Logitech Media Server (Version 7.9.4) die Medienbibliothek erneut durchsuchen bzw die Mediendatenbank neu aufbauen, so findet der Logitech Media Server weder eine Musikdatei noch eine Playlist. 🙁

    Hat jemand eine Idee?

    17. Januar 2023 at 17:42 #52592

    Hallo runmiwirun,

    Der Mount-Fehler bei deiner ersten Nachricht bedeutet, dass etwas mit den SMB-Versionen nicht stimmt. Dein NAS benötigt wahrscheinlich SMB v2 oder höher. Mit der Option vers=2.0 bei der Freigabe kannst du die SMB-Version einstellen. Welche SMB-Version dein NAS nutzt, kannst du unter Systemsteuerung > Win/Mac/NFS/WebDAV > Microsoft Netzwerk > Erweiterte Optionen nachsehen.

    Findest du denn mit der NFS-Freigabe im Squeezebox Server prinzipiell den Freigabeordner? In den Grundeinstellungen des Servers unter Medienordner > Durchsuchen müsstest du den Ordner auswählen und bereits die Inhalte sehen können. Falls das nicht funktioniert, ist bei der Freigabe etwas schiefgelaufen.

    19. Januar 2023 at 20:20 #52604

    Hallo MarioM!

    Danke für die Hilfe … Hatte trotz der Option vers=2.0 nach wie vor das Problem, dass ich im Squeezebox Server an der von dir genannten Stelle keine Inhalte sehen konnte.

    Habe nun doch wieder cifs statt nfs verwendet, und nun klappt es plötzlich.

    Wenn es also jemanden interessieren sollte, hier sind die Einstellungen, die (derzeit) bei mir funktionieren:

    //QNAP231Plus/m2pmedia
    /mnt/Qmedia
    cifs
    user=xxx,password=xxx,iocharset=utf8,vers=2.0

    Danke jedenfalls! 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here