[SOLVED] Mount SMB USB share with fstab

Max2Play Home 2016 (en) Forums Max2Play on ODROID U3/C1 [SOLVED] Mount SMB USB share with fstab

This topic contains 2 replies, has 2 voices, and was last updated by  Heiner Moderator 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 15. October 2017 at 8:17 #31900

    Hey i am trying to mount a USB drive attached to my Odroid U3 to another Ubuntu machine via fstab
    Working with a USB drive on a FrtizBox works flawlessly.

    But for the Odroid drive i only can access this drive via my filemamnager by calling smb://max2play/odroid/

    The aim of adding the usb share to fstab is a first step. Finally i want to try to set up a USB drive on my Odroid serving as a recording drive for my TVHeadend Serveran shate this with LibreELEC clients.

    [email protected]:~$ sudo mount -t cifs -o credentials=/etc/samba/auth2 //192.168.178.23/usb0 /home/patrick/odroidtest
    [sudo] password for patrick:
    Retrying with upper case share name
    mount error(6): No such device or address
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

    #FRITZNAS
    //192.168.178.1/FRITZNAS/Intenso-ExternalUSB3-0-01 /media/patrick/FRITZNAS cifs credentials=/etc/samba/auth,uid=1000,gid=1000 0 0
    #odroidstick TEST
    //192.168.178.23/media/usb0 /home/patrick/odroidtest cifs credentials=/etc/samba/auth2,uid=1000,gid=1000 0 0

    If you need any information, let me know.
    I am german, if you like we can discuss in german 🙂

    15. October 2017 at 8:34 #31901

    FINALLY I found the solution:

    One does have to give the NAME of the share (as given in the Max2Play Webinterface) but not the path.
    This worked in my fstab

    //192.168.178.23/odroid /home/patrick/odroidtest cifs credentials=/etc/samba/auth2,uid=1000,gid=1000 0 0

    17. October 2017 at 11:12 #31923

    Hi patrick,

    Thanks for the quick follow-up and the detailed problem and fix, much appreciated 🙂

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here