[SOLVED] Max2play server on Raspberry Pi not responding

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Max2play server on Raspberry Pi not responding

Tagged: 

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 2. November 2019 at 18:43 #47463

    Hi,
    I have max2play running on a Raspberry Pi 3, delivering music to three Squeezelite clients. This is working (and it’s great). I can access the squezebox server through port 8080. However, I can’t get the max2play server itself to respond. It appears that Apache2 isn;t running. I tried:

    $ apache2ctl start

    AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‚ServerName‘ directive globally to suppress this message
    (13)Permission denied: AH00072: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    AH00015: Unable to open logs
    Action ’start‘ failed.
    The Apache error log may have more information.

    Any ideas?

    Thanks,
    Andy

    15. November 2019 at 11:16 #47536

    Hi Andy,

    There might be a port conflict. Squeezebox Server should be running default at port 9000. Did you do any manual adjustments to get it to use port 8080 and did the web interface work before?

    15. November 2019 at 13:51 #47541

    Sorry, my mistake: the LMS server is working as normal on port 9000 but I’m getting no response from max2play on port 8080.

    Andy

    20. November 2019 at 16:07 #47571

    Hi Andy,

    There might some restrictions on your network that prohibit the access. Does your boot sequence (connect Pi via HDMI) show any special error messages during boot?

    20. November 2019 at 20:59 #47577

    I couldn’t see any easy way to resolve this so I’ve now downloaded a new image and installed it. It took a few minutes to restore my add-ons and settings but it now works fine – I have access to LMS on :9000 and max2play on :8080. Result – happiness.

    Thanks for your help,
    Andy

    27. November 2019 at 13:50 #47610

    Thanks for the update, Andy 🙂

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here