max2play quits – stops randomly

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) max2play quits – stops randomly

This topic contains 4 replies, has 3 voices, and was last updated by  Christoph premium 2 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 11. July 2016 at 16:46 #21425

    On June 30 I installed max2play on an SD RP3/HiFiBerry, music via USB Flash. At first it worked terrifically wonderfully as LMS and Squeezelite w/ an additional Squeezebox Classic V3. But in less than 24 hours, max2play quit which required an (AC) power cycle. This same story repeats, with a time period never greater than a few hours.

    When max2play quits it also disappears from my WiFi network. I use SqueezeCommander and my Andriod smartpone, SqueezeCommander because I like it better than the other Apps I tried.

    At some point I did use Putty to log into the RPi and did a “sudo raspi-config” and changed the password to “pi”, attempted to expand the partition (already expanded?), set the time zone and wifi country code. That’s it. And that’s after my “quits” issue was noticed.

    So it seems that max2play is somewhat fragile. It’s not supposed to be, is it? Hopefully, someone will tell me to read the instruction book.

    11. July 2016 at 16:54 #21427

    Hi Mike,
    You can see how much space you have left on your filesystem in the debug info window under “Settings/Reboot”. If its full, you forgot to expand, installed too much on a limited filesystem and crashed it. In this case, we would recommend burning a fresh a image and expanding the filesystem first.

    20. July 2016 at 16:17 #21692

    Thanks Heiner, and you were correct. I tried but had not successfully expanded the Partition. Although the “Instructions” say to expand the Partition First, max2play does not allow it. But if for example, the Time Zone is set First, then the Partition can be expanded. It’s important to get feedback from max2play indicating that the Partition has been expanded successfully.
    So after taking a couple days to get max2play re-installed, understand the weird 60MB partition that Win32DiskImage creates, discover that Windows can’t format properly except in that 60MB partition, but SDFormatter can format all of an SD card, I got max2play up and running again.
    And it has failed 5 times in those 5-6 days.
    Again I’ve been using SqueezeCommander, and have suspected that the failure is related somehow to SqueezeCommander changes, changing Radio Stations, e.g., between Radio Paradiso and TSF-Jazz, a “Swiss” one, and others. As I’m typing this it failed again (when it fails it’s WiFi connection is lost), so I’m now switching to Squeezer. [Another thing I noticed this morning is that LMS Favorites can’t be selected using either SqeezeCommander or Squeezer, but they can be using the Squeezebox Classic V3. (They can also be selected via But I won’t worry about that for now.] If I continue to get failures with Squeezer my next step will be to replace the Netgear router (WNDR3800) that I’m currently using with an old-faithful LinkSys WRT54 (standard firmware).
    Thanks again Heiner for your help, I wanted to keep you up-to-date,

    29. July 2016 at 21:48 #21949

    There are 2 issues:
    1. Although the Raspberry Pi 3 claims it has internal WiFi it has no antenna. There is plenty of space on the circuit board so this is baffling. Yes it has WiFi but it’s range is “short range”.
    -(The RPi’s location is now 3.5M with the use of a long RCA cable, and it’s going to be “perfect”.)
    –RPi’s location ~5.5M from Router = max2play/LMS failed after 3-4 days.
    –Previous location ~8.5M from Router = failed daily.
    –Another location ~15M from Router = totally dead, will not connect.
    Compared to smart phones, tablets, laptops, squeezeboxes, the Raspberry Pi3’s WiFi is disappointing.
    2. The other issue is that max2play’s error recovery, assuming it has some, allows the wifi interface to die. The question is: should max2play automatically reinitialize wifi when it dies?

    2. August 2016 at 14:41 #21967

    Hello Mike-97470,

    Max2Play has the function to automatically reinitialize the wifi when you disconnect and it is no wire connection detected. It could be a power problem. Please check that you having not a symbol in the right upper corner.

    We use our Raspberry Pi 3 with a wireless connection. And between the router lies an 0,5m wall and 8m airway. And it works fine, sometimes with a bad connection but it works.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here