MAx2Play Problems on Odroid XU4

Max2Play Home 2016 (en) Forums Max2Play on ODROID U3/C1 MAx2Play Problems on Odroid XU4

This topic contains 6 replies, has 3 voices, and was last updated by  flysurfer premium 1 year, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 15. September 2015 at 8:35 #15675

    Hi,

    I am new to this forum, so a little introduction: I have a couple of years programming and linux experience I am no newbie. Actually I planned to set up all by myself – when I discovered max2play decided to give it a try as I like the plugin architecture.

    By now I ran into some problems which might be related to the xu4 as I already tried a Odroid C something in my company where I can’t remember having had problems a year ago. Of course I installed the XU4 image and nothing else.

    Maybe this might help improving the code. I havent had the time to review the sources by now so I cant spot the issues.

    1. After copying the image with dd and starting the xu4 and starting the webgui on my osx, I tried to resize the filesystem using the entire 32 gb. This fails without a sensible error message. When doing it manually using gparted or commandline it works like expected.

    2. Installation of the non nightly squeezeboxserver works but it doesnt start. Using the nightly 7.9 works like piece of cake.

    3. My 2 TB external USB3 Hard-Disk with a ext4 partition is listed in the ‘Dateisystem / Mount’ but cannot be mounted to a fixed mountpoint. I put a UUID entry in fstab and it worked as expected. I assume it is due to the filesystem, I guess if I use fat or exfat it will work.

    3. Some installations ago I managed to get squeezelite started, it worked from the command line. I tried with the Odroid USB Spdif and without. For some reason it does not start anymore.
    I use all the defaults and tried a lot of output devices and always get an ‘command line’ error. I did not search for the logfile and the command line itself is not displayed. When starting squeezelite in bash it works like charm including the USB SPDIF.

    4. When starting kodi the complete system randomly hangs, to a degree where alt F doesnt show a terminal. Sometimes it simply didnt start. Sometimes it hangs. Using reinitialization did not help. No idea.

    5. When installing the vncserver plugin (when using a clean non kodi install) it starts. I tried to connect to the device with the osx builtin vnc and chicken of the vnc as well as a java jar vnc client. All the clients show a strange behavior: the actual max2play background is shown way down in a slim portrait view. Unusable and never seen sth like that.

    Maybe someone had the same problems and can give advise. Otherwise I will start searching myself…

    best Alex

    21. September 2015 at 3:53 #15746

    If you have eMMC and a SD card and try to re-size the file system it will not work. You have to unplug one of them.

    I thought the switch on the side would say what one I wanted to use. But have to unplug one and then can re-size the file system then.

    I got the Odroid-XU4 and it works real good on mine. No problems. I am very impressed with this max2play.

    • This reply was modified 1 year, 2 months ago by  Raymond Day.
    22. September 2015 at 16:10 #15771

    Hi Alex,

    thanks a lot for your detailed report! I finally found the time to test the things you reported. Expanding the SD-card only works without having plugged any other USB-Sticks, SD-Cards or other filesystems as Raymond wrote.

    2. The Squeezeboxserver in 7.8 is not working because of a perl update to version 5.20. The nightly builds do have CPAN-libraries for perl 5.20 and the default 7.8 is missing this one. I built these for earlier perl versions (e.g. 5.18) and added them to Max2Play – but as 7.9 works I didn’t even recognize this is missing.

    3. The mount-options and fixed mount points for your usb hard drive do not work as expected because of a missing newline in /etc/fstab (the “##USERMOUNT” must be on a new line, but it is not… this is a bug). You may fix this with sed "s/1##USERMOUNT/1\n##USERMOUNT/" /etc/fstab. I also added a patch to the Max2Play-Update-Script to fix this.

    4. Difficult to tell why the hardkernel USB-SPDIF is not working as expected. Maybe it is due to some access rights. You may try: stop and remove Shairport and kodi from Autostart or give Shairport and kodi another soundcard. Start squeezelite from commandline as user “odroid” like the script is doing it. You may see which devices are using the sound output as root in a console with /bin/fuser -v /dev/snd/* 2>&1

    5. Kodi – never experienced such issues – but maybe it is connected with the hardkernel USB-SPDIF stick. Sometimes kodi “hangs” if it has no access to the soundcard.

    6. VNC: The vnc-server tried to open a new display as it couldn’t see the existing one. There was just a small bug in the init script (/etc/init.d/x11vnc) that is fixed now. You just need to get the latest Beta and uninstall -> reinstall the plugin.

    To get the BETA-Versions and the updates I just did, you need to do a “Update to latest Beta” on the Settings page. This is only available if you have the premium license. The changes will also be in the next release (probably within 2 weeks).

    Hope I could help you a little with your questions! I will create a new Image for the XU4 (with all fixes), that comes with the latest Max2Play-version soon.

    Cheers,
    Stefan

    23. September 2015 at 10:29 #15784

    Hi Stefan,

    perfect! THX! Especially:

    4/5. I disconnected the USB SPDIF on Startup and disabled USB Dac in the squeezelite configuration. Kodi started up successfully. Afterwards I connected the SPDIF again and changed to USB-DAC again. Now both works. I assume that one have to configure kodi first and afterwards squeezelite and USB-DAC.

    In general: as u try to provide a linux media server for ‘dummies’ which is more or less plug n play. You should provide some information on the constraints like in this case the Expandfs Button. I assumed that the system is smart enough to find out which device is the one that was booted from and thus expands exactly this. Otherwise a selection option would be perfect.

    I ran into another issue. For some funny reason my Mailaddress that is linked to my license was accepted a couple of days ago and is now not found for premium options which stops me from trying out your vnc fix…

    Despite that: I cannot find any Isengard deb package. Not on your site and not on kodis download pages.

    best,

    Alex

    23. September 2015 at 10:42 #15785

    Oh, two more…:

    1. I found out that HD Transport Stream Files (*.ts) that were recorded from a stick have some issues with kodi: Kodi crashes randomly. When transcoded using:

    ffmpeg -i input.ts -vcodec copy -acodec copy output.mpg

    it works.

    I will transcode my entire library these days…

    2. I have a Sundtek DVB-C Stick. I want to use it as a viderecorder. I used a python script with some tvinfo XML Hack to enable remote programming of the pvr functionality. I want to switch to live-tv and pvr within kodi.
    The sundtek stick is somewhat special compared to other solutions. But I learned from your download page that you created sth. similar for the U3. Why does it only work on U3 and not XU4? Is it worth a try to use the U3 Plugin?

    best,

    Alex

    24. September 2015 at 12:49 #15799

    Hi Alex,

    good to hear you got the SPDIF USB-DAC working! If kodi is set to autostart and squeezelite tries to access the same audio device (e.g. your USB-DAC) there will always be problems because kodi uses pulseaudio and squeezelite uses alsa.

    If your email address is not recognized for a valid license there may be a problem with your internet connection or our server. You might try this: remove the email address -> click save -> insert email address again and save. If it is still not working please send us a mail with your address and we will check this.

    The expansion of SD-cards is not too easy to build fail safe… If a user doesn’t know about the names in a selection this might cause some confusion. As for now, the easiest way is to make sure no other storage device is plugged in just click “expand filesystem”.

    Problems with kodi should be discussed on the Hardkernel forum page as there are the experts who modified Kodi in some ways to work with the ODROID hardware. If you encounter issues you might find help on their page.

    I built the PVR-Addons and Kodi for the U3 and also tried this on the XU4 but ran into problems with starting my compiled kodi. If you want to try to compile kodi on the XU4 and also compile the PVR-Addons this is what I did to compile everything (maybe you get it working? I am not that expert in Kodi development but will try it again if i find some time for it…):

    # Packages
    sudo apt-get install automake bison build-essential cmake curl cvs libJsonCpp-dev default-jre fp-compiler gawk gdc gettext git-core gperf libasound2-dev libass-dev libboost-dev libboost-thread-dev libbz2-dev libcap-dev libcdio-dev libcurl3 libcurl4-gnutls-dev libdbus-1-dev libenca-dev libfontconfig-dev libfreetype6-dev libfribidi-dev libglew-dev libiso9660-dev libjasper-dev libjpeg-dev liblzo2-dev libmad0-dev libmicrohttpd-dev libmodplug-dev libmpeg2-4-dev libmpeg3-dev libmysqlclient-dev libnfs-dev libogg-dev libpcre3-dev libplist-dev libpng-dev libpulse-dev libsdl-dev libsdl-gfx1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl2-dev libsmbclient-dev libsqlite3-dev libssh-dev libssl-dev libtiff-dev libtinyxml-dev libtool libudev-dev libusb-dev libvdpau-dev libvorbisenc2 libxml2-dev libxmu-dev libxrandr-dev libxrender-dev libxslt1-dev libxt-dev libyajl-dev mesa-utils nasm pmount python-dev python-imaging python-sqlite swig unzip yasm zip zlib1g-dev autopoint ccache libavfilter-dev libbluetooth-dev libbluray-dev libcwiid-dev libcwiid1 libmp3lame-dev libpostproc-dev libsamplerate0-dev libswscale-dev libtag1-dev libva-tpi1 liblockdev1 liblockdev1-dev checkinstall doxygen libtag1-dev libgif-dev libgnutls-dev -y
    
    # IMPORTANT ON XU4: /usr/lib/arm-linux-gnueabihf/mali-egl/libglesv2.so verlinken in /usr/lib/arm-linux-gnueabihf/ statt mesa-egl !!!
    
    # KODI latest from Owersun Repository
    cd /opt
    git clone https://github.com/Owersun/xbmc.git -b Isengard
    cd xbmc
    ./bootstrap
    ./configure --enable-x11 --disable-pulse --enable-alsa  --enable-neon --disable-debug --enable-optimizations --enable-ccache --enable-gles --enable-non-free --enable-exynos5 --disable-gl --disable-vdpau --disable-vaapi --disable-crystalhd --disable-openmax --disable-joystick --disable-rsxs --disable-projectm --disable-fishbmc --enable-nfs --disable-afpclient --disable-dvdcss --disable-optical-drive --disable-libbluray --enable-texturepacker --host=armv7a-hardfloat-linux-gnueabi --with-platform=samsung-exynos --with-cpu=cortex-a9 --prefix=/usr/local
    
    FFMPEG_CFLAGS="-march=native -mfloat-abi=hard -mfpu=neon -ftree-vectorize -mvectorize-with-neon-quad -ffast-math -mcpu=cortex-a9 -mtune=cortex-9 -O3 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2" CFLAGS="-march=native -mfloat-abi=hard -mfpu=neon -ftree-vectorize -mvectorize-with-neon-quad -ffast-math -mcpu=cortex-a9 -mtune=cortex-a9 -O3 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2" CXXFLAGS="-march=native -mfloat-abi=hard -mfpu=neon -ftree-vectorize -mvectorize-with-neon-quad -ffast-math -mcpu=cortex-a9 -mtune=cortex-a9 -O3 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2" make -j8
    
    # create .deb file
    checkinstall
    
    # Fix f├╝r Bild, das nicht angezeigt wird (Fehler bei Kodi Start)
    rm -R /usr/lib/arm-linux-gnueabihf/mesa-egl/
    
    ####### PVR Addons Isengard von Liste https://github.com/kodi-pvr  #############
    # Zuerst Kodi Plattform installieren und VORHER kodi in Version 15.1 kompilieren / installieren
    cd /opt
    git clone https://github.com/xbmc/kodi-platform.git
    cd kodi-platform
    cmake -DCMAKE_INSTALL_PREFIX=/usr/local
    make && sudo make install
    
    # Platform installieren: http://forum.kodi.tv/showthread.php?tid=220990&pid=2013039
    cd /opt
    git clone https://github.com/Pulse-Eight/platform.git
    cd platform
    cmake -DCMAKE_INSTALL_PREFIX=/usr/local
    make && sudo make install
    
    # Addons creation
    # Select your Plugins to build
    PLUGINS=( "pvr.hts" "pvr.iptvsimple" "pvr.stalker" "pvr.demo" "pvr.dvbviewer" "pvr.dvblink" "pvr.vuplus")
    
    mkdir /opt/pvrplugins
    mkdir /opt/pvrplugins/build
    pushd /opt/pvrplugins
    
    for PVRPLUGIN in "${PLUGINS[@]}"
    do
    	pushd /opt/pvrplugins
    	echo "Build $PVRPLUGIN"
    	git clone https://github.com/kodi-pvr/$PVRPLUGIN.git --branch=Isengard
    	pushd /opt/pvrplugins/$PVRPLUGIN
    	cmake -DCMAKE_INSTALL_PREFIX=/usr/local
    	make
    	make install
    	cp pvr.* $PVRPLUGIN/
    	# ACHTUNG Versionsnummer muss in Zipfile stehen: $PVRPLUGIN-$VERSION.zip
    	VERSION=$(grep -i "^\s*version=" $PVRPLUGIN/addon.xml | grep -o "[0-9\.]*")
    	zip -r $PVRPLUGIN-$VERSION.zip ./$PVRPLUGIN
    	cp $PVRPLUGIN/addon.xml .
    	cp $PVRPLUGIN-$VERSION.zip /opt/pvrplugins/build 
    done
    

    Cheers,
    Stefan

    24. September 2015 at 17:34 #15810

    Hi,

    I just created the PVR Addons for the ODROID XU4 and Kodi Isengard version 15. You may find the repository here:
    http://cdn.max2play.com/kodi-15-pvr/xu4/

    Now also available for download: Kodi 15 Isengard for ODROID XU4: http://cdn.max2play.com/xu4_xbmc_15.1.91-1_armhf.deb. I will add this to the download section soon.

    Important: before the PVR-Addons do their job you need to do (this will not be neccesary anymore in the next release of Max2Play as I will add this to the installer of Kodi):
    apt-get install fonts-roboto javascript-common libhdhomerun1 libjs-iscroll libjs-jquery libshairport2 -y

    Just tested Big Buck Bunny with the PVR-Demo Plugin in FullHD and it works fine ­čÖé

    Cheers,
    Stefan

    • This reply was modified 1 year, 2 months ago by  flysurfer.
    • This reply was modified 1 year, 2 months ago by  flysurfer.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here