Max2play on RPI3 does not boot

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Max2play on RPI3 does not boot

This topic contains 16 replies, has 6 voices, and was last updated by  Heiner premium 6 months ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • 17. April 2016 at 17:28 #19802

    Dear all,

    I’ve by now tried many things to get Max2Play to boot on my RPI3:
    – several SD cards, closest I got was the “Kernel panic – not syncing: VFS: Unable to mount root fs on unknown-block(179,6)” (in versions 2 and 6).
    – got once a rainbow screen

    – have tried formatting the SD cards; even with a camera (adviced somewhere on the web)
    – downloaded the latest Max2Play, Max2play Jessie (2.29) and the Max2Play-Squeezeplug version (this one gave rainbow).

    I do have Max2Play running (slowly) on an old RPI-A.
    So I am aware of how to get to the web interface and to the LMS.

    The RPI3 seems to work: I installed the Raspberry NOOBS on an SD and got OpenElec and Raspbian running without issues.
    Max2Play on the same SD did not work however. (A freshly bought 16GB Kingston10, actually bought 2).

    By now I really suspect that the images are not fully compatible yet with the RPI3.
    But what puzzles and frustrates me is that others seem to have it running.

    Did someone experience similar problems to get a fresh M2P version running on an RPI3?
    What formatting (tricks) have you used for the SD card?

    By now I am quite frustrated and telling myself I should have gone for an RPI2 – out longer, more stable sw…

    BEst regards


    20. April 2016 at 4:49 #19847

    I have the same problem. The RPI3 does not boot. I have max2play running on 3 other pis but they are earlier models. The RPI3 boots using raspian jessie but not with either the default image or the hifiberry image.

    21. April 2016 at 13:19 #19894

    Hi Jan and Douglas,
    Currently, the ONLY image that works with the RPi3 is the Jessie-based one. This one should, however, not cause any big problems. Please try burning the Jessie image on your SD card using this software:
    This imager cleanses the sd card of any faulty data from previous images.

    22. April 2016 at 13:20 #19901


    I am unable to get my RPI3 to boot with the Max2Play Squeezplug image. I guess this is for the same reason mentioned above. Is there anyway for me to get this working at the moment or will i just have to wait for your latest image release? If the latter, when is that likely to be?

    Sorry I am new to PI and just bought the latest one available. Didn’t realise that the models were o\s specific

    22. April 2016 at 14:25 #19905

    Hi Gringo,
    The SqueezePlug image is our oldest image and stems from an old collaboration with a now inactive project “SqueezePlug”. Thus, we do not plan on making it compatible with new models. For the Raspberry Pi 3 we have the current Jessie image which works perfectly with the RPi3, no waiting necessary. It has all the features of the SqueezePlug image but has steadily been improved and expanded.

    22. April 2016 at 14:29 #19906

    Hi Heiner,

    thanks for the prompt response. Will this allow me to stream to a Squeezebox Boom?


    22. April 2016 at 14:38 #19907

    Yep, the installation of the Squeezebox Server on Max2Play is 7.9 nightly which should work fine with other preexisting Squeezeboxes.

    22. April 2016 at 15:07 #19909

    Hi Heiner,

    Ok I have downloadeded the Jessie image of Max2Play and have burned it to my SD card using USBIT. I had formatted the SD card using SDFormatter so it was a clean install onto an empty card. I have put the card into the RPI3 and connected up LAN and power cables. The main red power led is showing and the led to the left of it initially alternated between red and amber. However, it is now staying red and i can’t get onto my Pi using http://max2play Have i done something wrong?


    22. April 2016 at 15:09 #19910

    Hi Heiner,

    Ignore that last post. Just had one more flash of amber and tried connecting and got in ok. I thought the led nearest the sd card slot was supposed to show green not red with occasional amber flashes?


    22. April 2016 at 19:17 #19913

    Hi Heiner,

    I sure will give it a try this weekend – was abroad all week!
    Thanks for the tip, the only thing I didn’t use yet is the SD card burner you mention.
    With any other tool, the Jessie image didn’t work.

    Crossing my fingers now.

    Thanks and best regards


    23. April 2016 at 17:53 #19921

    Good afternoon.I just tried. No luck.
    System starts to boot but then ends with Kernel Panic not being able to mount root FS on unknown block (179,2)
    Like in many other attempts before I must say …

    Just tried it also with a 2GB card – that also ends with a stack dump. Of course this could be because there is not enough memory.
    Just to check, wrote the NOOBS data from Raspbian to the same SD card. Works.
    Difference is of course this isn’t an image written, but files copied. Needed to format card to Fat32 and ‘standard’ cluster size.

    My conclusion for now is that the max2play image is WAY TOO CRITICAL about its SD card for the RPI3, and/or not thoroughly tested.

    –> Has ANYONE effectively a working RPI3 + Jessie Max2play?
    If so can you tell me what combination of SD card (size and brand), formatting (cluster size) and tool used to write?

    I have a Kingston class 10 16GB SD card.

    Many thanks in advance again!


    23. April 2016 at 21:13 #19927

    Hi Jan,

    I have managed to get my RPI3 working with the Jessie image. Got Squeezeserver up and running and streaming to my Squeezebox and a network share so that MusicBee also has access to my tunes.

    Details as follows:
    16gb Transcend Class 10 SD Card
    RPI Case and power pack

    I formatted the SD Card using SDFormatter
    I then used a PNY SD Card reader to burn (restored) the Jessie image to the SD Card using USBit

    Plugged in network cable and powerpack and let the image do its work. Took about 15 – 20 mins before http://max2play became available.

    Hope this helps.


    23. April 2016 at 22:41 #19929

    Thanks for the development of Max2Play. It’s a great package and easy way to have a headless LMS server on a RasPi.

    I currently have a fully functional Max2Play image running on a Raspi 2 and would like to update my SD card to use in a new Raspi 3. Is there a set of instructions on how to properly update the existing install so the card can work with the new Raspi 3 hardware?

    I have SSH’ed into the setup with the SD card in the Raspi 2 and ran apt-get update and dist-upgrade, as well as upgraded LMS to the 7.9 nightly build and latest M2P software thru the web interface but I only receive a rainbow screen at startup when inserting the SD card into the Raspi 3 and powering up.

    The reason I want to update instead of start fresh with the latest M2P Raspi 3 image available is because I have the difficult to compile Google Music app working on the Raspi 2 and been unable to replicate the necessary steps for recompiling the Google Music app when using the new M2P Raspi 3 image. Any advice would be appreciated.

    I have been able to update my existing M2P SD Card to run on my Raspi 3 (with one issue, squeezelite player is not starting. 294 playback open error).

    Accomplished by performing the above steps as well as updating the Raspi 2 firmware (sudo rpi-update).
    Note: I was OK with breaking functional software/hardware. Results may vary if attempting to replicate.

    • This reply was modified 6 months ago by  P_DoubleU.
    24. April 2016 at 9:46 #19930

    Hi !

    I have the same problem.
    m2p_hifiberry_226_wps.img don´t start up on Raspberry Pi3.
    m2p_Jessie_wps_229.img works better but I am not able to activate the recently bought license.

    I will try it again today to see if I have a better luck.


    24. April 2016 at 12:07 #19931

    Update: yesterday was at a friend’s house. We used a linux computer to clean the SD card and repartition it to original state. Wrote the image to the SD card (still the Kingston 16GB). Result was the same as before: Kernel panic, not able to mount root filesystem (179,2). Friend (safe to say he’s industry expert) is quite convinced the distribution image is wrong and tries to address the wrong partition.
    We moved on to the debian version on the noob and could e.g. see that the fs is mounted on partition 7 etc.

    But Gringo had success. That is why I am now puzzled. I could try his brand of SD card as last resort. All the rest (formatting etc) I have also tried in vain already.

    For now, time to give up, await a new image (someday) and get a RPI2 and try on that one.

    Shame, though.

    Thanks all for the help!


    24. April 2016 at 13:26 #19933

    Hi again!

    I think it is a little bit strange that you don´t mention that Max2Play HiFiBerry Image don´t work with Raspberry Pi 3.
    The download page say that it works with Raspberry Pi all. I have spent hours to get it work, without succeeding.


    25. April 2016 at 14:31 #19947

    Hi guys,
    Sorry for your inconveniences. The jessie-image should really be working on all Raspberry Pi 3’s, for the SD card we recommend at least Class 10 speed but otherwise those should all work as well.
    Regarding your issues, benekm, we will look at our wording on the download page adjust for misunderstandings. Thanks for informing us.

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.

Register here