Max2play on Raspberry P1 (3B+) keeps corrupting SD cards

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Max2play on Raspberry P1 (3B+) keeps corrupting SD cards

This topic contains 11 replies, has 2 voices, and was last updated by  MarioM Moderator 1 month ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 7. März 2021 at 23:22 #50888

    Hi

    I have been running Max2play for a couple of years now on a Raspberry Pi 3B+ as a squeezebox server. Generally it works well. However, I am finding that it crashes seriously fairly regularly (3 times in the last 12 months). Each time, the only way to bring it back to life has been to create a new image on a new SD card (tried power cycling several times). I have been using Kingston class 10 SD 16GByte cards. I had been using m2p_stretch_rpi_v249.img until about 3 months ago. Since then I have been using m2p_buster_rpi-v253_new.img and this has now just crashed again. The pi does not boot up and I am about to reflash onto yet another new card. A few notes about the installation

    1. Music is located on a USB key plugges into the pi (not the SD card which is only used for the OS)
    2. Connected to my LAN via ethernet
    3. Powered from official Raspberry PSU and this plugged into a (quality) UPS
    4. I have 8 Squeezebox clients served by the pi

    Any guidance please? It is getting tiresome (and costly) replacing the SD cards. SHould I be using a different brand or type?

    Thanks
    Mike

    9. März 2021 at 16:05 #50898

    Hi Mike,

    There could be many reasons why your SD card gets corrupted. Even if you use an official power supply for the Raspberry Pi, the psu is always a possible reason for such problems. Of course, the SD card itself can also cause the problems. However, I cannot recommend any other brand to you. We primarily use SanDisk cards here on site. However, at least in theory there should not be any serious quality differences between Class 10 SD cards. To rule out that it is a software problem on the part of Max2Play: Which plugins are installed and activated on the Pi?
    Ultimately, the Pi could damage the SD cards over time. If you have another (maybe newer) Pi to test, I would try this out with our image and see if the same problems arise there.

    As I said, the cause of such problems is always difficult to pinpoint.

    9. März 2021 at 16:40 #50903

    Thanks for your reply.
    To answer your questions. I did not install any plugins – only LMS (the latest 7.9 version).
    I don’t have another pi unfortunately. And would prefer not to buy one as I already have used 4 sd cards as well as paying the licensing for max2play.

    Do other users have such a high failure rate of SD cards? I have now encountered this problem 3 times in just over 1 year. The last time (before 2 days ago) was only 3 months ago. Such a rate of attrition is not sustainable for me.

    10. März 2021 at 14:36 #50910

    Hi Mike,

    That’s understandable, there shouldn’t be so much wear and tear. There have been cases of defective SD cards, but these could usually be traced back to defective or poor hardware. Please monitor our health checker in the web interface in the future. There you can see if there are power supply problems or if the Pi’s CPU is reaching its limits.

    Can you describe to me how you set up Max2Play, i.e. what specific settings you made?

    10. März 2021 at 15:19 #50914

    Hi Mario. OK it’s pretty simple. Each time I have replaced the SD card I have done this

    1. Download latest image from your website
    2. Burn to SD card using Win32 disk imager, following your instructions
    3. Install LMS from the max2play embedded web page „Squeezebox Server Start Installation“
    4. Mount the USB drive in max 2play using „external drives on max2play – mountpoints for USB storage“ (my music is on a USB stick plugged into the pi)
    5. Configure LMS to point to the mounted external USB stick using LMS web management interface. Then have LMS rescan (and build) my music library
    6. Install „BBC sounds“ plugin in LMS
    7. Mount the USB volume in max2play so it can be accessed from my LAN using „sambashares on Max2play – setup network share paths“

    …that is all. Nothing else

    10. März 2021 at 17:21 #50915

    Hi Mike,

    Okay, then Max2Play really shouldn’t be causing the problems. For example, if you had manually expanded the file system, that could have been a problem. But your approach looks clean. How strong is your power supply? Although connecting a USB stick shouldn’t draw much power, we should still check whether the power supply isn’t too weak. Do you have the option of connecting the Pi directly to a „normal“ socket for a longer period of time?

    10. März 2021 at 19:20 #50916

    What do you mean by a „longer period of time“?

    11. März 2021 at 16:18 #50931

    Hi Mike,

    Please excuse me for not making myself clear. Since your SD cards corrupt after a few months, it would be good to test a „normal“ power connection via a socket over a similar period of time. But that would just be another attempt to narrow down the cause of the problem.

    11. März 2021 at 18:26 #50933

    When you say test a normal power connection, do you mean plug my pi into a non-ups outlet? Or do you mean something else?

    12. März 2021 at 15:51 #50936

    Hi pomeroy,

    Presumably that won’t be the reason for the SD card problems, because the ups should rather improve the power supply. But yeah, maybe you can plug the Pi into a normal power outlet without an interposed ups, to rule out a faulty power supply.

    12. März 2021 at 16:49 #50937

    So that is not what you meant by „Do you have the option of connecting the Pi directly to a „normal“ socket for a longer period of time“?

    In any case, the UPS is not the cause. I have had the pi in several different scenarios (without UPS, on UPS#1 which has my CCTV NVR connected and on UPS#2 which has my synology NAS connected) and the SD card failure has occurred in each of these scenarios.

    So, what indeed do you mean by „Do you have the option of connecting the Pi directly to a „normal“ socket for a longer period of time“

    15. März 2021 at 17:02 #50943

    Hi pomeroy,

    If you have already tried operating the system without a UPS, my question was already obsolete. Therefore I can only recommend you to replace the hardware on your system individually and step by step to find out where the problem is. If it’s not the power supply then the Pi or SD card will be causing the problem.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here