MAX2PLAY meldet Squeezelite läuft, LMS meldet 'Kein Player gefunden'.

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI MAX2PLAY meldet Squeezelite läuft, LMS meldet 'Kein Player gefunden'.

This topic contains 4 replies, has 2 voices, and was last updated by  Pereybere 1 day, 3 hours ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 15. November 2016 at 18:43 #23916

    Hallo,
    ich teste gerade die Machbarkeit meiner Anforderung mit MAX2PLAY. Ich möchte mit 2 Raspberry Pi ein Multiroom Musiksystem aufbauen. Einer soll Client- und Server mit lokaler Speicherung der mp3 Dateien sein, der andere nur Client mit zeitgleicher Wiedergabe wie der Serverclient. Die Musik soll im Zufallsmix wiedergegeben werden, es sind ca. 100 Titel und es gibt keine weiteren Anforderungen an Start, besonderer Reihenfolge oder Wiederholung. Wichtig ist jedoch, daß es beide Komponenten ohne weitere Bedienung in den Wiedergabemodus gehen. Also Strom an, booten, Musik kommt. Ausschalten per crontab und anschließendem Schalten der zwischengeschlteten Funksteckdosen.
    Da ich nicht sicher bin, ob das überhaupt klappt möchte ich noch kein Geld in weitere Hw oder Sw stecken bis ich sicher bin, daß es geht. Ich habe mir also das Image m2p_rpi3_default_234_wps.img heruntergeladen und installiert und im ersten Schritt die entsprechenden Minimalkonfigurationen für den 3,5mm Klinkenstecker und der internen Soundkarte vorgenommen. Mein erstes Problem ist, wie der Titel schon sagt, daß MAX2PLAY meldet Squeezelite läuft, der LMS hingegen meldet ‘Kein Player gefunden’. Nach dem manuellen Restart von Squeezelite im M2P wird der Player auch im LMS gefunden, bis zum nächsten Reboot. Gelegentlich klappt das aber doch und da kam gleich das nächste Problem. Trotz mehrstündiger Parametrierung in den Audioeinstellungen ist es mir nicht gelungen, daß direkt nach dem Booten Musik abgespielt wurde, das mußte ich dann immer von Hand starten.
    Was ist falsch?

    16. November 2016 at 8:07 #23923

    Hallo,

    verwendest du jetzt einen oder 2 PI? Ich gehe mal davon aus, dass du nur einen verwendest und sowohl Server als auch Client auf dem Pi laufen. Dass LMS deinen Player nicht findet ´, liegt vermutlich daran, dass der Squeezlite Dienst vor dem LMS mit dem starten fertig ist, dadurch gehts auch nach dem Dienstneustart.
    Das Starten vom Abspielen der Musik wird vom LMS erledigt, die Audioeinstellungen betreffen nur den Client.
    Das automatische Starten vom abspielen lässt sich am einfachsten über ein Script mit einem Webaufruf erledigen. Die URL hab ich grad nicht bei der Hand (kann ich erst am WE raussuchen), aber da gibts Infos beim Plugin für die Sprachsteuerung.

    lg, Andy

    16. November 2016 at 21:33 #23931

    Hallo Andy,
    vielen Dank für deine Antwort. Bisher verwende ich nur einen PI und taste mich an die Lösung für den kombinierten Server/Client heran. Wenn der so läuft wie ich will, kommt der zweite PI ins Spiel. Ohne funktionierenden Server muß ich mich nicht schon um den Client kümmern.
    Ich habe zwar schon seit einigen Jahren eine Squeezebox Touch die ich zum Hören von Internetradiosendern nutze, die Client/Server Konfiguration des LMS ist für mich allerdings ziemlich neu.
    Wenn der Server aus deinen o.g. Gründen keinen Client findet ist dessen bisherige Wiedergabeliste leer und er kann keine Titel abspielen. Das ist das erste Problem nach dem Booten. Wäre sie gefüllt müßte man die Wiedergabe mit deinem Script starten können, es wäre nett, wenn du die URL nachreichen könntest. Danach mache ich mich an den Client.
    Nochmal zum Hintergrund, ich möchte zwei Räume mit der gleichen Musik ‘beschallen’. Das Hochfahren, synchronisieren und Starten der Wiedergabe auf beiden PIs sollte komplett ohne weiteres manuelles Zutun erfolgen wie beim Einschalten eines normalen UKW Radios.

    23. November 2016 at 22:30 #24153

    Hallo,

    sorry dass es ein paar Tage länger gedauert hat. Hier die versprochene URL:

    Start Playing: http://SQUEEBOXSERVERIP:PORT/status.html?p0=play&player=MACADRESS

    lg, Andy

    • This reply was modified 2 weeks ago by  orcas.cc.
    7. December 2016 at 17:00 #24642

    Danke für deine Antwort. Ich bin jetzt auf Snapcast umgestiegen, das ist für meine minimalen Ansprüche einfacher und funktioniert ohne manuellen Eingriff. Stecker rein, Server startet automatisch und spielt Musik ab, genauso ist es beim Client. Musikwiedergabe von über 100 mp3 Dateien per mpd und mpc im Modus random, shuffle und repeat.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here