max2play Installation on Raspberry 1 Mod. A+ does not work

Max2Play Home 2016 (en) Forums SD-Card Imaging and getting started max2play Installation on Raspberry 1 Mod. A+ does not work

This topic contains 4 replies, has 2 voices, and was last updated by  marc premium 11 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 14. September 2019 at 15:15 #47082

    Dear all,

    I have a few month old topic where I tried to pin-down disconnect issues with several of my max2play clients. It turned out, all devices affected were the Raspberry 1 A+ devices, more details on the old issue can be found here

    I am writing this since I never solved the issue and unfortunately no one here could help how to resolve it and gave up after several days of fiddling around. I was waiting to see if a newer version of max2play would solve it. This is my list of clients:

    1. Raspberry 1 A+ with HifiBerry DAC+ and EDIMAX 7811UN WLAN from max2play shop
    2. Raspberry 1 A+ with HifiBerry DAC+ Pro and EDIMAX 7811UN WLAN from max2play shop
    3. Raspberry 1 A+ with HifiBerry Digi+ and EDIMAX 7811UN WLAN from max2play shop
    4. Raspberry Zero W
    5. Raspberry Zero W

    Hence for half a year I could only use my Zero devices. They recently showed me that a new version 2.50 was available so I tried the new version with the Pi 1 A+ devices. Still, I can’t install these versions successfully. The symptoms:

    1. With a freshly installed SDcard with the newest max2play image (which has version 2.49 although online updates of the 2 working Zeros show that a version 2.5 is available) the systems comes-up.
    2. Any WPS-handshake fails during boot.
    3. Access point mode does not work, openen max2play WLAN is visible, clients can not connect after password entry -> „invalid password“ using „mypasscode“ as password.
    4. Attaching a keyboard, mouse and monitor to setup manually shows the following behavior:
    a. Every user input at the GUI and the max2play web-interface is painstakingly slow. Every user-input is delayed and laggy, the browser seems to reload every 10 seconds to refresh.
    b. To manually enter the network data at the broser’s GUI fails with this message: „Something went wrong in last install attempt – Deleting Progressfile“
    5. The boot.log shows no real problems besides some network-related errors (e.g., dhcpd).
    6. A closer inspection of the boot output displays one notable error line as the first output before the boot messages appear and scroll this error out. It usually is scrolled out to fast by all messages hence it took me a while to really see it: „[ 0.326776] cma: cma_alloc: alloc failed, req-size: 2025 pages, ret: -12“

    So here I am, it seems that the error from 6. is not a real problem, is it? Just a bit of web search revealed that this is a known problem with raspbian for some time. But in any case, trying to install the latest (and also the one before) image of max2play with wireless network does not work on Raspberry 1 A+ and EDIMAX 7811UN adaptors which I both bought here at the shop. Any help would be highly appreciated, my setup with 5 clients worked wonderful for a long time but now the whole thing broke (waf is hampered drastically).

    best

    • This topic was modified 1 year ago by  marc.
    • This topic was modified 1 year ago by  marc. Reason: Added version of WLAN adapter and access point problem
    23. September 2019 at 9:40 #47131

    Hello marc,

    Sorry about the late reply, I was out office last week due to illness.

    With our newer images we mainly focused on compatibility with the new versions of Raspberry Pi coming out.

    Thank you for pointing out this problem with A+.

    Have you tried using the Wheezy version of Max2Play from our legacy downloads section?

    1. Oktober 2019 at 6:37 #47207

    Hi Heiner and all,

    I have now tried the legacy images with my different pis and DACs, working my way down from the newest to the oldest images. Turns out that I had to use all 3 images to get the 5 different setups working (for now). The working setups looks like this (please not that it is a bit different from the one I listed initially where I made one mistake):

    1. Raspberry 1 A+, IQaudIO Pi-AMP+, EDIMAX 7811UN WLAN -> m2p_default_226_wps.img
    2. Raspberry 1 A+, HifiBerry DAC+ Pro (B+ / PI 2/3), EDIMAX 7811UN WLAN -> m2p_rpi_default_244_wps_ap_expand.img
    3. Raspberry 1 A+, HifiBerry Digi+, EDIMAX 7811UN WLAN -> m2p_rpi_default_244_wps_ap_expand.img
    4. Raspberry Zero W, HifiBerry DAC+ Zero 1.0.1 -> m2p_stretch_rpi_v249.img
    5. Raspberry Zero W, HifiBerry DAC+ Zero 1.0.1 -> m2p_stretch_rpi_v249.img

    Notably, I could then upgrade the max2play version online on all installations to the newest release, 2.50. An initial test with the following setup did not conclude, here I had to switch to the Raspberry Zero W:

    6. Raspberry Zero, HifiBerry DAC+ Zero 1.0.1, EDIMAX 7811UN WLAN

    As for now, all systems are working for 3 days and reliably stay in the network. I am noting this since my initial venture started because some of the devices were disappearing from the network after undetermined time intervals and without any good handle how to debug. Hence I though a fresh install would solve this problem. However, it just showed the incompatibility with the images as identified now.

    I hope this is helpful for anyone with similar problems. However, it is not an ideal state since I now forced to run three different versions of raspbian with two outdated images. This is increasing administration load and it is canceling out any newer patches, e.g., needed for security reasons.

    • This reply was modified 11 months, 3 weeks ago by  marc.
    1. Oktober 2019 at 10:01 #47211

    Hi marc,

    Thanks for the detailed update on this. We will try to tackle these issues with the different boards in an upcoming version.

    We had a lot of issues with implementing the Zero W because of its different structure, I assume the A+ has similar differences that cause compatibility issues.

    Is there a specific reason why one of the A+ Pi’s worked with the 2.26 wheezy instead of the 2.44 jessie? Were there other differences in these setups aside from the sound cards?

    1. Oktober 2019 at 11:57 #47213

    Hi Heiner,

    the specific reason why one of the A+ Pi’s worked with the 2.26 wheezy instead of the 2.44 jessie is just the sound card and the 2.26 device has a more powerful power supply since it is using an amp. The rest is identical.

    best

    Marc

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here