Max2play Bluetooth – Use Echo and fire TV as sources

Max2Play Home Forums Max2Play Add-ons Max2play Bluetooth – Use Echo and fire TV as sources

Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • 26. Januar 2023 at 13:43 #52613

    Hello All,

    I have installed Max2Play on RPI 3 with HiFiBerry Digi+ sound card and an external WiFi dongle !

    I have then connected the above M2P device to a Sound Bar using the optical cable !

    I have also enabled SqueezeboxServer and Squeezelite Player on the same device. I also enabled Bluetooth plugin and i can stream from my phones to M2P device (when connected via Bluetooth) and appreciate all the features of M2P in this regard !

    However I am struck in below two issues

    1. Whenever I connect my Echo Show 5 to M2P. It’s is successfully paired and connected ! But when I try asking something to Alexa, I hear the response from Echo Show 5 only and not from the soundbar connected to M2P. The issue is Echo is simply not acting as a source to my M2P device !

    2. I want to connect my Fire TV stick via Bluetooth to M2P device. However fire tv is unable to see the M2P device during scanning ! Also the M2P Bluetooth Page does not show any fire tv stick while clicking on the scan button !

    I have looked around the forum and general search but could not find any feasible solution. Could you please help on above two issues !

    26. Januar 2023 at 14:22 #52614

    Just an update to echo problem. As someone on the the forum mentioned, i did the below steps:

    1. Connect Echo. Sound Still comes from echo and not from connected M2P device.
    2. I asked Alexa to disconnect Bluetooth and Connect Bluetooth.
    3. Magically, when i ask anything to Alexa now, sound comes from M2P device !

    Its just annoying to disconnect and connect alexa everytime to ensure alexa can act as a source to m2P device ! Any fix for this ?

    Also I am still unable to connect Fire TV Stick to M2P device via Bluetooth.

    Also, to add, If i am able to connect Fire Tv Stick, can M2P automatically switch the between echo and Fire TV based on whats playing ?

    28. Januar 2023 at 17:26 #52619

    can someone please help, i am unable to still use Fire TV Stick as source !
    I was able to conenct my phone and echo show successfully to M2P Device. No matter whaterver i try fire tv stick is unable to discover M2P !!! Could someone please help… Looking for answers all over since 3-4 days for help !!!

    I tried the following :

    1. Tried Manually discovering as sugegsted in https://www.max2play.com/en/forums/topic/using-pi-as-bluetooth-speaker-make-pairing-easier/ – Never worked for me

    2. Disabled on board Wifi, Enabled Wifi Dongle conencted to a powered usb hsb, Using onboard Bluetooth – Fire Tv is not discovered

    3. Onboard Wifi, TPLINK UB400 Bluetooth stick – Fire Tv is not discovered

    4. Onboard Wifi, TPLINK UB400 Bluetooth – installed realtek bluetooth firmware – M2P is not discoverable by any device – so ruled out this approach.

    Could someone please please help or give insights how to connect Fire TV as audio source to M2P Device ???


    @Heiner
    @flysurfer could you please help…

    31. Januar 2023 at 15:46 #52626

    Hi vishnu,

    Max2Play does not currently appear to be compatible with Fire TV. The Bluetooth pairing of Max2Play is set up in such a way that the connection always starts from the Max2Play device. For the connection to the Fire TV, however, it is necessary that the pairing is initialised by the Fire TV.
    Maybe someone else in the forum knows a workaround, but otherwise you cannot currently establish a connection to the Fire TV via Bluetooth.

    31. Januar 2023 at 16:10 #52628

    Thanks MarioM, for letting me know this though little disappointing to know fire Tv is currently not supported ! Is is something that will be supported in the near future ?

    Also I have seen someone on the forum as per below link.

    Using PI as Bluetooth-Speaker – Make Pairing easier

    They seem to successfully pair the Fire TV manually ! I have tried it but it never worked for me !!!

    2. Februar 2023 at 14:55 #52635

    We are not currently planning to revise the pairing in the Bluetooth plugin, as it works for the primary use cases we intended it for.

    It may be that the Fire TV only lists Bluetooth devices that correspond to a certain Bluetooth class. That is why sudo hciconfig hci0 class 0x00041C was used in the other thread to customise this class. You would have to check whether the class was updated correctly in your case. If you enter hciconfig hci0 class, the class should be displayed. Also when entering [bluetooth]# discoverable on the same class should be displayed.

    2. Februar 2023 at 16:06 #52637

    Thanks Mario. Yes i have setup the bluetooth class to 0x00041C and did verify it using the hciconfig too. But my Fire TV stick was still unable to discover the M2P device connected to my Sound bar !!! Perhaps i will check the bluetooth class of devices using http://bluetooth-pentest.narod.ru/software/bluetooth_class_of_device-service_generator.html

    I could see some thing like 0x41C – for Majority Device Class – Audio/Video & Minor Device Class – Portable Audio

    I could not generate 0x00041C with any combination and perhaps that why it didnt worked. I will try to generate various blueetooth classes and update here if some class is discovered by Fire TV !

    3. Februar 2023 at 17:30 #52639

    Finally I got it working !!! I was able to connect my Fire TV Stick to M2P Bluetooth Receiver.
    I followed the original instructions from
    https://www.max2play.com/en/forums/topic/using-pi-as-bluetooth-speaker-make-pairing-easier/ but unable to setup successfully.

    As mentioned in above post, I did set the class to 0x00041C as below:

    sudo hciconfig hci0 class 0x00041C

    However whenever i try to make the bluetooth adapter in M2P discoverable it gets reverted back to 0x0c0000

    So, I added the below line to /etc/bluetooth/main.conf in Default device class section.
    Class = 0x200414

    so it looks like:
    # Default device class. Only the major and minor device class bits are
    # considered. Defaults to ‚0x000000‘.
    #Class = 0x000100
    Class = 0x200414

    and then run
    sudo systemctl status bluetooth.service

    I used 0x200414 as my device class and it worked perfectly. I included more classes below that you can test ! i generated them using
    http://bluetooth-pentest.narod.ru/software/bluetooth_class_of_device-service_generator.html

    ================================ Device Classes ====================================
    Major Service Class | Major Device Class | Minor Device Class | Bluetooth Code
    ——————– ——————– ———————– —————-
    Audio Audio,Video Loudspeaker 0x200414
    Audio, Video Portable Audio 0x41C
    Audio Audio,Video Portable Audio 0x20041C
    Audio Audio,Video HiFi Audio Device 0x200428

    ======================================================================================

    Also i ssh’ed into M2P device, and then

    sudo hciconfig -a (check whether its showing the new class)
    sudo bluetoothctl (to go into bluetooth prompt)
    discoverable on
    pairable on
    agent on
    default-agent on

    Now Start Fire TV, and scan for bluetooth devices, Your M2P should definitely show up, Pair it and also ensure you fill in the prompts you get on bluetoothctl prompt on your M2P device. Thats it Enjoy
    the Fire Tv sound on M2P connected Speaker !!

    7. Februar 2023 at 15:25 #52647

    That’s great news vishnu! I’m glad you found a solution. Thank you for sharing it with the community.

    20. Mai 2023 at 0:35 #52838

    hello i seem to be having problem again ! Blutooth service on M2P somehow failed. So tried to restart bluetooth service which started fine. Fire Tv was unable to connect. So removed and tried to repair using bluetoothctl. It pairs and immediately gets disconnected ! can someone please help ?

    [bluetooth]# discoverable on
    Changing discoverable on succeeded
    [CHG] Controller 00:1A:7D:DA:71:15 Discoverable: yes
    [bluetooth]# pairable on
    Changing pairable on succeeded
    [CHG] Controller 00:1A:7D:DA:71:15 Pairable: yes
    [bluetooth]# agent on
    Agent registered
    [bluetooth]# default-agent
    Default agent request successful
    [NEW] Device D8:BE:65:19:E5:FB SV’s Fire TV
    Request confirmation
    [agent] Confirm passkey 742133 (yes/no): yes
    [CHG] Device D8:BE:65:19:E5:FB Modalias: bluetooth:v0171p03A1d0100
    [CHG] Device D8:BE:65:19:E5:FB UUIDs: 0000110a-0000-1000-8000-00805f9b34fb
    [CHG] Device D8:BE:65:19:E5:FB UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
    [CHG] Device D8:BE:65:19:E5:FB UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
    [CHG] Device D8:BE:65:19:E5:FB UUIDs: 00001200-0000-1000-8000-00805f9b34fb
    [CHG] Device D8:BE:65:19:E5:FB UUIDs: 00001800-0000-1000-8000-00805f9b34fb
    [CHG] Device D8:BE:65:19:E5:FB UUIDs: 00001801-0000-1000-8000-00805f9b34fb
    [CHG] Device D8:BE:65:19:E5:FB ServicesResolved: yes
    [CHG] Device D8:BE:65:19:E5:FB Paired: yes
    [CHG] Device D8:BE:65:19:E5:FB ServicesResolved: no
    [CHG] Device D8:BE:65:19:E5:FB Connected: no

    also tried to connect from UI and get the below error in debug

    If you connected Bluetooth Speakers, make sure to set the soundcard of your audioplayers to bluetooth as audio output! You need to restart your Audioplayer if the Bluetooth Device changed.
    If you connected a Smartphone to stream to Squeezebox Server, NO further setting to your soundcard is needed (do NOT set your soundcard to bluealsa)!
    Agent registered
    agent off
    Agent unregistered
    agent NoInputNoOutput
    devices
    Device D8:BE:65:19:E5:FB SV’s Fire TV
    Device C0:FB:F9:60:1D:BE osmc
    Agent registered
    paired-devices
    Device D8:BE:65:19:E5:FB SV’s Fire TV
    Device C0:FB:F9:60:1D:BE osmc
    connect D8:BE:65:19:E5:FB
    Attempting to connect to D8:BE:65:19:E5:FB
    Failed to connect: org.bluez.Error.Failed
    quit

    EDIT:
    Restarting the M2P device & repairing worked ! that seems to have did the trick

    • This reply was modified 9 months, 2 weeks ago by vishnu sure.
    • This reply was modified 9 months, 2 weeks ago by vishnu sure.
Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here