Max2Play Airplay stability

This topic contains 3 replies, has 3 voices, and was last updated by  phamd4 premium 3 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 8. February 2016 at 12:57 #18403

    Hi everyone.
    I’ve installed max2play and purchase premium license to use all the features.
    But I noticed that airplay works with much bigger delay that, say, pi musicbox, when I try it on the same raspberry pi B.
    Even if Squeezelite is inactive. I have also tried to use shairport plugin on LMS server on Mac Mini and Squeezebox server on my Raspberry Pi (instead LMS server on MAc Mini that was stopped) with shairport plugin. But result is slow and unstable (often devices connected to Raspberry via Airplay but I can’t hear any sound). But Pi Musicbox airplay works well and very stable.
    But I want to Use max2play because multiroom capabilities, streaming services and airport (with automatically switching between airplay and squeezebox).
    So what will the most effective and stable way to use max2play in my house where I have Mac Mini, 2 or more Raspberry pi with max2play. And I want to use raspberry Pi as Zone Players for Deezer, Tuneln etc. (played synchronyzed or different music) and have an ability to stable play Airplay for each Zone with minimal delay?

    19. February 2016 at 15:05 #18595

    Hi Malina,

    there should not be any delay or bad quality in airplay with shairport – even on the older Rapsberry Pi B.

    First thing: what version of Max2Play do you use? Did you try it with the latest Max2Play 2.27 from the download page?

    A few ideas:
    – remove squeezelite from autostart and stop it
    – remove kodi from autostart and stop it if it is running
    – check the load of your pi in the Debug output on the settings page of the webinterface (at the bottom)
    – do you have WiFi or LAN connection?
    – do you output audio with HDMI or with a separate DAC or soundcard (if so, try an other sound output)

    24. February 2016 at 16:50 #18718

    Hi flysurfer!
    Thank you for answer.
    – remove squeezelite from autostart and stop it
    I would like to use both squeezelite and airplay.

    – remove kodi from autostart and stop it if it is running
    It’s not running

    – check the load of your pi in the Debug output on the settings page of the webinterface (at the bottom)
    OK, I’ll try

    – do you have WiFi or LAN connection?
    Wi-Fi

    – do you output audio with HDMI or with a separate DAC or soundcard (if so, try an other sound output)
    USB Soundcard

    Now airplay works better.
    I think it’s home Wi-Fi network issues.

    18. August 2016 at 4:11 #22316

    Hi,

    I am also having the same issue, running rpi3 and using hifiberry digi+ my sound quality is find however everytime I try to stream music the sound play for like 3 min then studder/silience for about 10 sec then play again.

    Do you guys found a fix for it yet? Thank you

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here