[SOLVED] M2P, RP 3B+ and AMP2

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] M2P, RP 3B+ and AMP2

This topic contains 3 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 26. September 2019 at 9:05 #47164

    Hello everybody,
    first of all, I love your product. A very nice way to build a controlable multiroom player. But I’ve got still some issues here.

    I want a multiroom setup where the server is in the kitchen (and configurated fine already) and a another in the livingroom for music from server’s squeezebox and Kodi from itself.

    Setup
    Raspberry 3 B+
    HifiBerry AMP2
    –> bought as a bundle from your shop
    M2P licence

    Problem 1:
    Get passive speakers to work with AMP2. Is there a way to check if Hifiberry’s AMP2 is sending sound to the output (just to make sure it’s not a problem with the speaker), because till now I couldn’t get my speaker to play a sound?

    Problem 2:
    If Kodi streams to screen via HDMI I still want to hear the sound from the passive speakers.
    So I assume I have to change standard output when HDMI is connected in Raspberry settings. But only standard (HDMI), jack and HDMI are available in the drop down menu.
    Well, I now assume to disable raspberry’s internal on-board sound. –> If doing so, squeezelite stops working and cannot be re-started.
    Do I have to change settings in the extended audioplayer menu?

    I already tried several setups, always with the newest image from your homepage and with newest M2P version. Do kernel and package updates help? I sometimes did that but often appear problems when terminal is updating Apache2.
    I already got up a working multiroom setup when choosing ’none‘ as Raspberry’s soundcard and put earphones in the RP’s jack plug. That works fine.

    But I want to use AMP2’s passive speaker outputs.
    Any help welcome!!
    Thanks a lot!

    27. September 2019 at 10:03 #47168

    Hi hoge,

    For Kodi you need to deactivate the build-in audio in Raspberry Settings and reboot to make the AMP2 the first slot. Then you need to make sure to have „hw:0“ in the command line options of Squeezelite to have it also recognize that it’s now in the first slot.

    27. September 2019 at 22:23 #47190

    Yepp, that solved the problem. did a fresh install and followed your steps.
    Thanks!

    30. September 2019 at 10:03 #47195

    Great, thanks for letting me know! 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here