[SOLVED] M2P on rPi with touchscreen. Stops at login: No longer boots into GUI

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] M2P on rPi with touchscreen. Stops at login: No longer boots into GUI

This topic contains 8 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year, 1 month ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 8. August 2019 at 12:10 #46707

    Hi,

    I have a rPi with a touchscreen. No keyboard, its just a touchscreen. M2P boots up to the login screen, at which point the screen goes dark for a second and then the boot screen and login: prompt reappears and thats it

    No GUI, nothing,

    I can connect from another computer to the M2P box via web and everything looks correct there
    I can SSH in via user pi / max2play

    Any ideas?

    9. August 2019 at 11:05 #46716

    Hi Nugents,

    Usually, Max2Play should boot into a simple desktop. However, our OS is not made for desktop use. You need to choose the GUI you want to use in our web interface and set it to autostart to boot into it. For Squeezebox control, you need Jivelite. For video playback, you can use Kodi.

    9. August 2019 at 18:12 #46736

    I am running squeezelite which is running if I control from the squeezebox server.

    But

    I now just get this null when the rPi boots. I used to get a screen that I could use to control things with

    Jivelite won’t run

    Restart Desktop-Manager completed (initialized Display)
    Trying to launch … NOT successful Click here to show detailed information

    JiveLite 0.1.0
    No protocol specified
    No protocol specified

    I have even tried re-installing jivelite – but that doesn’t help.

    12. August 2019 at 10:49 #46749

    Hi Nugents,

    Seems like something is stopping the system from entering the desktop. Which GUI do you have in autostart (tick in the web interface)? If you have none, please set Jivelite to autostart and reboot. If you have one, please remove it and reboot to rule out a conflict.

    12. August 2019 at 11:21 #46754

    I have jivelite set to autostart

    Settings/Reboot – Autostart Desktop is ticked
    Under jivelite – autostart jivelight and autohide Panel are ticked

    What else do I need to tick / untick?

    Sean

    12. August 2019 at 11:58 #46755

    Hi Sean,

    Please remove the tick on Settings/Reboot for autostart desktop and reboot the device.

    27. August 2019 at 20:00 #46884

    Sorry for the delay – that didn’t work. I am currently going to rebuild the SD, reinstalling everything to see if that fixes the issue.

    Just as an extra comment – being able to install on a USB would be really helpful. That way I wouldn’t have to dismantle everything to get at the SD card

    Sean

    27. August 2019 at 22:20 #46885

    Reformatted an re-installed the SD Card

    All working now
    Looks like some form of corruption somewhere I guess

    Sean

    28. August 2019 at 10:33 #46888

    Hi Sean,

    Thanks for following up and letting me know. Glad to hear it’s working now 🙂

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here