[SOLVED] LMS Discovery over 2 or more subnets

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] LMS Discovery over 2 or more subnets

This topic contains 3 replies, has 2 voices, and was last updated by  Jerome 2 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 1. Mai 2019 at 3:45 #45194

    Hi there,

    I have been working with Squeezebox/Logitech Media Server on 2 Raspberry Pis running Max2Play.

    The two device setups are below.

    SERVER DEVICE
    Version 2.47
    Raspberry PI 3
    License Activated
    Squeeze box server installed and running (Nightly 7.9)
    Squeezelite running

    CLIENT DEVICE
    Version 2.47
    Raspberry PI B+
    License Activated
    Squeezelite running

    I’ve successfully set the machines to run on a single subnet (172.17.1.x). When opening LMS by clicking on the „Open Squeezebox Webadministration“ button I have both the Server’s player and the discovered client device’s player. This is brilliant. I can play music and even syncronise the music to play on both devices.

    Here’s the problem: I have another site on a seperate subnet where I want the client to be installed. This means I’ll have the server on 172.17.1.x and the client on 172.17.2.x. The sites are well established and route. When moving the client device to the site/subnet the server no longer ‚discovers‘ the client.

    Can I just find out if I am missing some additional configuration to achieve this goal of detection over different subnets or is this a limitation in LMS that force discovery of clients only within the local subnet.

    Appreciate all help. Kind regards.

    3. Mai 2019 at 11:22 #45235

    Hello Jerome,

    Have you tried adding the IP address of the server unit in your player unit’s Squeezelite command line options? Here’s the syntax:
    -s <server>[:<port>] Connect to specified server, otherwise uses autodiscovery to find server

    Here’s also a topic form slimdevices that gets into this subject

    30. Oktober 2019 at 10:10 #47451

    Hi Heiner,

    Thank you so much for replying. I hadn’t realised you had answered and I still had not found a solution to this issue of finding the discovery server over different subnets.

    Using the command -s <server>[:<port>] seems like just the solution I was looking for. When I run the command:

    sudo squeezelite -s 172.17.9.x :3483

    I get the error: -bash: squeezelite: command not found

    I’ve tried to locate where the sqeezelite program exists and run the program from there but still meet with the „command not found“ result. I’ve also downloaded the run command web plugin and tried the command there but that also returns an error.

    If you are able to help so I can run that command that would be great!

    Thanks,
    Jerome

    4. November 2019 at 6:03 #47467

    Think we were able to solve this so I’ll put the solution down in case there is anyone else trying to get this to work.

    You need to download and install sqeezelite on the remote pi (seems strange given that it is apparently already there), then you are able to use the commandline sudo squeezelite-s <server>[:<port>] from the remote pi.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here