LMS Cannot Find Music on Thumb Drive

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI LMS Cannot Find Music on Thumb Drive

This topic contains 22 replies, has 2 voices, and was last updated by  Joe Gorin premium 9 months, 4 weeks ago.

Viewing 23 posts - 1 through 23 (of 23 total)
  • 12. Dezember 2021 at 20:17 #51842

    I have a new Raspberry Pi 4 B with 4 GB. It replaces another Rpi, 3 B, that failed by becoming intermittent. I have yet another 3 B that is working.

    On this Rpi, when I set the path in Media Folders to /media/usb, the scan finishes fast, having found nothing. Yet the LED on the thumb drive blinks, meaning it is connected. This thumb drive works in my other Rpi. I have also tried another thumb drive that works in another mp3 player.

    I am using the latest „buster“ image. I have clicked on „Upgrade Kernel“. I have powered down and powered up. I have rebooted. I have erased and reloaded my SD card, and reset all the parameters. I am using a high current power supply.

    The „Scanned Log File“ has a colored entry:
    [21-12-12 09:53:48.4755] Slim::Schema::forceCommit (2143) Warning: Trying to commit transactions before DB is initialized!

    I cannot find any way to initialize DB (database?). How can I make this player operate?

    14. Dezember 2021 at 15:08 #51844

    Hi Joe,

    Please check if your usb drive is displayed in the „Filesystem/Mount“ tab and if you can save the path there. If this works, scan the path to which the stick was mounted to again.

    17. Dezember 2021 at 1:34 #51850

    Hello again.

    My „Filesystem Mount“ tab does not show my USB drive. And I am not confident I know how to „save the path there.“ I typed:
    „USB thumb drive“ /media/usb <blank> no 666
    …into the „add“ boxes and clicked „Save.“ The response was:

    Sambashare successfully added
    Samba Service restarted

    But when I try to scan for music using the path /media/usb, I still get no files found.

    Please also note: I have shown that I get this same misbehavior with my Rpi 3 B using the „buster“ image. It works fine with the „stretch“ image. I have also shown that I can run Volumio successfully on the Rpi 4 B, with the same thumb drive. I am not sure, but I think I recall trying the stretch image on the 4 B without success; this is not recommended anyhow.

    I would think that this means that the buster image v253 is not meeting customer needs; it certainly does not work for me.

    21. Dezember 2021 at 15:31 #51859

    Please post your debug info here (which you will find at the bottom of the „Filesystem/Mount“ page) when you have connected the drive. Is the USB drive listed there?
    If the stick is recognised, it should be displayed under „External Drives on Max2Play – mountpoints for USB-Storage“. There you should also be able to save the path to the USB drive. It should then appear at the top of the page as a mountpoint.

    21. Dezember 2021 at 21:15 #51860

    When you say, „when you have connected the drive,“ I interpret that you mean when the thumb drive is plugged in, which it is. The USB drive is not listed on the „Filesystem Mount“ page. There is nothing displayed under „External Drives on Max2Play.“

    The „DEBUG Info“ at the bottom of the „Filesystem Mount“ page is:

    #### blkid ####
    /dev/mmcblk0p1: LABEL_FATBOOT=“boot“ LABEL=“boot“ UUID=“B6BB-0F0E“ TYPE=“vfat“ PARTUUID=“0634f60c-01″
    /dev/mmcblk0p2: LABEL=“rootfs“ UUID=“638417fb-7220-47b1-883c-e6fee02f51ac“ TYPE=“ext4″ PARTUUID=“0634f60c-02″
    /dev/sda1: UUID=“982A-618C“ TYPE=“vfat“
    /dev/mmcblk0: PTUUID=“0634f60c“ PTTYPE=“dos“
    /dev/mmcblk0p3: PARTUUID=“0634f60c-03″

    #### mounted ####

    3. Januar 2022 at 21:23 #51870

    Let me reiterate with minor new information.

    I have a Raspberry Pi 3 B with the stretch m2p image and it works. I have a Rpi 4 B with the buster 253 m2p image, and it cannot find my thumb drive, as explained above. This Rpi works correctly with Volumio and now also moOde.

    5. Januar 2022 at 12:30 #51883

    It may be that our buster image has a flaw here. I will test the whole thing again soon and discuss it with our developer. If it is due to our image, we will provide a fix as soon as possible.

    6. Januar 2022 at 3:59 #51891

    Thank you!

    I tried piCorePlayer about three years ago, as a substitute for max2play. I love their business model, and I like the way they distribute their use of memory. But I found it to fail and require a reboot four times in the 7 months I used it, while I got the first two years on max2play before the first instance of such a problem. So I am anxious to use max2play in both of my players. I am optimistic that you will fix the problem.

    (As you probably recognize, a reboot for a Raspberry Pi with non-volatile SD card is a lot of work! I now keep a „clone“ SD card, and have a documented process for how to start from scratch with a complete new download.)

    10. Januar 2022 at 15:32 #51912

    Hi Joe,

    I tested the whole thing again and initially encountered the same problem as you. With the Stretch Image and a Pi 3, there were no problems at all. It also found the external hard drive with the Buster image and a Pi 3. But with a Pi 4, the drive was not recognised.
    However, I have now discovered that in my case it was probably due to the power supply unit. I had used a USB-C cable, which didn’t seem to supply enough power to both the Pi 4 and the hard drive. With a different cable, the whole thing worked.
    Could the power supply possibly also be the reason in your case?

    10. Januar 2022 at 18:31 #51914

    Thank you, Mario. I am grateful for your experiments and observations.

    The interesting thing from the m2p perspective is that the apparent hardware problems are experienced by m2p software but not volumio nor moOde. And that the problems with power have such a narrowly observed misbehavior. I would bet that it is possible to code the m2p operating system so that this does not happen. I am not saying that would be necessary nor straightforward, though.

    The interesting thing from a Rpi perspective is that the cable makes a difference in your experience. In my configuration, I have a USB-C charger rated at 3 A, which is what the Rpi 4 B is said to require when allowing for extra current required by USB connections. My USB thumb drive does not have specifications on how much current it consumes. The HifiBerry Digi+ Pro that I am using is no longer produced, but the new Digi Pro is said to use a negligible amount of current, so I doubt that is part of the problem. I am suspicious that Rpi 4 B is not configured optimally for independence from cable parameters, where it could be. But this is only speculation.

    From my perspective: I have ordered a Raspberry Pi 4 B power supply, 3.5 A, for further experimentation. The experiments are pretty time-consuming, and even if I show that using a different cable fixes the problem, I doubt it has a comfortable margin. So I want to use a more complete fix of a new power supply with integrated cable and more power than is needed.

    I will let you know of the results. Thank you so much for replicating the problem.

    16. Januar 2022 at 17:47 #51933

    Sad to say, the problem was not resolved with a new power supply. The new power supply is designed for use with the Rpi. It is a CanaKit Raspberry Pi 4 Power Supply (USB-C). It is rated at 5.1V, 3.5A, with an integrated cable.

    I have tried rebooting and restarting Squeezelite and Squeezebox server. I have tried _v7.9.3 and _v8.2.0.

    If it helps understanding the problem, I can try piCorePlayer. As I said before, my experience with piCorePlayer on the Rpi 3 B was that it needed complete software rebuild about every two months, which is unacceptable for my long-term needs.

    In summary, I cannot get a Raspberry Pi 4 B to work with max2play with the only available image, Buster. The failure to work is due to the inability to find any music on a USB thumb drive. The same player and drive works with MoOde and Volumio.

    18. Januar 2022 at 14:34 #51936

    Hmm, that’s strange.
    Can you try to set the USB power supply to maximum in the Raspberry settings? (simply activate the checkbox and save)
    Do you have the possibility to test a hard disk that has its own power supply? (and once and for all exclude a power problem)
    Can you check if your files are displayed in the /dev/sda1 folder when you connect the hard disk?

    19. Januar 2022 at 2:46 #51942

    1. I had set the checkbox to „Max USB Current“ before my recent posting. It is still set that way. It does not change the symptoms.
    2. I have tried an externally powered USB hard disk. I have also tried another brand of USB thumb drive. Neither changes the symptoms.
    3. When I access the Webadministration, and click on the Basic Settings tab, and click on one of the Browse buttons, under /dev, there is no /sdal.

    Thank you for continuing to try with me. Thus far, the problem still looks to be with the buster image. Would it be of value for me to try a piCorePlayer image? If I get the problem with both piCorePlayer and m2p, and not with moOde nor volumio, that would imply a problem with LMS. If I get the problem with m2p but not piCorePlayer, that would imply a m2p problem.

    19. Januar 2022 at 14:46 #51949

    To narrow down the problem, you could of course try piCorePlayer. Nevertheless, I suspect the problem has to do with the Max2Play configuration. Because normally you should be able to mount your hard drive in the file system/mount plugin. In any case, this is not normal behaviour on the part of Max2Play, so it is of course in our interest to find a solution to the problem.

    Edit: Could you please check if your hard disk is formatted with „vfat“?

    • This reply was modified 10 months, 1 week ago by  MarioM.
    23. Januar 2022 at 19:26 #51961

    Hello again,

    I missed your „edit“ because I was not informed that it was there, and I had already read your message. I would recommend that you put in a new reply instead of an edit when communicating next time.

    I have some things to say. First: On my PC, under Properties, my external disk shows „File System: FAT32.“ I thought that was the recommended way to set it. Should I create a disk that is formatted as „vfat“ and test again?

    Second: I have not yet tried the piCorePlayer experiment, though I started to try. As I said, it is a lot of work. And I do not know whether I should try the 32- or the 64-bit version, or both. I understand from your previous message that whatever I learn from that experiment is very unlikely to be helpful for you. So I will not put high priority on this unless you encourage me to do that, and if you do, please recommend 32, 64, or both.

    Third: In studying about piCorePlayer, I came to learn that the 64-b version of piCorePlayer when running on the Rpi 4 does not support the USB fiq drivers. I have no idea what that means, but just in case it might be a hint for your debugging, I will pass that along.

    Thanks again.

    25. Januar 2022 at 12:56 #51982

    Dear Joe,

    We have now published a beta version of Max2Play 2.55 on our download page. This now also runs under a more up-to-date kernel. Please try to burn this image onto an SD card and try to connect and mount the hard disk with this image again.

    25. Januar 2022 at 19:35 #51987

    Thanks for the effort, Mario.

    I tried 2.55 and got the same behavior as I did with 2.53. Sorry!

    On the other topic, as I said, my externally powered hard drive was formatted as FAT32. I have checked and my thumb drives always are FAT32. I do not know how to make them VFAT. If that experiment is still of value, I will try to figure out how to format the external drive as VFAT. If you have any hints on how to do it, they would be appreciated.

    26. Januar 2022 at 14:09 #51991

    I have now tested mounting again with different formats. In fact, the problem of the hard disk not being recognised only occurred with FAT32. If you have the option to format the hard disk with exfat or ntfs, then it should work. Nevertheless, we will try to make FAT32 compatible as soon as possible.

    Do you use a Windows PC? If so, you can format the hard disk via the disk management. Note, however, that formatting deletes all data on the hard disk.

    26. Januar 2022 at 19:12 #51993

    Thanks for the efforts, again. The hint on formatting saved me a lot of time. I do use a Windows PC.

    I have created thumb drives with exFAT and NTFS formats. They both fail to be scanned by LMS in m2p on my Rpi4B with the beta buster image 255.

    27. Januar 2022 at 9:40 #51995

    Is the thumb drive at least now displayed below „External Drives on Max2Play – mountpoints for USB-Storage“? And can you save the mount point there? If so, you have to do that first. Afterwards, the drive should be accessible under /mnt/extdrive.

    27. Januar 2022 at 17:13 #51998

    Yes. That worked. Thank you. I can work with that until the Buster image is fixed, of course. I would like to avoid the complexity of incompatibility with the default FAT32 file system, and the extra step of mounting an external drive. But you know that and it is in your plans. So thanks again, I look forward to a new image.

    31. Januar 2022 at 15:29 #52012

    We have now revised the Buster Beta once again. Please try downloading it again and burning it to an SD card. With this new image, mounting a Fat32 formatted hard drive should now work.

    31. Januar 2022 at 21:39 #52016

    Yes, it now works. Thank you.

    If you can, please add another reply to this thread when a non-beta version is available.

Viewing 23 posts - 1 through 23 (of 23 total)

You must be logged in to reply to this topic.

Register here