License does not Activate on Second HiFiBerrt in Multi-Room Layout

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) License does not Activate on Second HiFiBerrt in Multi-Room Layout

This topic contains 7 replies, has 2 voices, and was last updated by  Heiner Moderator 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 11. September 2018 at 0:39 #37767

    Hello! My license does not show as activated in my second max2play setup for a multi-room setup. I am not sure if it is supposed to, so I thought I would ask.

    For my primary, under the Max2Play name, I use a Pi 3 and HiFiBerry DAC and dedicated speakers. For the second room, I use a Pi Zero and HiFiBerry DAC and dedicated speakers; however, I gave this room a unique name. Everything shows up and I can play music through Spotify on both rooms through the Logitech Media Server.

    My license shows up as activated under the Max2Play primary. However, under config for the Pi Zero setup, my license does not show up as activated even though I input my e-mail address through which I purchased my license.

    Do I need the license to show up as activated in the Pi Zero setup for other room and future rooms? It plays fine, but I am not sure if I will miss some functionality as I work with the system.

    Thank you and best regards.

    Mike

    11. September 2018 at 4:10 #37768

    I apologize, but I have a follow-up question.

    I would like to be able to use the second system from a smartphone. Nothing came up on the smartphone when http://max2play was input in the address field of the chrome browser. However, when I went to my PC and entered http://max2play, and then retrieved the numerical address from the WiFi/LAN drop down menu for max2play (192.168.0.8), I was able to enter the numerical address into the smartphone browser and access max2play.

    I am unclear why the smartphone could not access max2play when http://max2play was input in the address field while the numerical addrress worked. Thank you for your help and best regards.

    Mike

    11. September 2018 at 10:54 #37790

    Hi Mike,

    Thanks for your detailed posts, I’ll try to answer all your questions:

    – Your license can be activated on all your Pi’s. Try removing the license, saving with a blank field, rebooting and re-entering the license. Make sure your device is connected to the internet in the Health Checker (green box to the right in Settings/Reboot).

    – Your player can work without the license since both HiFiBerry and Audioplayer are free plugins. You can check which ones need a premium license and which ones are free in our plugins overview webpage.

    – Activate network Look-Up on both your device to easily switch between the two. After activating, a little box will show up in the webinterface’s upper right corner, listing all the max2play devices in your network.

    – For access on your phone, make sure it is connected to the same network and add a slash at the end („max2play/“). Also, make sure your browser parses the url correctly and perhaps try a different one to rule it out as the source of error.

    11. September 2018 at 10:54 #37791

    Hi Mike,

    Thanks for your detailed posts, I’ll try to answer all your questions:

    – Your license can be activated on all your Pi’s. Try removing the license, saving with a blank field, rebooting and re-entering the license. Make sure your device is connected to the internet in the Health Checker (green box to the right in Settings/Reboot).

    – Your player can work without the license since both HiFiBerry and Audioplayer are free plugins. You can check which ones need a premium license and which ones are free in our plugins overview webpage.

    – Activate network Look-Up on both your device to easily switch between the two. After activating, a little box will show up in the webinterface’s upper right corner, listing all the max2play devices in your network.

    – For access on your phone, make sure it is connected to the same network and add a slash at the end („max2play/“). Also, make sure your browser parses the url correctly and perhaps try a different one to rule it out as the source of error.

    11. September 2018 at 16:10 #37803

    Thank you!

    The license activated. I first saved settings/reboot as a blank field and then saved it after typing in the e-mail address again. The license became active. Thank you

    The IP addresses show up in the right corner of the interface. (I have had network look-up checked from the start for both Raspberrys). The drop down menu shows the numerical IP address rather than the name of each device. I presume that these internal IP addresses are static and will not change? If so, it does not matter if the SmartPhone cannot connect to the name I’ve assigned to the second Rasperberry Pi system since it can connect directly to the IP address input into the search engine address bar.

    I’ll try the Smartphone suggestion using the name of the second device tonight when my wife returns from work since it is her access that I am setting up.

    Thank you again and best regards.

    Mike

    11. September 2018 at 17:00 #37805

    Hi Mike,

    Usually, the device name should show up next to its IP address in brackets. Please make sure you have the current version of Max2Play and try renaming your device once more to see if your router can parse its name then. Our WiFi IPs are not static but they should not change unless your router re-assigns them.

    12. September 2018 at 16:26 #37820

    Hello! After trying various approaches discussed, the devices names do not show up in the right upper corner – just the internal IP addresses.

    Neither does the smartphone recognize max2play by name – either with or without the ending backslash (http://max2play/). I need to input the actual internal network IP address and then the smartphone accesses it.

    This is not a problem, and I’ll keep an eye on it in case the internal IP address is changed. It just means that I’ll have to look up the address when guests might want to access the system from their smartphone since I won’t remember the internal IP address. Best regards.

    Mike

    13. September 2018 at 9:36 #37822

    For guests you can also activate the DLNA interface plugin for LMS and see if the device shows up on DLNA apps.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here