Larger SD-card: Cannot expand filesystem

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Larger SD-card: Cannot expand filesystem

Tagged: 

This topic contains 1 reply, has 1 voice, and was last updated by  sugarcube premium 5 months, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 6. Mai 2020 at 16:20 #48719

    I have taken an image of the SDcard of one of my Raspis and copied it to another SD-card, which is 32Gig instead of 8GB. I need more space on the disk as i want to copy my Kodi database to the card an as it is rather huge, 8GB are not enough.

    When I run the image it boots fine, but it will not allow to expand the filesystem to suit the new size.
    It always claims: Expandiere Dateisystem: mmcblk0p3
    Dateisystem bereits expandiert – nichts zu tun! (Basically meaning: Expanding..already done, nothing to do.)

    I tried several ideas so far:
    — Just click the expand button in GUI (won’t expand)
    — enlarge the file-system with gparted by copying the data on sdd3 to a different location using dd (won’t boot)
    — reset the configuration (won’t expand)
    — download a fresh image (m2p_stretch_rpi_v249.img) which does not work at all for me. It stops booting after setting up the networking.

    I am running out of ideas now. Can s.o. please advise.

    Thanks in advance

    System: Raspi 3B+ with HiFiBerry AMP2

    7. Mai 2020 at 19:08 #48735

    Ok, I solved it myself. Here’s how (as documentation for others):

    1. I burned a fresh image on the 32GB SD-card
    2. I used another raspi w/o AMP2 card to boot this image.
    3. This raspi booted fine and expanded the image to use the full disk space.
    4. I set up the WiFi connection using the AMP-less raspi as the other always stopped when setting up networking
    5. I booted the image with the original raspi and so got it working again.

    Unsure, as to why the Raspi would not boot with AMP2 attached, but as problem is solved I will not ask any questions now.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here