lan/wlan/dhcp trouble

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI lan/wlan/dhcp trouble

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner Moderator 7 months, 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 24. Januar 2018 at 19:23 #33629

    Hi all,
    using my rp3 with the tailored image for rp+7“ display I cannot connect to my logitech media server.

    The raspi is connected by lan to the fritzbox (via powerlan, if this is important here).
    Also, I configured the wlan (as provided by the fritzbox).

    + So, I can ssh to the raspi using the lan connection as well as the wlan connection (selected using the corresponding IP).
    + I can ping the raspi, being on the raspi I can ping back to my host pc.
    – I cannot ping the logitech media server (normally named hape). Even more, the name hape is not displayed any longer in the network list of the fritzbox. Instead „squeezebox/max2play“ is displayed there. Looks like dhcp disturbance, but I found no dhcp server running on the raspi.
    – I tried stating the IP of hape in /etc/networks of the raspi, no success.
    – the raspi does not start up using wlan only, at least there is nothing to connect to with name max2play. DHCP not updated properly? the DHCP server is provided by fritz btw.
    – route states
    ernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    default fritz.box 0.0.0.0 UG 0 0 0 wlan0
    default fritz.box 0.0.0.0 UG 202 0 0 eth0
    default fritz.box 0.0.0.0 UG 303 0 0 wlan0
    192.168.178.0 * 255.255.255.0 U 0 0 0 wlan0
    192.168.178.0 * 255.255.255.0 U 202 0 0 eth0
    192.168.178.0 * 255.255.255.0 U 303 0 0 wlan0
    does this makes sense?

    Any hint is appreciated
    Jan-Mark

    24. Januar 2018 at 23:39 #33634

    The scary part: after leaving the raspi as it is and trying again I am able to ping the music server.
    Connecting to it via jive was not possible.
    However, starting max2play in the server front end (with only one instance of max2play) was possible.
    Nicely enough I have got to max2play players provided in the jive display…
    confused,
    Jan-Mark

    26. Januar 2018 at 17:03 #33679

    Hi Jan-Mark,

    If possible, please back up your current image and try a fresh one with our 2.44 universal .img file and install the RPi-Display plugin manually to rule out an error with the 7inch display image.

    26. Januar 2018 at 17:03 #33680

    Hi Jan-Mark,

    If possible, please back up your current image and try a fresh one with our 2.44 universal .img file and install the RPi-Display plugin manually to rule out an error with the 7inch display image.

    28. Januar 2018 at 0:15 #33700

    Hi Heiner,
    I tried the 2.44 image already before and have an card available with it.
    – the 2.44 image turns the screen upside down…
    – network wise both appear in the fritzbox list using wifi only, but cannot connect to hape.
    – using a lan connection, on the 7 inch image I can ping the music server, but the squeezeplayer does not work and remains unvisible to the server (e.g. the logitech server page’s player list). For the 2.44 image I even cannot ping the music server.

    Best Jan-Mark

    29. Januar 2018 at 17:15 #33735

    – There’s an option to turn the screen in the RPi-Display plugin
    – Try disabling WiFi completely to rule it out as a source of error. (Remove tick at „Load WiFi Interface“ and add tick in Raspberry Settings „Disable Default wiFi“)
    – Try running the LMS on the RPi3 itself for test to rule out a more general error

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here